1

I'm trying to use the CentOS-8-x86_64-1905-dvd1.iso as the http source for my PXE/kickstart install.

I'm struggling to understand why the installer is looking of squashfs.img and a directory named LiveOS, neither of which exist in the above iso image.

Should I be using the CentOS-8-x86_64-1905-boot.iso instead? I followed https://docs.centos.org/en-US/8-docs/advanced-install/assembly_preparing-for-a-network-install but there was no mention made of which iso to use.

1
  • docs.centos.org/en-US/8-docs/advanced-install/… does not do us any favors. It says to use " cp -r" to copy the contents of the ISO to disk. cp -r will not copy some critical dot files. For example, .treeinfo (in the root of the ISO)will not be copied, and without this file the install will fail. – mr.zog Dec 18 '19 at 2:02
2

If you've gotten that message, then you are probably attempting to install CentOS 8 with a CentOS 7 initrd.img and vmlinuz. You have to change the initrd.img and vmlinuz that you point to in your APPEND and KERNEL line in your tftpboot file. Here's an example of a working file.

default menu.c32
prompt 0
timeout 30
MENU TITLE PXE Boot install for my server
LABEL Centos 8.2
  MENU LABEL Install Centos 8.2 via Kickstart
  KERNEL /images/CentOS-8.2.2004/vmlinuz
  APPEND initrd=/images/CentOS-8.2.2004/initrd.img ks=ftp://ftp.server.org/pub/kickstart_file_name.cfg

This page will tell you where to find those files in your CentOS 8 iso:

https://docs.centos.org/en-US/8-docs/advanced-install/assembly_preparing-for-a-network-install/

-2

The CentOS document https://docs.centos.org/en-US/8-docs/advanced-install/assembly_creating-installation-sources-for-kickstart-installations/ is wrong. You are better off using rsync to copy the ISO's contents. See my comment above for details.

3
  • Please provide the whole answer and not reference comments on the question. Be sure to include succinct steps that other can follow. E.g. rsync /mnt/cdrom /data/export/ – Alastair McCormack Dec 18 '19 at 2:41
  • You forgot -av . – mr.zog Dec 18 '19 at 3:25
  • What works reliably is to mount the ISO on a directory that is shared on the network i.e. /var/www/html/{somedir}. I suppose we will eventually set up a local yum mirror. – mr.zog Dec 18 '19 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.