3

I'm trying to forward incoming web traffic to a Plone server on my Ubuntu set-up using the following rules (based on 'Installing Plone with Apache'):

<VirtualHost *:80>
 ServerAlias www.mydomain.com

 ProxyRequests Off
 <Proxy *>
   Order deny,allow
   Allow from all
 </Proxy>
  ProxyPreserveHost On
  ProxyPass / http://localhost:7373/VirtualHostBase/http/mydomain.com:80/plonesite/VirtualHostRoot/
  ProxyPassReverse / http://localhost:7373/VirtualHostBase/http/mydomain.com:80/plonesite/VirtualHostRoot/
  #ProxyPass / http://localhost:7373/ukpa/
  #ProxyPassReverse / http://localhost:7373/ukpa/
</VirtualHost>

Both variations, however produce and Internal Server Error, that shows in the log as:

[warn] proxy: No protocol handler was valid for the URL /. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.

I can browse locally to the site, via lynx, using the address http://localhost:7373/ukpa/ (hence the commented out attempts to simply forward to that at the bottom).

Where am I going wrong?

5

You might try:

# cd /etc/apache2/mods-enabled/
# ln -s ../mods-available/proxy.load
# ln -s ../mods-available/proxy_http.load
  • You'll need to restart apache after doing this step. – mfarver Jan 5 '10 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.