3

I am trying to create a maintenance plan that will run automatically and back up my SQL Server 2005 databases automatically. I create a new maintenance plan and add a "Back Up Database Task", select all User databases, and choose a path to back up to.

IMAGE in http://www.freeimagehosting.net/uploads/16be7dce43.jpg [new user limitation]

When I save and try to execute this plan, I get the following error message:

===================================
Execution failed. See the maintenance plan and SQL Server Agent job history logs for details.
===================================
Job 'Backup.Subplan_1' failed. (SqlManagerUI)

I've checked the maintenance plan log, the agent log, and just about every log file I can find and there are no entries at all to help me figure out why this is failing.

If I right-click on a specific database and select "Back Up", the task succeeds. I tried changing the plan to back up just that one database and it still failed.

I've tried running the plan with both Windows authentication and SQL Server authentication with the sa account. I also tried specifically granting the SQL Server Agent user account full privileges on the backup folder, but it still failed.

Thanks for any suggestions!

migrated from stackoverflow.com Jan 5 '10 at 16:44

This question came from our site for professional and enthusiast programmers.

3

Check you SQL version, if SQL 2005 then you need to have SP2 for this to work w/o Integration Services. SQL 2008 requires Integration Services regardless.

Look in the default log directory for the text output of the maintenance plan log which should give you a better error than the SQL Agent: c:\program files\microsoft sql server\mssql\mssql.1\log

If not a local administrator on the machine, make sure your service account has full permissions on that backup directory

0

Try backing up just the one to start with, rather than selecting "all user databases". Also, do you have any databases marked as "offline"? This prevents our maintenance plans from completing.

0

Look in the application log and SQL Server Agent log if you haven't already. Also, turn on the reporting options in the maintenance plan properties if they're not already on, and check the log directory (as mentioned above) for a more detailed error.

If you can at least get an error code, look it up with "net helpmsg" or another method. Once you find the actual error that is happening, this should be pretty easy to fix.

0

I was having the same problem. Looking at the Agent log gave me more clues. (The agent log is not the same as the log file specified during creation of the Maintenance plan). In my case it contained a warning:

SQLServer Error: 15404, Could not obtain information about Windows NT group/user 'xxx\xxxxx', error code 0x54b. [SQLSTATE 42000] (ConnIsLoginSysAdmin)

This led me to the folowing post. In short, in SSMS, go to SQL Server Agent -> Jobs -> Backup.Subplan_1 -> Properties and set the Owner to a non-domain user; I use sa.

  • Wouter you rock! I'm no DBA by any measure.. but have to do some SQL stuff here and there. While Veeam usually handles this I needed a "real" from SQL backup for something and was pulling my HAIR out about this. I was using a restored backup copy of the real SQL server at our DR site on a "test" VLAN with no access to a domain controller so I assume that's why the task was failing while trying to use my credentials. Changed to SA and BOOM! I'm the man! err.. at least that's the story. – Jack Hanna Jan 29 at 19:02
  • Glad this helped you! It is recomended to upvote answers that helped you on StackExchange. This way other users can find helpful answers faster, and users get rewarded with sweet sweet karma points :) – Wouter Jan 30 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy