0

I have server in OVH. I buy 13 IP blocks, added to server but ip not working.

My step: I added new IP block 151.80.170.164/30 to my /etc/systemd/network/50-default.network, i added this line

[Address]
Address=151.80.170.164/30

In DirectAdmin i added ip from this block:

151.80.170.165
151.80.170.166

beacuse my block have 4 IP. I set netmask to 255.255.255.252, assign IP from block 151.80.170.165 to domain tr-bahis.com and restart server. Domain still not working. In domain provider i set record A to 151.80.170.165, 2 weeks ago.

When I ping an IP outside the server, then I get no response, while when I ping while logged in, I get a reply after a while.

I used this tutorial https://docs.ovh.com/gb/en/dedicated/network-ipaliasing/#debian-9-ubuntu-1704-fedora-26-and-arch-linux_1 beacuse i have Debian 9 on my server. I contacted OVH support on this issue and they said that it should work and that their help ended.

My /etc/systemd/network/50-default.network:

# This file sets the IP configuration of the primary (public) network device.
# You can also see this as "OSI Layer 3" config.
# It was created by the OVH installer, please be careful with modifications.
# Documentation: man systemd.network or https://www.freedesktop.org/software/systemd/man/systemd.network.html

[Match]
MACAddress=a4:bf:01:24:fe:c3

[Network]
Description=network interface on public network, with default route
DHCP=no
Address=51.38.52.235/24
Gateway=51.38.52.254
IPv6AcceptRA=no
NTP=ntp.ovh.net
DNS=127.0.0.1
DNS=213.186.33.99
DNS=2001:41d0:3:163::1
Gateway=2001:41d0:0403:16ff:ff:ff:ff:ff

[Address]
Address=2001:41d0:0403:16eb::/64

[Address]
Address=151.80.170.164/32
Label=failover1

[Route]
Destination=2001:41d0:0403:16ff:ff:ff:ff:ff
Scope=link

systemctl status systemd-networkd output

pawel@51:/etc/systemd/network# systemctl status systemd-networkd
● systemd-networkd.service - Network Service
   Loaded: loaded (/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-12-27 17:27:06 UTC; 2s ago
     Docs: man:systemd-networkd.service(8)
 Main PID: 14590 (systemd-network)
   Status: "Processing requests..."
   CGroup: /system.slice/systemd-networkd.service
           └─14590 /lib/systemd/systemd-networkd

Dec 27 17:27:06 51.38.52.235 systemd[1]: Starting Network Service...
Dec 27 17:27:06 51.38.52.235 systemd-networkd[14590]: eno1: Gained IPv6LL
Dec 27 17:27:06 51.38.52.235 systemd-networkd[14590]: Enumeration completed
Dec 27 17:27:06 51.38.52.235 systemd[1]: Started Network Service.
Dec 27 17:27:06 51.38.52.235 systemd-networkd[14590]: eno1: Configured

I tried to find out in several places what I should do to make it work, but unfortunately the only answer was to completely reinstall the system for something other than debian 9, but for me it's no solution.

Does anyone have a better idea why it doesn't work? :(

Command result

ifconfig

pawel@51:/home/pawel# ifconfig
eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 51.38.52.235  netmask 255.255.255.0  broadcast 51.38.52.255
        inet6 fe80::a6bf:1ff:fe24:fec3  prefixlen 64  scopeid 0x20<link>
        inet6 2001:41d0:403:16eb::  prefixlen 64  scopeid 0x0<global>
        ether a4:bf:01:24:fe:c3  txqueuelen 1000  (Ethernet)
        RX packets 8275014  bytes 575280957 (548.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 344641  bytes 81811319 (78.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xa2b00000-a2bfffff

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 12428  bytes 8113671 (7.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 12428  bytes 8113671 (7.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

ip -br link

pawel@51:/home/pawel# ip -br link
lo               UNKNOWN        00:00:00:00:00:00 <LOOPBACK,UP,LOWER_UP>
dummy0           DOWN           fa:ae:bb:5a:8f:02 <BROADCAST,NOARP>
ifb0             DOWN           fe:a4:b1:ef:80:de <BROADCAST,NOARP>
ifb1             DOWN           2a:f1:09:b9:fa:34 <BROADCAST,NOARP>
eno1             UP             a4:bf:01:24:fe:c3 <BROADCAST,MULTICAST,UP,LOWER_UP>
eno2             DOWN           a4:bf:01:24:fe:c4 <BROADCAST,MULTICAST>
teql0            DOWN           <NOARP>
tunl0@NONE       DOWN           0.0.0.0 <NOARP>
gre0@NONE        DOWN           0.0.0.0 <NOARP>
gretap0@NONE     DOWN           00:00:00:00:00:00 <BROADCAST,MULTICAST>
erspan0@NONE     DOWN           00:00:00:00:00:00 <BROADCAST,MULTICAST>
sit0@NONE        DOWN           0.0.0.0 <NOARP>
ip6tnl0@NONE     DOWN           :: <NOARP>

ip -br address

pawel@51:/home/pawel# ip -br address
lo               UNKNOWN        127.0.0.1/8 ::1/128
dummy0           DOWN
ifb0             DOWN
ifb1             DOWN
eno1             UP             51.38.52.235/24 151.80.170.164/30 2001:41d0:403:16eb::/64 fe80::a6bf:1ff:fe24:fec3/64
eno2             DOWN
teql0            DOWN
tunl0@NONE       DOWN
gre0@NONE        DOWN
gretap0@NONE     DOWN
erspan0@NONE     DOWN
sit0@NONE        DOWN
ip6tnl0@NONE     DOWN

ip route

pawel@51:/home/pawel# ip route
default via 51.38.52.254 dev eno1 proto static
51.38.52.0/24 dev eno1 proto kernel scope link src 51.38.52.235
151.80.170.164/30 dev eno1 proto kernel scope link src 151.80.170.164
  • @A.B Hello i added command result to my post :) When i set /32 or /30 in network file still not working. I don't know what is wrong, and why ip block not working. From ovh i get ip block with /30 – PawelC Dec 29 '19 at 9:45
  • Well I don't know how to help you further. Maybe you should try with /32 rather than /30 and use .165 to test rather than .164 (test with only one IP until it works). Good luck. – A.B Dec 29 '19 at 19:42
  • @A.B Hi :) Now domain working but only when i use IP, when i use domain name not working. – PawelC Jan 2 '20 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.