5

I have an Azure App Service Plan shared by two App Services. For the first (www.rachel-lumsden.net) I have added an "App Service Managed Certificate". This has enabled secure requests to the site.

I've tried to configure the second app service (www.stratus-integration.com) in the same way but I get an error message that "Hostname not eligible".

Can anyone see where I've gone wrong please?

enter image description here

enter image description here

enter image description here

2 Answers 2

4

App Service Managed Certificates can only be used with URL's that are setup as DNS CNAME records. "www.stratus-integration.com" has been setup as an A record, not CNAME. You will need to delete the A record and create a CNAME record pointing to the app service DNS name.

8
  • Thanks for your answer Sam. My domain registrar is 123-reg.co.uk. I've updated so that it uses dns from cloudflare.com. Within the cloudflare control panel, I now have CNAME entries for www and stratus-integration.com pointing at stratus-integration.azurewebsites.net (I've added a screen grab into question to illustrate)
    – tr0users
    Dec 30, 2019 at 7:18
  • I'm afraid I still get the same error when attempting to add the Azure managed service certificate, perhaps I need to wait for the CNAME record to propagate?
    – tr0users
    Dec 30, 2019 at 7:25
  • 2
    The issue is because you are using cloudflare. Whilst you may have setup CName records in Cloudflare, because you are proxying them, Cloudflare is only presenting A records. You need to use non proxied records. mxtoolbox.com/…
    – Sam Cogan
    Jan 1, 2020 at 22:21
  • 1
    Thank you so much Sam. With your answer I was able to work around the problem by updating my domain (from the 123-reg.co.uk control panel) to point at the 123-reg dns servers. These had a cname record. When I returned to the Azure setup page I had a green tick, so was able to create a cert and add the ssl binding for the site.
    – tr0users
    Jan 2, 2020 at 19:19
  • 1
    I was having this same issue and, in case it helps anyone else, i just clicked the orange cloud next to the CNAME entry in cloudflare in order to make it grey and "dns only" and instantly the error went away and i was able to create a free "App Service Managed Certificate". Sep 5, 2020 at 12:15
1

To add. Whilst you may have a CNAME record, this will be flattened to an A-Record. For the validation to pass you must set Cloudflare only to flatten the root domain.

Flatten CName Records

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.