1

I've recently deployed Hyper-V into my hosting infrastructure and i'm trying to setup windows network load balancing and ARR so that i can have 2 VM web servers that are load balanced by 2 ARR servers running NLB.

I have the following setup:

2 Physical Host Machines IE; Host1, Host2

Then the following VM's are split 1 on each host for redundancy.

2 Hyper-V VM's ARR1, ARR2; both with NLB installed

2 Hyper-V VM's WEB1, WEB2

2 Hyper-V VM 's DC01, DC02 (Domain Controllers)

Note* I have all my Hyper-V VM's connected to the domain, but my host machines are not on the domain, not sure if this makes any difference

I've successfully installed NLB on both ARR1 & ARR2 and setup a cluster on a shared IP on ARR1.

Now i'm trying to connect ARR2 to that cluster but i'm getting an error message in the NLB GUI saying: Host Unreachable

I've tried disabling firewall on both the Hyper-V VM's and the host machines at the same time to see if that was the issue but even with all 4 machine's firewall off they are unable to connect to each other.

When i ping my DC01 from either ARR1 or ARR2 i get replies, when i ping ARR2 from ARR1 or vice versa i get Destination host unreachable. So i think there might be an issue with my virtual switch? All machines have static IP's configured on the NIC's

I'm running Windows server 2019 on all machines.

Any insights appreciated.

UPDATE

Thanks to @joeqwerty that got me past the first issue, however now i'm running into this error: The RPC Server is unavailable on the specified computer. From what I've read around it could be due in part because i only have 1 NIC on each VM and i need two? Or the Unicast/Multicast is incorrectly setup.

Any ideas?

Switching to Multicast seems to have corrected the issue and allowed me to connect both ARR1 and ARR2 together, after a restart they are both giving me the same issue than before. "The RPC Server is unavailable on the specified computer"

2

With NLB you need to enable MAC Address Spoofing on the virtual NIC of each NLB member.

enter image description here

2
  • now it's saying "The RCP server is unavailable on the specified computer." – UserSN Dec 30 '19 at 16:59
  • I followed all these steps excluding the registry edits and it's still the same error; drivereasy.com/knowledge/… – UserSN Dec 30 '19 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.