1

We are usually using ssh + keys to access our servers.

Recently I had to give a password to another person to enter into the login prompt in person at the client location, with monitor and keyboard and all. I wanted secure servers so I set all passwords to 50 random characters. Never actually tested that a normal person can enter them.

The problem is that shortly after you start entering the characters the password prompt resets. I'ts not that shortly, but its 50 characters...

Can I somehow get that timeout increased?

PS. I'm talking about this screen: enter image description here

3

This should be possible to set in /etc/login.defs with the value LOGIN_TIMEOUT.

http://man7.org/linux/man-pages/man5/login.defs.5.html

       LOGIN_TIMEOUT (number)
           Max time in seconds for login.
| improve this answer | |
  • This was what I wanted. Thank you. – Hristo Kolev Jan 6 at 9:18
  • Your welcome. Good to know it worked. :) – hargut Jan 6 at 9:19
-1

Change Login Grace Time . set 1 minutes or 5 mins as per your requirements

vi /etc/ssh/sshd_config
LoginGraceTime 1m 

if wants to disable login session during ssh login set

LoginGraceTime 0 

for more info - https://linux.die.net/man/5/sshd_config

| improve this answer | |
  • This is not about ssh. I'ts about the default login screen. Imagine you just installed a server and you have a keyboard and mouse and have to type in username and password. – Hristo Kolev Jan 6 at 7:56
  • you will type username and password in terminal. right ? grace time allow you more time to type username and password. – sanjayparmar Jan 6 at 8:33
  • 1
    Yes. Default terminal. Not ssh, not sudo prompt. Just a new installation and the screen that opens up. i.imgur.com/0Mpot50.png How do I change that grace time? – Hristo Kolev Jan 6 at 8:39
  • do you want increased time during installation ? if you have multiple servers, you can write ansible/chef to change in config. – sanjayparmar Jan 6 at 8:42
  • Just tell me how to do it after installation. I can do the rest. – Hristo Kolev Jan 6 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.