1

I have a server with x36 3TB installed, all are assigned to a single Storage Pool with x3 virtual drives.

I've discovered that x2 physical drives have failed and the Operational status says Lost Communication. This unfortunately has gone unnoticed for some time, however I still have a relatively functional system, for now.

In order to resolve this issue I initially tried the Reset Disk option, to no avail.

I then tried Remove Disk, this also failed.

My next step was to pull out and replace just one of the failed drives with an identical part. The new drive was listed in the Primordial Pool so I added it to Pool01 and set it to Automatic in the hope something positive would happen, but nothing did.

I've noticed that when looking at the Physical Disks window, the x2 failed drives and the new one don't display info in the Chassis field, all the working drives however display the enclosure and slot number.

For my next step I'm looking at using PowerShell to retire the disks and remove them. I haven't attempted this method yet because the friendly names for the x2 failed drives are identical, PhysicalDisk-1.

I don't have a HotSpare to play with and now finding myself in a pickle trying to resolve this issue.

Any help would be most appreciated.

12
  • Remove a failed disk completely and try to use it as temporary storage if it's still good, then rebuild SS from start. – Overmind Jan 9 '20 at 13:23
  • I've tried the PowerShell command to remove the retired drives. This failed because it stated the disks are in use. – SteveD Jan 9 '20 at 13:45
  • Can you post some pics from disk management and outputs from diskpart ? Those could help. Did you try using Set-ClusterStorageSpacesDirectDisk to mark disks as reclaimable ? – Overmind Jan 10 '20 at 6:31
  • I have a couple of screenshots, but I don't have the option to upload them here. – SteveD Jan 10 '20 at 9:25
  • Put them on any free image hosting site. – Overmind Jan 10 '20 at 9:48
0

To resolve this I decided to add the second replacement drive. I subsequently ran a repair on the virtual drives.

After a couple of days repairing, I was able to remove the 2 failed drives that were still listed in the Pool. I couldn't do this previously, even though they were retired.

All warnings related to the Pool have gone, however there appears to be a bad block on a different drive.

0

Although you seem to have resolved your issue, this one may help others later if the come across this question:

To remove a failed disk from a pool it has to be replaced first. A documentation I was able to dig up explains it in this order:

  1. Replace the bad drive physically with a new known good one
  2. Add the new drive to the pool
  3. Add the new drive to the virtual disk
  4. Let the virtual disk rebuild
  5. Now you're able to remove the failed disk from the recovered virtual disk
  6. As the failed drive is now free and no longer in use by any virtual disk it can be removed from the pool

It's basically the same just doing it on the PowerShell as the GUI version on a client OS: You have to add the new drive, let the volume rebuild, and then you're able to remove the failed one.

I guess this is caused by Microsoft doesn't really know about replacing a failed disk but rather expanding the pool and volume to the new drive and then reduce it from the failed one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.