0

I have an AWS instance (Ubuntu 18.04) on which I am deploying ejabberd xmpp server (v.19.09.1). I took the following steps.

  1. I disabled Ubuntu firewall (ufw) within the AWS instance since I already have the required security group in place. I enabled the following tcp ports in the inbound section of the AWS security group: 4369, 5222, 5223, 5269, and 5280 (all ejabberd ports). In the outbound section, I enabled all tcp ports from 0-65535.
  2. I also installed both Apache httpd and Redis servers on the same instance, and I also added the relevant ports (80, 443, 6379) to the inbound section. I am able to access these servers remotely (Web page for Apache2 and redis-cli in the case of Redis).
  3. I also configured ejabberd.yml file for my subdomain (im.mydomain.org), and I also set the domain's A record (im.mydomain.org) to point to the AWS instance's ip address. I also specified the admin users.
  4. I used ejabberdctl utility to add users successfully.
  5. I am also able to access the web interface at https://:5280/admin/server/im.mydomain.org/users/ No problems there.

Despite all this, I am unable to log in (registered_user@im.mydomain.org) to ejabberd using an xmpp client. (I use Pandion.) I also tried logging in with other clients like Pidgin, but no go. I just get the message "Disconnected from the server" or "unable to login."

Quite frustrated because ejabberd inexplicably will not allow users to log in via an xmpp client. Any help will be greatly appreciated.

  • Try Gajim, it's more updated than Pandion and more XMPP-compliant than Pidgin. When you try to login, what does ejabberd show in the log files? It's weird you cannot login using a Jabber client using the same account and password that already works when using the webadmin page... – Badlop Jan 10 at 11:32
  • Tried logging in with Gajim too. Still doesn't work. – Najeeb Jan 10 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.