0

I have a new server (Windows Server 2019) which I am trying to add to an old NLB cluster (It was set up on servers which previously did not consist of any servers newer than Windows Server 2003)

In NLB Manager on an existing member of the cluster I can load the cluster. If I try to add the new machine it tries for a while and then gives three log entries, one for each NIC of the new machine...

Could not read configuration of interface "{long guid}": error 0x8004100a

(one for each Network Card)

I have tried approaching this from the new server - I can load the cluster, and I can add this server to the cluster, but once I do, NLB Manager becomes unable to load the config from the other hosts. Specifically the last time I tried it I got host is misconfigured error for one of the other hosts (This is a host has been in the cluster without issue for years).

If I remove the new host from the cluster, and refresh the cluster, it loads the other hosts without issue.

I have quadruple-checked the network settings in the new server and can't find any conflicts.

None of the servers are domain joined, but that has never been an issue before (as long as either they all have identical username\password, or the username\password of a local account is specified when adding to NLB)

I have of course tried googling these errors without much luck.


Edit : I have now tried manually 'joining' the cluster by manually entering the cluster's IP addresses as extra IPs in the new server, then click the checkbox for 'Network Load Balancing' in the network properties screen. This seems to work, but if I open NLB Manager on one of the other servers it shows this host as unreachable, and I cannot ping it.

As soon as I reverse those manual changes I can then ping the server fine from one of the other servers.

It seems that attempting to join a cluster renders the server un-detectable by the other servers.

0

To answer my own question: It might not be possible to do this. I looked in the event log on the new server after some recent attempts and saw this....

An unsupported legacy host 3 was discovered on the network. The OS version on this host is no longer supported in a mixed cluster configuration. The cluster will remain in the converging state until all deprecated legacy hosts are removed. Please remove the desprecated hosts from the cluster.

So I may try to...

  • Disable the existing cluster
  • Set up a new cluster on the new host, consisting only of new servers. For now it will be a 'cluster' of one, until I install the second server due to be installed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.