I recently created a disk with a single xfs partition in ubuntu 9.04. I tried plugging it back in as a USB disk using an enclosure, and it shows up as /dev/sde. Unfortunately there is no /dev/sde1. cfdisk and other tools show that the partition is there, but the actual device file is not there, which means I cannot mount it.

What could cause this behavior, and how can I fix it? I tried running cfdisk, and re-writing the partition table, which just caused cfdisk to indefinitely hang.


Ick. You may have to manually recreate the device. I've had to do it a few times on older kernels that didn't correctly handle HP raid cards. The key to determining if the partition sees it is if it shows up in /proc/partitions. If it doesn't show up there, the kernel has no knowledge of it. As it is seeing /dev/sde, it should populate it.

/proc/partitions gives output like

major minor  #blocks  name

   8     0  312571224 sda
   8     1     530113 sda1
   8     2          1 sda2
   8     3   18346230 sda3
   8     5    3148708 sda5
   8     6   46074420 sda6
   8     7  126953631 sda7
   8     8  117507379 sda8

Which can be used with the mknod command to create an entry in /dev.

    mknod /dev/sda1 b 8 1

That would create /dev/sda1 on my system if udev didn't pick it up. You can then mount it from there. This is a good way to determine if the device is really correctly set up, or if there is a problem with the media in some way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.