0

Running ESXi 6.5U1. Trying to install OMSA from cli.

When I run:

esxcli software vib install -d "vmfs/volumes/datastore1/ISOs/OM-SrvAdmin-Dell-Web-9.1.0-3523.VIB-ESX60i_A00 (2).zip"

I have confirmed that the file "vmfs/volumes/datastore1/ISOs/OM-SrvAdmin-Dell-Web-9.1.0-3523.VIB-ESX60i_A00 (2).zip" does exist and that it has an index.xml inside.

I get the following result:

[MetadataDownloadError] Could not download from depot at zip:/var/log/vmware/vmfs/volumes/datastore1/ISOs/OM-SrvAdmin-Dell-Web-9.1.0-3523.VIB-ESX60i_A00 (2).zip?index.xml, skipping (('zip:/var/log/vmware/vmfs/volumes/datastore1/ISOs/OM-SrvAdmin-Dell-Web-9.1.0-3523.VIB-ESX60i_A00 (2).zip?index.xml', '', "Error extracting index.xml from /var/log/vmware/vmfs/volumes/datastore1/ISOs/OM-SrvAdmin-Dell-Web-9.1.0-3523.VIB-ESX60i_A00 (2).zip: [Errno 2] No such file or directory: '/var/log/vmware/vmfs/volumes/datastore1/ISOs/OM-SrvAdmin-Dell-Web-9.1.0-3523.VIB-ESX60i_A00 (2).zip'")) url = zip:/var/log/vmware/vmfs/volumes/datastore1/ISOs/OM-SrvAdmin-Dell-Web-9.1.0-3523.VIB-ESX60i_A00 (2).zip?index.xml

For some reason esxcli is prepending the "/var/log/vmware" in front of the zip location.

I did nook in the logs but am not sure which log would give me the right info. In any case I did not find any helpful info.

I am new to vib's. What am I doing wrong?

1

Use the absolute path to your zip file. It's even documented:

esxcli --server=server_name software sources vib list --depot=absolute_path_to_depot_zip_file

In your case:

esxcli software vib install -d "/vmfs/volumes/datastore1/ISOs/OM-SrvAdmin-Dell-Web-9.1.0-3523.VIB-ESX60i_A00 (2).zip"

Note the missing / at the start of your path.

1
  • I am such a dumb A**. Thank you. – Eric Snyder Jan 15 '20 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.