0

On Debian Buster I have installed the UFW Firewall

However, after enabling

$ ufw enable
Command may disrupt existing ssh connections. Proceed with operation (y|n)? y
Firewall is active and enabled on system startup

The Firewall is disabled after Reboot

$ ufw status
Status: inactive

The Config-File looks like this:

nano /etc/ufw/ufw.conf
ENABLED=yes

Help is very appreachiated!

0

You need to enable the service with a service manager.

sudo systemctl start ufw    # starts the service 
sudo systemctl enable ufw   # starts the service on boot
0

ufw enable should do the same. See the first Output:

Firewall is active and enabled on system startup

However, your suggestion:

$ sudo systemctl enable ufw
Synchronizing state of ufw.service with SysV service script with /lib/systemd/systemd- 
sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable ufw

Has no effect:

$ ufw status
Status: inactive

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.