So when I built my unmanaged webserver for my portfolio site jasonwarner.dev I had initially locked it down by disabling any login and the root account, completely because I was getting notifications about a couple hundred thousand root login attempts from an IP in china. I had a two different RSA keys, one for my windows machine, and the other on my linux distro that's dual booted on my macbook. Everything worked flawless and as expected. But of course, it just so happened that after experimenting with WINE on my linux machine I rendered myself incapable of logging into any account, and I don't have internet when I use recovery mode. I also had issues with a network adapter for my windows machine at the exact same time, and I thought it was the recent virus the NSA disclosed so I reset my windows machine. So even though my windows reset was supposed to save my files it only saved my raid array and wiped my C. So I recovered my .ssh folder from my linux machine onto a USB but when I tried to login to my webserver from MacOS or windows I am able to connect and enter my passphrase but then it gives me the same error:

debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic

Nothing I have tried has worked to resolve this, I'm assuming I am going to have to rebuild my server but if there's some miracle solution I would appreciate the time saved.

I would also appreciate an understanding as to why it's not working for me, I did not think RSA keys have anything to do with your computer, I thought you just need a RSA key to match a pub from the webserver

Thank you

result of RSA login attempt

  • When it prompted for your passphrase, are you sure you submitted the correct one? – cutrightjm Jan 20 at 3:51
  • @cutrightjm yes, I am sure because when I enter an invalid passphrase it prompts you to enter it again, and I wrote it down, and made sure my passphrase was the same for all my computers. I use hostwinds, and they have the option to generate new ssh keys but it is still giving me the same issue... – thuperman Jan 20 at 4:18

Rescue mode is definitely the solution for this problem.

There should always be some sort of safe boot for any linux distro and if you are renting a VM like me, they should have a system in place to use this feature of the linux OS.

In my case I use hostwinds and they have a rescue boot option, from there I was able to simply VNC into my server and use the username and password I had previously made and change my settings in my sshd_config.

Just wish I did this from the start

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.