-1

screenshot of the update history

It's a Windows Server 2012 (Build 9200). The machine restarts daily at 03:00 trying to install the pending updates, but the updates stay in the "Pending restart" state (see background window in the screenshot). Eventually, they fail with error code 80246013 (see foreground window in the screenshot).

Things I have tried (without success):

  • Windows Update Troubleshooter (WindowsUpdateDiagnostic.diagcab). Says that it fixed issues, but the problem persists.

  • DISM.exe /Online /Cleanup-image /Restorehealth followed by sfc /scannow.

  • Made sure the BITS, Cryptographic Service and Windows Update Service are running.

  • Manually reset the update store by renaming C:\Windows\SoftwareDistribution while wuauserv is stopped.

  • No, I don't have (and never had) any third-party anti-virus or security solution installed on the server.

I also tried manually downloading and installing the Servicing Stack update. It ends with the "Installation complete. You must restart your computer for the updates to take effect." window, but after the restart - you guessed it - it's still not installed.

I checked C:\Windows\Logs\CBS\CBS.log, but it contains ~30,000 entries for the last 10 minutes, those relating to the service stack update look OK (as far as I can tell), and I don't really know what to look for in there.

Is there anything else I can do?

1
  • @Downvoter: Feedback to improve the question is appreciated. – Heinzi May 4 at 5:53
0

Did DISM.exe or sfc /scannow report that it fixed anything?

How many updates is it trying to do? Trying to do only one at a time can be helpful, if it is trying to do a bunch.

Another basic thing: Check your disk space available on C: drive.

If serverfault allows me to link a place, you can post here to get some more advanced help. https://www.sysnative.com/forums/forums/windows-update.88/

2
  • Thanks for your feedback. (1) Yes, both reported that they fixed something. (2) Three. I've tried to do the Servicing Stack update alone by downloading it and installing it manually. (3) There's plenty of disk space available. – Heinzi Jan 28 '20 at 9:54
  • Just looking back at this. I actually experienced this this year. The server was an upgrade from 2008 and there might have been something buggy with the reserved/recovery partitions. We just did a re-image to server 2016. – rwt Nov 9 '20 at 23:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.