Questions tagged [3ware]

3ware are SATA and SAS RAID controller cards from LSI

Filter by
Sorted by
Tagged with
0 votes
0 answers
35 views

Error: (CLI:144) Invalid drive(s) specified when trying to add a removed unit (initial goal was migrate JBOD into single)

concerning the already asked question (Error: (CLI:144) Invalid drive(s) specified when trying to rebuild 3ware RAID) I have an similar issue at my server. My goal is to change the UnitType for all to ...
user avatar
0 votes
1 answer
57 views

Mysterious disk activity with 3ware controller?

I recently moved one of my servers into the same room I sit in and noticed something strange. Each morning for an hour or more there is a huge burst of disk activity. I am running a 3ware 9750-4i RAID ...
user avatar
  • 3
1 vote
1 answer
483 views

RAID-5 inoperable, but no disk failure

Inheritted a system with a 3ware LSI 9750-8i having five disks and RAID-5. I see a message about "RAID-5 INOPERABLE" for u1 but see no disk failure for the only disk (p1) in the unit. Unit ...
user avatar
-1 votes
1 answer
46 views

3ware: Is it possible to add a new drive to an existing raid5 set?

I would like to know if it's possible to add a new drive to a raid5 set with the purpose to expand the storage available in the set. 9550 controller For example to go from: 4x1TB drives to 5x1TB ...
user avatar
0 votes
2 answers
812 views

3ware 9550SX on CentOS8

I'm trying to use a 3ware 9550SX controller on CentOS 8. lspci shows the controller, but lsblk doesn't list the exported drives. I've exported 2 drives, each as single drives, no RAID mode being used. ...
user avatar
  • 103
1 vote
1 answer
184 views

3ware: Replace failed disk with Spare

I have a 3ware RAID controller running a RAID-10. I have a disk that currently has a SMART-FAILURE. I've ran a /c0 rescan and the Status will change to OK then back to SMART-FAILURE > /c0 show ...
user avatar
  • 585
1 vote
2 answers
124 views

Supress 3Ware warnings in syslog

I'm trying to suppress the following warnings in my syslog: Oct 13 04:43:33 Winston kernel: 3w-sas: scsi1: ERROR: (0x03:0x0101): Invalid command opcode:opcode=0x85. Oct 13 04:43:33 Winston kernel: md: ...
user avatar
  • 113
1 vote
0 answers
130 views

Saving a 3ware RAID configuration for later use?

I have a 3ware-based (using tw_cli) 24-bay array filled with 2 TB hard drives, used for backup. The plan is to upgrade them to substantially larger drives, but I would like to remove the 2 TB drives ...
user avatar
1 vote
1 answer
1k views

luks IO error while decrypting keyslot

I'm trying to use cryptsetup to encrypt some partitions, but getting the error IO error while decrypting keyslot. The command and output is: root@rescue ~ # cryptsetup --debug --verbose --cipher aes-...
user avatar
  • 121
0 votes
2 answers
1k views

Boot Drive Not Found

I just recently upgraded the coolers on my Supermicro server and now it can't find the default boot device unless I unplug ALL of the drives except the boot drive. This system is an older Supermicro ...
user avatar
  • 2,017
0 votes
1 answer
1k views

3ware 9550SX RAID-10, one degraded drive, rebuild and initialization stuck

Question: Is there a way to force this to rebuild? I'm also toying with the idea of turning the system off and attempting to rebuild it in the 3ware controller BIOS. If I turn this system off in ...
user avatar
  • 11
6 votes
1 answer
2k views

Dealing with CONFIG FAILURE on fresh drive (3ware / LSI RAID)

This is not about DRIVE failure. It's about drive CONFIG failure. I bought 3 brand new drives for my server, because existing ones have worked for over 4 years and one of them is failing (shows ECC ...
user avatar
  • 378
1 vote
1 answer
2k views

Error: (CLI:144) Invalid drive(s) specified when trying to rebuild 3ware RAID

We have a RAID 5 using a 3ware 9550SX RAID controller that shows one degraded disk. There is a spare drive configured for the array, but it wasn't used automatically as intended. The current array ...
user avatar
0 votes
1 answer
3k views

LSI iBBU07 troubleshoot: BBU not detected?

I have bought a used LSI iBBU07 for my LSI 3ware SAS 9750-8i RAID card. And now the card cannot detect the BBU even though I have seemingly installed it correctly. I would like to know that: Is ...
user avatar
-2 votes
1 answer
644 views

3ware 9650se not recognizing SAS drives, what else should I check? [closed]

The card works fine with SATA Raptors but can't see 2 different models of Cheetah. Drives are fine and have standard fw - visible with LSI 3081ER.
user avatar
0 votes
0 answers
915 views

The RAID array shows up as DEGRADED, but all drives are OK

The current RAID controller I am using is an AMCC 3ware 9690SA-8I SAS RAID Controller. I have just received this server unit used, and going into this blind; I have no idea how long it has been this ...
user avatar
  • 1,450
0 votes
1 answer
214 views

3ware 9650se raid6 replaced with larger drives

I'have been running a setup with 8 drives, each 2TB by now (raid6). I started to build up the setup with 1.5TB drives back few years ago and slowly added and replaced all drives to 2 TB. Now the last ...
user avatar
0 votes
0 answers
870 views

RAID-6: Two drives failure with 3ware 9650SE

We have a 6-drive RAID-6 on one of our servers. Each drive is a 750GB Seagate, and they are connected with Hardware RAID card 3ware 9650SE. We do not have sparse drives. The system is old and probably ...
user avatar
  • 1
0 votes
1 answer
265 views

Can I recreate a unit from a single drive RAID1 in a 3ware Raid controller?

I have a broken server and a broken disk on that same server on a RAID1 setup. I need to setup this same RAID unit, now on a new server, and from only 1 drive (since the other is broken). I moved ...
user avatar
  • 501
1 vote
0 answers
82 views

Enable external SAS on 3ware 9750-16i4e Card

I am adding an external SAS enclosure to a 3ware 9750-16i4e Card. Have connected 3ware 9750-16i4e Card to 2nd 3ware 9750-16i4e Card in exteranal SAS enclosure via a Norco 1M SFF8088 to SFF8088 Cable. ...
user avatar
1 vote
3 answers
697 views

Is there a way of relating the RAID units with the OS devices in 3ware?

I got a Linux server recently with a 3ware RAID. It has several volumes (/c4/u*/v*) that are seen by the OS as devices (/dev/sd*) I can roughly relate those units with the devices because of their ...
user avatar
  • 501
1 vote
1 answer
2k views

HW Raid controller error

On one of my old servers when i was randomly checking for system messages /var/log/messages in this Redhat case. I came across this message Mar 9 12:11:46 app-prod kernel: 3w-9xxx: scsi0: ERROR: (...
user avatar
1 vote
2 answers
686 views

3ware array limited to 6TB in linux

I have a server with a 9650SE-24M8 in it. which has a 7x2TB drive RAID5 array. tw-cli shows the following: Unit UnitType Status %RCmpl %V/I/M Stripe Size(GB) Cache AVrfy --------------...
user avatar
  • 41
0 votes
2 answers
2k views

How to recover from raid 5 failure of 2 disks with tw_cli?

I have hardware raid 5 of 12 disks, 2 of them died and the data is not accessible anymore. I was told that even though 2 disks died, some of the data might be recoverable. My hosting provider replaced ...
user avatar
  • 151
0 votes
1 answer
214 views

IO tasks easily starve eachother on 3Ware 9650SE

I have a server (Debian 6 LTS) with a 3Ware 9650 SE RAID controller. There are two arrays, one RAID1, one RAID6. It runs Xen 4.0, with about 18 DomUs. The problem is that I experience that IO tasks ...
user avatar
  • 7,771
5 votes
2 answers
7k views

How to identify failed drive/port on 3ware card

I have a 3ware 9650-SE controller with 2 drives in RAID-1 configuration. The drive on "port 1" has an error but the drive cages aren't labeled. I tried using the cli to "identify" the drive but tw_cli ...
user avatar
  • 3,434
0 votes
0 answers
1k views

Increasing the size of a 3ware 9650SE RAID5

These questions seemed similar, but they did not worK: Why is the 9650SE RAID1 not showing the full size of the disks? How can I increase the size of a RAID 1 array from 750GB to 1TB? 3ware Here is ...
user avatar
2 votes
1 answer
319 views

3ware 97504i - Disk mappings/UUIDs change on reboot

I have a 3ware 9750-4i with 36 drives running (4 in RAID 10, rest individual drives, i.e JBOD). When I reboot, all the drives except for the RAID 10 array, have their UUIDs changed on reboot (it ...
user avatar
  • 344
1 vote
1 answer
214 views

3ware 9500 stopped showing up in Linux

I was contacted by a client about this system that they're having trouble with. As the system boots, I can hit ALT + 3 to enter the 3ware bios and it shows the drives are available in an exportable ...
user avatar
4 votes
3 answers
7k views

3ware: Add a drive to a RAID unit

I have a 3ware RAID controller running a RAID-6. I manage the RAID via the tw_cli command line utility. So, one drive in the array failed, and I removed the faulty drive (p6) from the array, and ...
user avatar
  • 349
0 votes
1 answer
180 views

RAID controller shows 2 arrays using the same disks

We have a server with a 3ware RAID controller that went into read-only mode today due to an aborted ext4 journal. I checked the RAID status and found the following strange configuration: //host> /...
user avatar
0 votes
1 answer
839 views

3ware raid controller does not get a proper reset signal after a reboot

I have a linux server that has a 3ware controller 9650SE-4LPML connected. Today, I migrated this server with all its disks and raid controller to a new motherboard + cpu + ram (gpu is also changed). ...
user avatar
  • 538
1 vote
1 answer
112 views

First 500MB of RAID6 array is wiped, how to recover?

We have a RAID6 array with 12 disks on a 3ware 9650SE-12ML controller. An engineer of our server provider issued this command by mistake: sudo dd if=/dev/zero of=/dev/sde bs=1M count=500; sync; /dev/...
user avatar
  • 193
0 votes
1 answer
490 views

3ware controller hotswap Linux

I have a server with a 3ware 9650SE controller running Debian. The tw_cli utility shows this: Ctl Model (V)Ports Drives Units NotOpt RRate VRate BBU ---------------------------------...
user avatar
  • 11
0 votes
1 answer
231 views

Will 3ware controllers continue to rebuild when I reboot the computer?

I am using a 3ware 9690SA-8I controller and one drive in my raid 6 hick uped and now the raid is rebuilding. Meanwhile I noticed I have an unfortunate combination of stupid programs and I need to ...
user avatar
0 votes
1 answer
1k views

Change the Hard Drive in RAID using tw_cli while lustre file system is mounted

I've setup RAID-5 array disk, but recently one of the Hard drives is reallocating excessive sectors: (Reallocated Sectors = 323) # tw_cli /c0/p1 show all /c0/p1 Status = OK /c0/p1 Model = ...
user avatar
1 vote
2 answers
1k views

Move raid10 from LSI 9750-8i to 3ware 9650SE-8LPML

This is a little risky task I want to try. I have a 4 SATA III disks RAID10 array running on LSI (former 3ware) 9750-8i controller with BBU (read and write cache enabled). In case of hardware failure ...
user avatar
7 votes
1 answer
246 views

Disk size addressable by the OS

I have a 3ware 9550SXU-12 storage controller and 750G disks connected to it. The disks are configured as single units (not JBOD). I've been running some performance tests, mainly to see the impact of ...
user avatar
2 votes
1 answer
4k views

Unable to access 3ware 3dm2 web interface, failed to start listening socket

I am unable to get to the 3ware 3dm2 web interface. When I attempt to execute 3dm2 from the command line, i get the following error "(0x0C:0x0005): Failed to start listening socket". This was working ...
user avatar
1 vote
5 answers
5k views

Replacing 2 disks (raid 1) to a larger pair under a 3ware controller in linux

I have a 3ware 9650se with 2x 2TB disks in raid-1 topology. I recently replaced the disks with 2 larger (3TB) ones, one by one. The whole migration went smoothly. The problem I have now is, I don't ...
user avatar
  • 538
1 vote
1 answer
2k views

3ware card in RAID-5 configuration slow and causes load when writing

I have a 1Gb/s bandwidth between my computers. The source can actually read and send data at 25MB/s via SSH. My test file is 4GB, I use scp without compression for the test transfer. The rate is 25MB/...
user avatar
  • 217
1 vote
1 answer
1k views

3ware: Drive power on reset when trying to rebuild

I have a RAID bus controller: 3ware Inc 9550SX SATA-II RAID PCI-X with four disks, with the following current state: tw_cli> /c1 show Unit UnitType Status %RCmpl %V/I/M Stripe Size(...
user avatar
  • 217
0 votes
2 answers
3k views

3Ware 9500s Raid array not visible in Windows 7 x64 disk management - latest firmware and drivers

I bought a used 3Ware 9500s-4LP raid controller from Ebay (the old 3ware 8506-4lp didn't support RAID arrays over 2TB, but it was working), installed it in my server and attached it to the SATA ...
user avatar
  • 11
1 vote
0 answers
142 views

3ware 9500S-4LP raid-1 rebuild failed

After replacment of 2 failed drives on 3ware card i got this: Ctl Model (V)Ports Drives Units NotOpt RRate VRate BBU -----------------------------------------------------------------...
user avatar
  • 11
0 votes
1 answer
1k views

moving disks around on a 3ware raid controller , using tw_cli

I have a raid controller (9650SE-4LPML) I am unluckily in a rather crappy situation: Unit UnitType Status %RCmpl %V/I/M Stripe Size(GB) Cache AVrfy -------------------------------------...
user avatar
  • 538
1 vote
0 answers
268 views

three disks with ECC errors on 3ware raid in two weeks

I have a server I maintain for a client, It's an Intel Nehalem based computer, so not new, but in working order. It has a 3ware 9650SE-24M8 card with 20 drives attached and 4 empty slots, configured ...
user avatar
  • 11
2 votes
4 answers
3k views

LSI 3Ware tw_cli and tdm2 segfault with Debian Linux kernels after 3.8

I have notified LSI support, twice, but so far they are unable to reproduce the problem. I wanted to post here to get some unbiased expert thoughts about it and see if anyone else has seen a similar ...
user avatar
1 vote
3 answers
2k views

install xenserver 6.2 on 3ware 9750 raid5

I would like to install XenServer 6.2 (kernel 2.6.32) on a raid5 managed by a 3ware 9750 controller. The XenServer installer doesn't recognize the raid5 and i think i have to load a driver for the ...
user avatar
  • 262
2 votes
2 answers
2k views

RAID controller won't rebuild RAID-1 array

I have a RAID-1 array on a desktop computer. The RAID controller is a 3ware 7006-2. Recently the controller has been reporting ECC errors from one of the drives. It was able to correct all of those ...
user avatar
1 vote
1 answer
3k views

Does a 3ware "ECC-ERROR" matter on a JBOD when I have ZFS?

I have a FreeBSD 8.x machine running ZFS and with a 3ware 9690SA controller. The 3ware controller shows an ECC-ERROR with one of the disks: //host> /c0 show VPort Status Unit Size ...
user avatar