Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [alpn]

ALPN (Application Layer Protocol Negotiation) is an extension for TLS and negotiates which protocol should be handled over a secure connection.

0
votes
1answer
81 views

ALPN negotiation choosing http/1.1 over h2

I've created a DigitalOcean droplet with "LAMP 18.04" preset and did all updates. Configured a new virtual host and used certbot to configure HTTPS. So far everything was working fine. Then I tried to ...
3
votes
1answer
5k views

“server certificate verification OK” but “ALPN, server did not agree to a protocol”

I am making a curl call curl -v ... https://... and the verbose output contains .... * ALPN, offering http/1.1 * SSL connection using TLS1.2 / ECDHE_RSA_AES_128_GCM_SHA256 * server certificate ...
7
votes
1answer
7k views

What does ALPN, server did not agree to a protocol mean?

I see this quite regularly when using various calls in curl. I'm not sure if its the root cause to some of my returns resulting in error 400 but as a newbie just curious more than anything.
1
vote
0answers
143 views

Ubuntu 17.04 netty-tcnative ALPN not available for JDK SSL/TLS engine

I have a Java application (runnung under Oracle Java, but the same issue happens with OpenJDK) that uses netty-tcnative. It runs without issue on macOS, but when I try running it on Ubuntu 17.04 I get ...
0
votes
1answer
1k views

nginx ALPN with debian 9 (stretch)

I just upgraded to Debian 9 (stretch) but system seems to not support ALPN negociation (after running a HTTP2 test). All guides over the internet still refers to Jessie (Debian 8) but none talks about ...
1
vote
4answers
2k views

Why does HTTP/2 test say that I have ALPN support even if I only have OpenSSL1.0.1t?

This question is kind of related to this Why is ALPN not supported by my server? But in my case, the same test does say that ALPN is supported even if I am not using OpenSSL1.0.2 and only OpenSSL1.0....