Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [apache-2.4]

Version 2.4 of the Apache HTTPd Server. When asking questions about virtualhosts, please include the output of the following command: "apache2ctl -S" (or "httpd -S" depending on your OS)

0
votes
0answers
106 views

How do I do a correct reverse-proxy to a Redis instance?

I'm running an application called Ambar on a (Samba)fileserver. I want users in my network to be able to search for documents freely, and securely. Since Ambar runs on HTTP, and the server already has ...
0
votes
0answers
16 views

Kerberized WebDAV Folder Ownership/Permissions

I am running a CentOS file server bound to an IPA domain (IPA master is a different machine). I have successfully configured Apache with Kerberized WebDAV on the file server and I am able to login ...
0
votes
0answers
24 views

Apache 2.4: mod_proxy_http2 and Proxy balancer

I want to combine mode_proxy_http2 and Proxy balancer and I wonder if it's possible : Here is my current configuration : - one proxypass with a balancer - one proxypass without balancer I ...
-1
votes
1answer
47 views

Apache mod_perl Apache::Status Cross Site Scripting Vulnerability, CVE- 2009-0796 [duplicate]

During a scan on our server (PCI-DSS), we found Apache mod_perl Apache::Status Cross Site Scripting Vulnerability, CVE- 2009-0796. I did a lot of search on google and came up with no clear solution. ...
0
votes
0answers
44 views

SSL with Let's Encrypt, Apache and ProjectShield not working for WWW

I have a site behind ProjectShield, for www and bare domain. Without https, it is working for www and bare domain. Under https, is only working for the bare domain, not working for www, and that is ...
0
votes
1answer
121 views

ERR_SSL_PROTOCOL_ERROR after http2 enabled

I'm setting HTTP2 for my application and I get randomly ERR_SSL_PROTOCOL_ERROR on y browser. this is happening only on Google Chrome browser. Everything is OK on Firefox. I'm using Let's Encrypth ...
0
votes
0answers
14 views

Apache2.4 will load 5.7MB Allow from IP list, but not 5.7MB Require from IP list

Strange problem with loading Country Blocklists into an apache2 Virtual Host. Both files are 5.7MB but the first one loads quickly with no issues. I have not been able to successfully load the other....
0
votes
0answers
54 views

Let's Encrypt SSL on Google Cloud

I am utterly failing to find a working guide for installing Let's Encrypt certificates on a single Google Cloud virtual machine. I'm pretty clearly getting the picture that just doing the Apache ...
0
votes
0answers
27 views

Compress content (mod_deflate) with chunked transfer encoding in Apache

I have a Ubuntu LTS 18.04 vm with the suri repository installed (that provides the latest PHP 7.2 and Apache 2.4.38 packages). PHP is setup as FPM. The problem is while I have configured Apache to use ...
2
votes
0answers
40 views

mod_rewrite on Debian Stretch breaks php7.0-fpm with AH01071: Got error 'Primary script unknown\n'

We've just built a new Debian 9.8 server to replace our 8.11 server in order to test and upgrade to php7. We've installed apache2, php7.0-fpm and brought over out existing virtual host config, which ...
1
vote
0answers
379 views

Error log: “client denied by server configuration” but all works fine

Centos 7, Apache 2.4, php7, Virtualmin (testing server) I've read almost all suggested similar questions/answers but still don't realize why httpd log displays these errors despite I don't have ...
0
votes
0answers
36 views

Several GET / HTTP/1.0 in apache2 logs with 400 error

We have a Magento 1.X hosted on AWS EC2 with apache2. We have thousands of calls that we don't understand what they are. The calls are all GET with HTTP/1.0 (calling ip masked) x.y.z.87 - - [28 / ...
0
votes
0answers
15 views

Reverse Proxy in Apache 2.4.34 based on Browser Language ENU/FRA

I am using Apache for the first time and came across a below requirement I am having a requirement to implement a ReverseProxy in Apache based on the HTTP:Accept-Language, my application is hosting ...
2
votes
1answer
58 views

.htaccess RewriteRule not working

I have a windows environment using WAMP where this works fine. I am just setting up my Ubuntu desktop development environment, and this particular mod_rewrite is not working. It's pretty basic, but ...
2
votes
0answers
28 views

Failed to renew SSL certificates using Certbot's “dry-run” command

I was using apache for my website and created the SSL for Apache. Then for some reason, I have to change my server from Apache to Node.js. To do that I just copied the SSL certificates path from ...
1
vote
1answer
30 views

Apache rewrite/redirect issue

I have the below in my 000-default.conf file (Ubuntu and Apache 2.4.34) yet when I access either www.mydomain.us or mydomain.us I do not get redirected to the https page that does indeed work directly ...
1
vote
1answer
173 views

SElinux: allow httpd to connect to redis

I'm running on RedHat7, with apache 2.4 and redis installed. Apache won't connect to redis unless selinux issues are resolved. I know that one option to fix that is to allow all connections with: ...
0
votes
1answer
55 views

Set an Environment Variable in both Apache and System

I'd like to set an environment variable in both system and httpd. I set the variable, let's say IMPORTANT_FOLDER = /MY/PATH, in /etc/profile and it works for all system users. What i want to do is ...
0
votes
0answers
40 views

Apache mod_deflate doesn't work on new server

Apache mod_deflate doesn't work on new server OS Ubuntu 16.04.6 LTS, Amazon instance, Apache version 2.4.18 Apache modules: Loaded Modules: core_module (static) so_module (static) ...
0
votes
1answer
19 views

Configuring Apache to log referrer url

I'm trying to make Apache server log the referrer URL in all requests including 404 and 200 for example someone has embedded an image hosted on my websites on his own website. the image is loaded ...
0
votes
1answer
56 views

Apache2 RewriteRule does not work

I configured my apache2 like this before: <VirtualHost _default_:443> ... RewriteEngine on RewriteCond %{HTTPS} !=on RewriteRule "^/?(.*)" "https://%{SERVER_NAME}/$1" # ...
0
votes
1answer
76 views

apache2 redirect doesn't work

This is my configuration: <VirtualHost *:80> ServerName example.com Redirect / https://example.com/ ServerAdmin info@example.com ServerAlias www.example.com </VirtualHost> ...
0
votes
1answer
32 views

Zimbra behind a Apache Reverse Proxy

I mention my network architecture. My service provider has not made zone delegations to manage my DNS, and currently I only have one PTR record pointing to one of my servers which has a real IP on ...
0
votes
0answers
12 views

How to diagnose wamp services sporadically slowing down to a freeze?

I have a web application running on a wamp server (Windows Server 2008 R2 Service Pack1, Apache 2.4.4, PHP 5.4.12, MySQL is installed but an outside DB is used instead by the app) which suffers from ...
0
votes
0answers
11 views

Apache: handle compression for large static XML files

My site (hosted by Apache 2.4 on ubuntu 14.04) must provide some large XML files (more than 200Mb). I choose to compress them to speed up the download process (.tar.gz) but recently my users need the ...
0
votes
0answers
11 views

Non-terminating php-fcgi causing lack of memory

I am running a quite large WordPress multisite installation with apache2 and php-fcgi. We are executing php-fcgi via a wrapper script because some time ago, we needed to support different versions. I'...
1
vote
1answer
38 views

mod_perl seems to be sharing modules across user accounts

Please do ask if you need any more information. I'm just trying to work out what is going on. So I have a server with nginx as the front end, and then passing along to Apache (2.4.18). In my Apache ...
0
votes
2answers
53 views

oci_connect(): Error while trying to retrieve text for error ORA-28547

I have this connection string on an older server which works fine and connects to a remote oracle server. On this new server I installed oracle instant client simple and devel and php pecl oci8. ...
0
votes
1answer
232 views

Install and enable exif

I moved my website to a vps and I used exif function but look like in this new server exif not installed or enabled.. I tied many ways to enable it but no success: Information: Linux, Apache, ...
0
votes
1answer
47 views

Can't Write to Public Files but Permissions Appear Fine

Originally asked on Drupal Stack Exchange but opening up since it may be a general Linux/Apache issue. Need the internet to confirm my sanity. On a Drupal 7 site it's saying "The directory sites/...
0
votes
0answers
15 views

What does apache return when a GET comes in for a file that's in the process of being replaced?

I can't find the answer on google and this seems pretty difficult to test with certainty. So, I am really hoping that someone out there just knows what actually happens. What happens if a GET comes ...
1
vote
1answer
20 views

LAMPs w/Wordpress with 3 domains. Two work as expected. One redirects to one of the others

I have Mint 19.1; Apache 2.4; PHP 7.2; phpmyadmin, Wordpress 5.1.1 successfully installed and functioning. Site 1 Works as expected Site 2 Redirects to Site 1 without warning Site 3 Works as ...
0
votes
2answers
79 views

Disable health-check logging in AWS ELB Django Application

I have a Django application running on aws-elastic-beanstalk. I try to disable the logs caused by my health-checks. The health-checks are already routed to a seperate page. Elastic-beanstalk uses ...
1
vote
1answer
83 views

Apache mod_rewrite encode query string parameters

I have a URL coming into apache 2.4: http://localhost/index.html?q=asdf&b=a|c|e&c=4&d=dsjklkjhd I need mod_rewrite to URLencode the | so that I get: http://localhost/index.html?q=asdf&...
-2
votes
2answers
36 views

Unable to reach Apache website from NAT IP. Resolving to hostname

CentOS 7.x Apache (httpd) External NAT: 10.140.x.x Internal IP: 10.105.x.x When trying to reach the apache server on https://10.140.x.x, it tries to resolve the hostname in the lower left corner ...
0
votes
0answers
103 views

Apache allow HTTPS with Virtual Hosts

I am setting up an UBUNTU 18.04 environment with Apache, MySQL, PHPMyAdmin etc. I need to allow HTTPS connection for URL rewrites, currently HTTPS crash when I enter a 'pretty' URL HTTPS: If I ...
1
vote
1answer
79 views

Kerberos delegation with Apache, SSSD and FreeIPA

Let me start from describing my real goal, because I am not sure that I am trying to solve it in a proper way =) I am simply trying to make my web application obtain Kerberos credentials on behalf of ...
0
votes
2answers
50 views

Multiple domains on different servers with 1 nat rule

I am pretty new to this and cant get it figured out. I have 2 domains. 1 domain should go to 1 web-server, the other to a 2nd. 1 is on IIS and the other on Apache. on my router i can only make 1 NAT ...
0
votes
0answers
27 views

Why does mod_rewrite require FollowSymLinks or SymLinksIfOwnerMatch?

I would like to disable FollowSymLinks and SymLinksIfOwnerMatch options, but at the same time I do want to use mod_rewrite. I checked the source code of apache 2.4 and I found there is only a ...
0
votes
0answers
15 views

Apache mod_auth_form and SSO

Is it possible to set up SSO using the apache's mod_auth_form alone? By setting the domain of the cookie I can make it available on other servers, but the encryption seems to be different even with ...
0
votes
0answers
42 views

Squid Reverse Proxy From Local Subdomain To An IP:Port

my first real problem so I'll try to be brief and give enough details. I have a webmin on digitalocean which has squid integrated. When I use the lines below, it redirects all other domains to the ip ...
1
vote
1answer
73 views

Forbidden after enabling SSL

I recently used LetsEncrypt's Certbot to enable SSL on my server. It's running Apache 2.4.18 with Django 1.11 on Ubuntu 16.04. As explained here, I duplicated my :80 VirtualHost definition for 443 in ...
-1
votes
1answer
24 views

How to get rid of WWW from domain, and make it always redirect to https://example.com or https://foo.example.com

I'm using Apache2, and I'm still pretty new to it. The issue I'm having is my site, is causing infinite loops, and I also want to get rid of the WWW portion from my domains and subdomains. This is ...
2
votes
0answers
36 views

PHP-Script cannot create directories outside of web root [closed]

I have a strange issue with my drupal 8 installation on Ubuntu 18.4. The Drupal Webform-module is not able to create needed directories. Therefore file upload fails. The error occurs if I use the ...
0
votes
0answers
29 views

How to perform ADVANCED authentication duties with Apache

I'm building a system based on an architecture of micro-services. There is a degree of interoperability among the services in that one or more services rely on the capabilities of others. Clients are ...
0
votes
0answers
14 views

Apache, 20+ long running connections with little memory usage

I have a small server, 2 GB memory (an AWS t2.small) that I would like to run cron jobs on. These crons run by specific URLs getting hit (an AWS setup I can’t change), and take maybe 1 – 2 minutes ...
0
votes
0answers
135 views

Segmentation fault detected in apache error log

I have this problem on my Ubuntu Server: Problem Some time my sites are not reachable from the browser and I can see a "Time Out Error", however the server replies to PING requests. I checked the ...
0
votes
1answer
90 views

NGINX FastCGI Cache on NGINX > Apache > PHP-FPM

I had failed attempts earlier at getting Nginx Fast-CGI caching to work in Nginx > Apache > PHP-FPM config so I started fresh on a new server but am still having issues. The server has a clean ...
0
votes
0answers
94 views

AH02027: Failed to release SSL session cache lock

I got an error in /var/log/apache2/error.log. I use Magento 2. [Fri Mar 08 06:03:05.767587 2019] [ssl:warn] [pid 4144:tid 140469346477824] (22)Invalid argument: AH02026: Failed to acquire SSL ...
1
vote
0answers
45 views

Apache Webserver Config issues in Windows

I'm trying to configure an apache 2.4 webserver for data entry that will feed into a SQL server. I've got the individual processes up and running but I can't get the webform to load. I just get the ...