Questions tagged [aptitude]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
130 views

I want to update a debian package, but apt deletes packages that are needed

I can see that my xfce4-panel version didn't get upgraded to 4.16 (it's still 4.12) after upgrading debian from buster to bullseye. So I wrote sudo apt install xfce4-panel to try to upgrade xfce4-...
user avatar
0 votes
1 answer
27 views

How do I install newer openjdk-x-jre packages using apt and vanilla Debian?

My current environment is SMP Debian 4.19.132-1 When I try to run sudo apt search openjdk-14 nothing shows up when I run sudo apt search openjdk only 11 shows up. Per another question I tried adding ...
user avatar
  • 101
0 votes
1 answer
906 views

Did aptitude uninstall the gnome gui?

Recently I wanted to remove the keyboard-configuration app for linux, so I typed sudo apt-get remove keyboard-configuration it prompted me if I wanted to remove a bunch of packages (17 MB), and now ...
user avatar
4 votes
1 answer
2k views

Docker install on clean Debian 10.2 causes error with aufs-dkms package

After installing Docker 19.03 on a clean updated Debian 4.19.67 I am experiencing some problems with the aufs-dkms package that is a dependency. I even reinstalled the Debian server and tried all ...
user avatar
  • 361
0 votes
1 answer
282 views

Aptitude: list security updates

I'm trying to list and display some info about available security updates on Ubuntu server. I would use the following command, where ?archive(security) filters packages that contain security in their ...
user avatar
  • 1,017
1 vote
0 answers
505 views

apt-get reinstall requires removal of essential packages

I did a dist-upgrade from debian 8 to debian 9. Now I need to reinstall xserver-xorg-core. But in doing so, apt-get wants to remove 'init'. # apt-get install --reinstall xserver-xorg-core Reading ...
user avatar
  • 21
1 vote
0 answers
65 views

Unclear why aptitude marks package as broken

I have a situation where aptitude marks a package cgroup-bin as broken: $ aptitude search '^cgroup-bin$' pB cgroup-bin ... In its UI, aptitude provides the following explanation: Some dependencies ...
user avatar
  • 345
0 votes
1 answer
34 views

Install same programs/functionality across different linux systems

Is there a standard way to install the same programs across different linux systems in an automated way (a single script that would work on each system)? Most of my systems are Ubuntu and an Ubuntu-...
user avatar
  • 289
0 votes
1 answer
397 views

debian apt-get update fails on connecting to hwraid.le-vert.net

It is debian7 apt-get update 100% [Connecting to ftp.debian.org (2001:67c:2564:a119::148:12)] [Connecting to hwraid.le-vert.net (2001:bc8:357c::1)] AND NOTHING... No way to install new packages: ...
user avatar
  • 797
1 vote
0 answers
68 views

What is aptitude"upgrade" failing here while apt-get succeeds?

UPDATE: added why-not output as suggested (why output also). # aptitude why-not libwbclient0 Unable to find a reason to remove libwbclient0.` `why` gives this reasoning. # aptitude why ...
user avatar
  • 3,434
0 votes
1 answer
693 views

How can I host my public GPG key on S3?

I've been packaging some proprietary software that runs on Raspbian into .deb files and hosting them in a private S3 bucket using a program called deb-s3. I also use a program called apt-transport-s3 ...
user avatar
  • 719
0 votes
1 answer
285 views

apt-get install package - tries to upgrade unwanted packages

How to prevent so many additional installs and upgrades? rather just install only apt-file package along with its dependencies....? Are all the extra packages and upgrade required for just apt-file ...
user avatar
3 votes
1 answer
80 views

(Ubuntu 16.10) How to pick/encourage a specific solution proposed by aptitude using only command-line arguments?

According to aptitude, the ubuntu-mate-desktop and ubuntu-mate-core packages recommend the ntp package, which conflicts with the openntpd package that we use. Interactively, it's easy to ask aptitude ...
user avatar
  • 152
1 vote
1 answer
471 views

Icinga2 : Apt check notification

I got one question related to following facts : On my server with icinga2 installed (with icinga2-web), I receive some critical notifications each 30min despite the fact that all packages are ...
user avatar
  • 127
0 votes
1 answer
37 views

Migrating from beta to release repository

Okay, so I'm probably having a hard time finding an answer for this as I don't know if I'm using the correct terminology for it. In short, I installed php7.0 a while ago before it was available in ...
user avatar
  • 233
14 votes
1 answer
16k views

How to check postfix server using telnet

I have postfix email server on Ubuntu 11.04 version. I upgraded installed packages using the following command sudo aptitude update && sudo aptitude safe-upgrade Once I update those packages,...
user avatar
0 votes
1 answer
745 views

Are the packages from apt-get remove --auto-remove sendmail safe to remove?

Im trying to clean up the mess left by sendmail, My unix knowledge is extremely limited so I would appreciate some help with whether these packages are safe to remove, I have already run apt-get purge ...
user avatar
  • 111
0 votes
0 answers
2k views

How do I install a virtual package?

I'm trying to install postgis with aptitude on Ubuntu 15.10 and is having problems with virtual packages that prevent the installation. me@laptop:~$ sudo aptitude install postgis The following NEW ...
user avatar
  • 101
0 votes
2 answers
1k views

Removing old kernels

My boot partition is full and I can't install new kernel versions. So I tried to remove some old versions like this: get active kernel uname -a Linux Ubuntu-1404-trusty-64-minimal 3.13.0-43-generic ...
user avatar
2 votes
1 answer
2k views

apt: list required dependencies for deb package without installing it

For a build tool I'm writing (for which I'd like to implement a sort of dependency-caching system) I'd like to know what the missing dependencies for a .deb package are, without resorting to ...
user avatar
1 vote
1 answer
101 views

Mark packages to be installed and run aptitude in interactive mode

I want to install series of packages. Selecting all of them in TUI is inconvenient. But if there're any conflicts, resolving them in interactive mode is much easier. Is it possible to mark packages ...
user avatar
1 vote
0 answers
119 views

Why some apt-get and aptitude installations remove some programs?

I wanted to install wireshark, and I went to Installing wireshark So I just typed on terminal aptitude install wireshark and before it install wireshark, it removed 251 programs, and I don't have ...
user avatar
1 vote
1 answer
2k views

Problems updating Debian 6

Im trying to update a Debian 6 server, but get the following output with some errors after sudo aptitude update: Ign http://archive.debian.org oldstable Release.gpg Ign http://archive.debian.org/...
user avatar
  • 111
5 votes
0 answers
4k views

Unable to apt-get install nginx-extras package on top of nginx 1.7.9

I am attempting to install Phusion Passenger for nginx on a dev Ubuntu box following this guide from the passenger website. I have Nginx installed and running already, version is 1.7.9-1~trusty. I ...
user avatar
10 votes
1 answer
3k views

apt-get install -t testing appX VS apt-get install appX/testing

I've been trying to understand the difference between these two commands and noticed that I get different results. apt-get install -t testing appX apt-get install appX/testing Background I setup my ...
user avatar
  • 419
0 votes
4 answers
1k views

Unable to install software using apt-get in Ubuntu Server

I'm trying to install some software in my Ubuntu Server 12.04 installation, but whenever I try to install it using apt-get or aptitude, I would usually get an error message like this: E: unable to ...
user avatar
  • 163
1 vote
1 answer
774 views

Why does aptitude want to update the original kernel when I use backports?

On Wheezy I am using the current backports kernel, which I set up via # echo "deb http://ftp.de.debian.org/debian wheezy-backports main" > \ /etc/apt/sources.list.d/wheezy-backports.list # apt-...
user avatar
0 votes
0 answers
619 views

Segmentation fault using group add

Today I tried to install a tftp server to setup a PXE server on a virtual machine (powered by VMware ESX 4) for our network to ease server installation. The base installation (Debian 7.5.0 x64) worked ...
user avatar
  • 109
3 votes
2 answers
1k views

How to tell when apt-get upgrade or apt-get dist-upgrade was last run

Is there a clean way to detect when apt-get upgrade or apt-get dist-upgrade was last run on an Ubuntu Server? If there isn't a way to do this by default, where would be the best place to modify a ...
user avatar
1 vote
0 answers
98 views

What can prevent apt from installing higher version

I'm trying to install a specific version of a package (python-neutronclient), but apt is failing to do that due to old packages. This happens even though new packages are available. Aptitude also ...
user avatar
  • 1,254
0 votes
1 answer
74 views

Why is my aptitude inconsistent about packages that must be removed to install another package?

This is on debian (3.11-0.bpo.2-amd64 #1 SMP Debian 3.11.8-1~bpo70+1 (2013-11-21) x86_64 GNU/Linux). I was just attempting to "aptitude install ntp". Aptitude told me it would install ntp and ...
user avatar
  • 103
0 votes
1 answer
183 views

How to get the Package-List of a debian/ubuntu package?

It's possible to view the Package-List of a debian/ubuntu package, using the package management tools like apt, aptitude or dpkg? I need to list the packages provided by a package, the list is ...
user avatar
  • 133
1 vote
0 answers
196 views

Ubuntu web host update strategy

I have a couple of questions regarding best practices for updating an ubuntu web server. A server that is hosting a live website that would be very problematic should the server "go down". I am a ...
user avatar
2 votes
1 answer
4k views

installing git from debian wheezy backports: anyway i see old package version

I need to install git 1.8.* version. I added backports to my sources.list; Removed current installed git via apt-get remove git; Executed apt-get update to update my packages list aptitude show git ...
user avatar
  • 279
3 votes
1 answer
1k views

Exclude sources files for apt-get update

I use an specific command to check security updates: /usr/bin/apt-get update -o Dir::Etc::SourceList=/etc/apt/security.sources.list But when executed it use sources files in /etc/apt/sources.list.d/....
user avatar
  • 586
0 votes
1 answer
3k views

apt-get dependency issue when installing nginx passenger module

Sorry I Have no idea how to fix the dependency problem. My Ubuntu server is 12.04 64 bit $ sudo apt-get install libcurl4-openssl-dev Reading package lists... Done Building dependency tree Reading ...
user avatar
  • 181
6 votes
1 answer
6k views

Ubuntu apt-get update vs upgrade

I have a VPS with Ubuntu Server 12.04 and I want maximal stability of my server, which's main purpose is a webserver. What are difference between Update and Upgrade? I can't understand difference. As ...
user avatar
1 vote
1 answer
2k views

On Debian, how to audit installed packages against packages in a particular repository?

I manage a number of Debian servers and usually track the Debian stable repository but occasionally install from the Debian testing repository or third party sources. For audit purposes, on each ...
user avatar
1 vote
0 answers
128 views

Best effort (failover) HTTP proxy use in aptitude?

I was installing a new Ubuntu 13.10 (daily build) for testing, and came to the option of being able to configure an HTTP proxy server for aptitude. It's been a while since I've sat through an ...
user avatar
  • 305
3 votes
1 answer
2k views

Unable to install python2.7-dev on Ubuntu 12.04.2 LTS

The command $ sudo apt-get install python2.7-dev yields this result: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
user avatar
  • 133
3 votes
1 answer
147 views

Disallow virtual package in Debian's /etc/apt/preferences

I know I can disallow a particular package in Debian by appending /etc/apt/preferences with: Package: *x11* Pin: release Pin-Priority: -1 But how can I do that for a virtual package like httpd? I'd ...
user avatar
0 votes
1 answer
843 views

Removing sources from sources.list doesn't work

I had recently upgraded to php 5.4 but it was not working for me so I thought I'd remove php 5.4 and re-install php 5.3. I uninstalled php5.4, removed the dotdeb sources from sources.list file, ran ...
user avatar
2 votes
1 answer
579 views

web-based apt-get/aptitude frontend

I manage some 15-20 Ubuntu servers and am faced with the tedious task of keeping them all up to date. I have looked for a simpler solution and came across Ubuntu Landscape, but this is waaaay out of ...
user avatar
  • 21
0 votes
2 answers
3k views

Unmet dependencies when updating PHP 5.4.8 to 5.4.15 using dotdeb on debian

I'm not quite sure how to act here. I installed php5 as dotdeb package. I'm on debian squeeze 686. Now I try to update from 5.4.8 to 5.4.15 and get the following output after running aptitude install ...
user avatar
  • 667
3 votes
1 answer
2k views

Prioritise repositories in Ubuntu

We have a few PPA sources on some of our servers which we stick into /etc/apt/sources.list.d . Some of these repos provide same packages (in terms of names) but different versions and possibly ...
user avatar
  • 1,778
2 votes
1 answer
190 views

Abnormally high number of safe-upgrade packages on debian squeeze

One of our webservers which is running Debian Etch Squeeze (6.0.7) and which we regularly maintain with safe-upgrades (normally it's only a few safe-upgrade packages per week) now shows an abnormally ...
user avatar
  • 125
0 votes
2 answers
878 views

How can I exorcise a specific Ubuntu package that crashes on a postinstall script?

I have a libssl-dev package installed, possibly because I am not sure if I bypassed the package manager, and it's visible from the package manager but won't go away. root@li393-189:/home/jonathan/...
user avatar
0 votes
1 answer
2k views

installed post-installation script returned error exit status 1

I found many complains with same error but for different packages. However, i couldn't understand essence of this error and how to fix it. Pls. help if you have any clue about it. It appeared first ...
user avatar
1 vote
2 answers
6k views

After update, Ubuntu booting into black screen (but ssh working)

I am running Ubuntu 12.04.2 LTS on HP ProLiant server. After recent update (using apt-get update and upgrade), it boots into black screen. BIOS Post screen still shows normally, but when the OS ...
user avatar
0 votes
1 answer
337 views

Ubuntu 12.04 Server on VMWare - apt-get failing to hit repos

So, I have an Ubuntu 12.04 LTS 64-bit server instance running on VMWare player. Everything appears fine at the surface. Even internet connectivity appears good as I can perform both pings out to ...
user avatar
  • 411