Questions tagged [bad-request]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
84 views

Hostname provided via SNI and hostname provided via HTTP are different - 400 Bad Request

When a user visits one of our sites they are randomly receiving a 400 Bad Request error. We have 8 domains on this IP. Running Apache 2.4 w/letsencrypt SSL certificates for each domain. We used the ...
1
vote
1answer
19 views

Odd requests for urls that are the *body* of my CSS files

I'm not sure quite how to express this but my NodeJS server has recently been getting errors because some middleware library is unable to parse certain parameters from urls. When I look at which urls ...
12
votes
1answer
1k views

How to block mysterious remote requests?

My CentOS server is experiencing huge (millions a day) requests looking like this: Srv PID Acc M CPU SS Req Conn Child Slot Client Protocol VHost Request 62-1 - 0/0/335 . 0.00 ...
1
vote
2answers
192 views

Determine the end of a malformed (bad) http request

I'm implementing a HTTP server and wonder, if there is a defined way of when a server would determine a bad request as ended to return the corresponding 400 status, and accept the following data as ...
0
votes
1answer
537 views

Ubuntu 16.04 public wifi connection failure “The request is invalid due to malformed syntax or invalid data.” [closed]

I use Ubuntu 16.04 on my laptop and I can't connect public library's free wifi. First, It shows this error when I try to open HTTP pages: Open me in new tab When I try to open https pages, it says "...
1
vote
1answer
40 views

API backends app revision Y not the same as expected X

I have API endpoints on app engine, and after a certain deployment I found a server error. By mistake, I did a rollback, then I fixed the problem, and then I deployed again. Since then I'm having this ...
2
votes
1answer
2k views

Nginx Docker 400 Bad Request

I am currently trying to host nexus as a private registry for docker images within my organisation . My nginx configuration are as below . user nginx; worker_processes 1; error_log /var/log/nginx/...
0
votes
1answer
596 views

Accept custom header field “Content type” in apache

My app was sending request with header field "Content type" [sic] and value "form-data" [sic] to the server. Although it seems wrong - it seems it was causing no problem until couple of days ago. Then ...
0
votes
1answer
37 views

Unusual requests on Apache2

I am developing an eBay-like system in PHP only to accept Bitcoin as the only payment method. For this purpose I've set up a virtual machine on my computer because I don't want to be paying for ...
0
votes
0answers
194 views

Why I can't upload a 4k video to phpvibe?

So I trying to playing with Google VM tools and Phpvibe. My chalange is, you can upload any video whatever you want, to the site and after that the server is convert to the optimal format, so you can ...
4
votes
4answers
19k views

HAProxy returns Bad Request (Invalid Host) for seemingly no reason

I've been trying to test a setup that looks like this: Website: Http GET Request -> Nginx -> HAProxy -> .Net application I've placed Nginx and HAProxy on the same Debian machine. However, HAProxy ...
2
votes
2answers
552 views

Resolving HAProxy BADREQs using socat

I'm trying to figure out why i'm getting BADREQs from time to time, by using "show errors" in socat. The problem is that it only shows the last error. I want to be able to see all of them ( like using ...
0
votes
1answer
253 views

Odd web server requests that look like truncation and concatenation, possibly IE-related

We're logging a few errors consistently that we don't know the cause of. The user agent string indicates this is almost always, if not always, Internet Explorer. (More than 90%, the remaining either ...
9
votes
4answers
31k views

Apache Bad Request “Size of a request header field exceeds server limit” with Kerberos SSO

I'm setting up an SSO for Active Directory users through a website that runs on an Apache (Apache2 on SLES 11.1), and when testing with Firefox it all works fine. But when I try to open the website in ...
0
votes
1answer
2k views

Intermittent 400 Bad Request Errors in IIS

We recently upgraded our infrastructure to Windows server 2008 R2 (64 bit), and are now getting intermittent 400 errors on post. I set up failed request tracing, and have caught a couple of them. ...
5
votes
3answers
2k views

How often should we expect 400 Bad Request?

We run an Apache2 web server which has somewhere in the vicinity of 2-3 million pages served every day (only HTML+CSS+Javascript, images and other content is served with Lighttpd). Our daily logwatch ...
2
votes
2answers
728 views

Bad Request Due to “Bad” Cookie

I have a web site under a domain, where the main domain is using Google Analytics which sets a cookie named __utmva which is value is part binary. As far as I can tell passing this cookie to IIS ...
2
votes
1answer
2k views

Uploading file > 1 MB on Django admin gives 400 Bad Request response

I have a small Django (1.2.x) project deployed on Apache (2.x) via mod_wsgi (3.x). In the admin, if I upload a file < 1MB, I can get it through; however, for a file, say, 1.2MB in size, I get a 400 ...