Questions tagged [bonding]

"bonding" is the Linux-term for link aggregation.

Filter by
Sorted by
Tagged with
0
votes
1answer
32 views

Can LACP run over Linux tunnel devices?

I'm looking for a way to know if a tunnel device is up or down without needing to use ping myself. Every single tunnel device (gre, ipip, l2tp, geneve, etc) does not have a logical mechanism to decide ...
1
vote
1answer
148 views

Change an active slave of Linux network bonding interface without ifenslave command

Linux supports bonding of multiple Ethernet network interfaces for extra reliability or load balancing. Bonding driver used to be configured via ifenslave command, which has been deprecated (...
0
votes
2answers
52 views

nic bonding very slow

I have 2 dl380 g9 servers which feature 2 nics with 4 ports each running debian buster. I have connected 7x 0.50m cat6e patch cables directly server-to-server and set the /etc/network/interfaces on ...
0
votes
0answers
80 views

MT27710 (ConnectX-4 Lx) connection troubleshoot

Background: MB: Supermicro X10DRi SW: 2x Supermicro SSE-F3548R (MLAG - UP and running) Cables: 1x Mellanox MCP2M00-A003E30L and 1x FS S28-PC025 OS: Ubuntu 18.04 Problem: For my perspective ...
1
vote
0answers
37 views

Why I am Getting Higher than %100 Network Usage From SNMP?

I am using SNMP in Ubuntu 20.04 to get the network usage info and I am using this formula to calculate the network usage: InOctets : The difference between two poll cycles of collecting the snmp which ...
0
votes
1answer
101 views

Ethernet bond interface fails after NIC replacement

I've replaced a failing 10GbE adapter in a Dell PowerEdge server running a bonded pair of Cat6 cables to an aggregate switch. The old NIC and its replacement are both Intel Ethernet Controllers (10-...
1
vote
0answers
24 views

Packet Loss between server-to-server Oracle Linux 7.9 bond

I have 2 Oracle Linux 7.9 physical servers, each one with a dual nic. I bonded this dual nic end attached server-to-server with 2 cables (not crossover cables). I have packet loss in average 50% ...
1
vote
0answers
129 views

Linux 5.9 VLAN interfaces don't receive traffic unless promiscuous mode is enabled

I've just upgraded a NAS running Debian Buster to Debian Bullseye. This included a kernel upgrade from 4.19.0 to 5.9.0, and a systemd upgrade from 241 to 247.1 (the system is using systemd-networkd ...
1
vote
1answer
145 views

LACP between Netgear ProSafe GSM7248V2 and Linux server

I am trying to connect a Linux server with two 1Gbps NICs with a switch Netgear ProSafe GSM7248V2 using bonding, specifically 802.3ad mode. The results are very confusing, I would be thankful for any ...
0
votes
1answer
72 views

Bonding NIC on VM

I have an ESXi server with a DS switch configured with LACP and lag uplink with 2x10G port on the switch I'm wondering if I give 2 10G interfaces on my VM can I bond them and use that 20G uplink? I ...
0
votes
1answer
139 views

Why does my bond interface with multiq ignore tc's queue selection?

On Debian Buster, Kernel 5.4.51, I have two interfaces tap0 and tap1 joined in a bond interface in mode balance-xor to increase throughput. There is, however, some traffic that must be sent through ...
0
votes
0answers
156 views

bonding issue with ethernet interface (raspbian strech)

Since i've bonded (active-backup) eth0 & wlan0 i'm no able to ping a specific device within my LAN. I'm under raspbian stretch. Linux raspberrypi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 ...
1
vote
1answer
235 views

Adding a VLAN (over bond/lacp) interface to bridge makes physical interfaces to go down

I have a working configuration of a team interface bonding two physical interfaces, with several VLANs. ens1f1 ----- |--- team0.1826 (172.18.x.y/28) |--- team0 -----|--- team0....
1
vote
2answers
142 views

Bonding 2 interfaces inside a linux network namespace

I'd like to be able to bond/aggregate 2 interfaces inside a Linux network namespace. The configuration I'm working with is the following: On the root linux net stack I have two physical ethernet ...
0
votes
0answers
62 views

Forwarding bonded connection to local network through stateful firewall - ArchLinux

I'm using Arch Linux to set up a firewall for a school which will stream each classes' video to students at home, so I need a strong and safe connection, that's why I was thinking about bonding ...
0
votes
0answers
42 views

rtk8192ee wifi firmare stops loading after ifenslave setup attempt (Debian 10)

I tried setting up Mode 0 NIC bonding using ifenslave between my Ethernet and WiFi cards on Debian 10. After numerous ifconfig wls1 up/down, I was able to set up Bond0 until it stopped working. After ...
1
vote
2answers
177 views

I'm trying to Bond Two Internet uplink for Increased VPN Speed, but no luck

I'm trying to Bond Two Internet uplink for Increased VPN Speed under this guide: How to Bond Two (Multiple) Internet Connections for Increased Speed and Failover But I have some problems: I've been ...
0
votes
1answer
592 views

Redundant Mikrotik switch bonding modes

All the posts I can find about redundant switches only address the servers connected to the switches. I need to confirm my configuration on both the servers and the router handling the traffic. We're ...
2
votes
0answers
43 views

Can NetworkManager deactivate connection when all bond slaves lost carrier?

For Ethernet connection, when carrier is lost then NetworkManager sets connection state to 'unavailable': [root@host ~]# ip link set down enp2s0f0 [root@host ~]# journalctl -u NetworkManager --since ...
2
votes
0answers
24 views

port channel delay coming up <> linux config

after our 5k switch reboots, due to many configured vlans, LACP/port channels take some time to come up. seems to be a serial process, and if vlans are at bottom of this list, it takes some time - ...
2
votes
1answer
38 views

How to setup a bonded ethernet connection directly between macOS and Windows Server 2019?

I've been having trouble connecting a macOS 10.13 High Sierra server to a Windows Server 2019 server with a bonded ethernet connection consisting of 3 directly connected ethernet adapters. Windows ...
0
votes
0answers
29 views

No connection to default gateway

I freshly installed a new ubuntu server and set up netplan for 802.3ad. Now I can reach every device in my network but not the gateway and therefor the internet. The server is directly plugged into ...
0
votes
0answers
60 views

linux router, 2x NIC, HA with interface bonding, two ethernet switches

I have two NIC server (eth0, eth1) that I use as router. I have two switches working in stack. Is it a good idea / possible to create on them two bond lacp interfaces ( bond0, bond1 ). And use bond0 ...
0
votes
0answers
270 views

How to bond two interfaces having different speeds in Linux?

I have successfully set up two simultaneous VPN tunnels over different Internet connections to the same server. Then I've bonded them using systemd-networkd and balance-tlb mode. It works as designed,...
0
votes
1answer
268 views

Interface bonding on GRE tunnel with nmcli

I have two Ubuntu server-based routers and I'd like to bond (in broadcast mode, since I only care about redundancy) a radio link (where the radio equipment is connected to an Ethernet port) and a LTE ...
0
votes
1answer
489 views

What is the Proper Way to Create Port Bonding on RHEL?

I've got for data interfaces on my server: eno5, eno6, ens3f0 and ens3f1. I need to create port bonding with these four interfaces with a VLAN ID 101 and with bond name data0. More info: RHEL 7.6 ...
0
votes
1answer
3k views

debian 10 bonding error boot bond0

I try to set up bonding on my debian 10 computer. I have 2 NIC card, I try to use enp1s0fX port. Sample of my interfaces file auto bond0 iface bond0 inet static address 192.168.211.124 gateway ...
1
vote
1answer
1k views

CentOS 7, KVM, bridge, VLAN, bond and no guest traffic

I'm running into an issue where my KVM guests have no network traffic in- or outgoing. After a lot of hours debugging I'm pretty sure I'm missing something essential. What I have a server with 2 10 ...
0
votes
1answer
415 views

Bridge over VLAN interfaces causes broadcast storm

I am doing experiments on my Proxmox server. The purpose of the expriment is to establish reliable and fault-torrant communications between two PCs that control industrial equipment. but I am puzzled ...
0
votes
1answer
399 views

LCAP and VLan on FreeNAS box

I can not seem to get the FreeNAS GUI to come up when I try to use link aggregation. I have been googling for days and I am totally lost as to where I am going wrong. I will list the equipment I have ...
1
vote
0answers
490 views

Network interface is down then is up with different speed

i have a HP ProLiant server with 4 physical network ports. eth0 and eth1 are bonded together. today we faced a lag in our services, turned out that eth0 was down then up with 1000Mbps speed then went ...
2
votes
0answers
90 views

NIC bonding on Linux in redundant network topology

I want to implement NIC bonding on Linux server in redundant network topology as shown in the network diagram below. Network topology Both interfaces of the Linux server fa0 and fa1 would be in one ...
1
vote
0answers
213 views

site to site openVpn link aggregation with linux

I'm trying to improve access over VPN for a site office to the head office. Will the following increase single file download speed. Provide 2 WAN (NBN) connection at both sites. Dedicate each WAN ...
0
votes
0answers
864 views

ubuntu 18 nic bonding not working

I have some issue with my aggregated nics in ubuntu 18. I was not able to make it work. it is not pingable and not able to ping also. **Netplan config:** *network: bonds: bond0: ...
0
votes
1answer
2k views

Failed to configure network bonding on CentOS 7 with Ansible

I am trying to configure a bond interface using the Ansible net_linkagg module but the tasks failed with the following error. FAILED! => {"msg": "ansible_network_os must be specified on this host ...
0
votes
1answer
61 views

Bonding Fails in Kickstart %pre Section

I am trying to setup a bonded network from the %pre section of a CentOS 7 kickstart. I can prove the the following bonded network works: network --device=mynetwork --bondslaves=eth0,eth1 --bootproto ...
7
votes
2answers
9k views

How to Bond Two (Multiple) Internet Connections for Increased Speed and Failover

We are located in a rural area with two slow ADSL connections (3.5/0.5 Mbps) and wanted to improve connection speed and reliability by somehow "combining" them. The following describes our solution ...
0
votes
0answers
237 views

“Unreachable Network” After network bonding

We've configured network bonding on more than 20 VM. It is working properly but after this configuration VM's fall from network in random order and conditions. Restarting network service is solving ...
3
votes
1answer
773 views

Why is networkd changing the MAC addresses of my bonded interfaces?

When I add the config files below into /etc/systemd/network and restart systemd-networkd, I find that the MAC addresses of bond0, eth0 and eth2 have all been changed to a single, locally administered ...
0
votes
1answer
182 views

Setting up DHCP with CloudInit and Bonding

I currently have a cloud init file that setsup the DHCP via the following: - path: /etc/systemd/system/dhclient@.service content: | [Unit] Description=Run dhclient on %i interface After=...
0
votes
1answer
40 views

Adding a bridge on top of a bonded interface that have multiple ip?

I have a server that has three static IP addresses. I'd like to add a bridge to these settings. I tried to add the bridge this way but it doesn't seem to be working. auto bond0 iface bond0 inet ...
2
votes
0answers
26 views

Bonding / link aggregation, is it ok to connect 2 switches together? [duplicate]

I have 2 computers, each with 2 ethernet ports connected to 2 unmanaged switches using linux Bonding Mode: load balancing (round-robin). Can the 2 switches connect to each other without causing a ...
0
votes
1answer
2k views

KVM QEMU Guest VMs randomly lose network connection

I'm working on setting up a server with KVM/QEMU and all Linux servers. We are going to use this server for web development, git, VoIP PBX, etc. (We were using XenServer and Windows Server 2016, but I'...
0
votes
2answers
373 views

Is it possible to use Link Aggregation to connect to two unmanaged swtiches, providing switch redundancy?

Assuming that I have a firewall that supports Round-Robin or Loadbalance link aggregation (no LACP necessary), would it be possible to connect each of the NICs in the LAGG group to a separate, ...
1
vote
1answer
2k views

Bonding balance-xor (mode 2) using only one network interface

I am using Ubuntu 16.04.6 LTS and bonded 2 network interfaces with the following config: auto eno0 iface eno0 inet manual bond-master bond0 auto eno1 iface eno1 inet manual bond-...
3
votes
0answers
2k views

bonding network interface speed changed to 0

I have Suse12 system with Intel 82599ES nic(with 2*10-Gigabit SFI/SFP+ port),two ports are bonded by lacp.Recently,the system network is unreachable,lasted 3 minutes. Looking through the message log, ...
1
vote
1answer
130 views

Recommended application and storage server network link over NFS

Background: I have a RHEL6 storage server (lots of HDs) and a RHEL6 Application server (little storage, lots of CPU/memory). They are currently connected to a 1GB Catalyst 2960-X switch. There is ...
1
vote
2answers
1k views

Linux optical 10Gbe networking, how to diagnose performance problems?

I have a small cluster consisting of 3 servers. Each has two 10Gbe SFP+ optical network cards. There are two separate 10Gbe switches. On all servers one NIC is connected to switch 1, second NIC is ...
0
votes
1answer
224 views

Ubuntu Bridge network interfaces on 4 port gigabit card

I've seen this on the internet before. I have a Ubuntu server with a 4 port gigabit network card. I would like to bridge the interfaces so that, if an interface is busy, the packets will go through ...
1
vote
0answers
105 views

Bonding on centos only and switch without LAG enabled vs Bonding on centos and swtich with LAG enabled

I am a little confused on Bonding on Centos side and Link aggregation on netgear switch side. Would mean a lot if someone can clear it out. Using switch Netgear XS708E which does not support IEEE 802....

1
2 3 4 5
7