Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [bonding]

"bonding" is the Linux-term for link aggregation.

0
votes
0answers
16 views

Collecting NIC teaming information on Server 2008 R2/PowerShell 2

Is there a way to do this via WMI? I've collected info but am not sure what to look at as far as identifying interfaces as set up with teaming. Nearly all the servers that have teamed interfaces ...
1
vote
1answer
37 views

VM transfer speed between XCP-ng (XEN) servers

I have two HP DL380 G8 servers with 4x 1TB on HP p420 RAID controllers in RAID 1+0 setup. Eth0s are connected to the router, and Eth3&Eth4s are bonded (LACP) and connected directly between ...
0
votes
0answers
19 views

bonding configuration when SLAVE=yes

In my network configuration I see the settings of SLAVE=yes what is mean that - SLAVE=yes # cat /etc/sysconfig/network-scripts/ifcfg-eth0 DEVICE=eth0 BOOTPROTO=none ONBOOT=yes # Settings for ...
0
votes
0answers
30 views

How do I tell anaconda kickstart installer to assign a specific MAC address to when creating a bond?

I want to force use of specific MAC address when creating a bond at install time on CentOS/Fedora. I do expect that the side effect of doing this is that the /etc/sysconfig/network-scripts/ifcfg-...
1
vote
1answer
24 views

How to I assue same MAC address when creating bonded interfaces using anaconda kickstart installer?

I observerd that the bond0 interface I create at install time may randomly use the MAC address of the first or second interface. This is causing problems because it means that the IP address of the ...
0
votes
1answer
42 views

Linux Bonding Mode 1 Active-Backup

Is it possible both NIC configured as Linux Bonding Mode 1 sending traffic? I have a strange case where both NIC is set as Linux Bonding Mode 1 (active-backup) and connect to two different switches (...
0
votes
0answers
27 views

Is it possible to bond two bond two network connections and almost double single connection speeds?

I have two gigabit ethernet adaptors on my servers and my switch also supports 802.4ad and I tried several ways of configuring the bonding but so far I was not able to speed-up single connection ...
0
votes
0answers
32 views

NIC teaming issue on CentOS7

I have team interface with only one physical NIC em1 attached. Then I try to add another NIC em2 to team with following command: teamdctl team0 port add em2 After adding second NIC team interface ...
1
vote
1answer
38 views

can multiple ip addresses be attached to a single network bonding device?

I am setting up an Ubuntu server for several hosting tasks that has 2 network cards and I have 5 ip addresses reserved for this server. From the bonding documentation I understand that it can easily ...
-1
votes
0answers
75 views

linux bonding active backup to a pair nexus switch

I am trying to connect a Linux Server with 2x10Gbps to a pair Nexus switch as shown below : The bonding itself is using Mode 1 Active-Backup, between Nexus switches there is a vPC peer-link, and ...
0
votes
1answer
56 views

Is it possible to create iface teaming/bonding over tunnel devices?

I have several physical NICs on one server which should be able to access peer server's physical NICs. I have ip-tunnel devices (currently set as GRE) between each pair of NICs. I'd like to team/bond ...
0
votes
1answer
58 views

Network bonding active-backup mode with two switches

This below is a sample of my network. I have two interfaces on one machine eth0: 192.168.150.2 and eth1: 192.168.150.3 and I want make my network redundant using mode=1 which is active-backup, so if ...
1
vote
0answers
91 views

Linux Bonding with 2x10G LAN poor performance in kernels after 4.13.x

Here is our setup a DELL server with two 10G LAN ports and our old kernel 4.13.4 serving static video content using nginx (~8000 active connections) with the bandwidth of around 15.5G (1.2Mpps) on ...
1
vote
0answers
53 views

ifenslave stuck (lacp bond)

I'm trying to set up LACP bonding on Ubuntu 16.04.1 but I'm presented with this slightly illogical issue: $ ifenslave bond0 eth0 eth1 eth0: is already enslaved to bond0 eth1: is already enslaved to ...
1
vote
1answer
174 views

In a LACP bond, do all partner interfaces need to have the same “oper key”?

We use LACP (mode 4) bonds extensively in our environment, and I occasionally run into problems with new deployments where cables get crossed, or switch ports are misconfigured causing bad LACP port ...
0
votes
0answers
10 views

one bond cant send packet out

We have a Centos 7 server with two bonds and one of bonds can not send out any packet (cant ping google for instance) but its public IP is accessible from outside and can be pinged; this happened so ...
2
votes
1answer
422 views

Setup 802.3ad bonding under Debian Jessie with a HP 1920G switch

I've got a Debian Jessie server with two Intel i350 onboard 1Gbps NICs which I would like to bridge using 802.3ad protocol to my HP 1920G 48port managed switch. Here is the kernel I'm running ~ % ...
0
votes
0answers
23 views

Ethernet bonding 802.3ad [duplicate]

I've configured 802.3ad ethernet bonding on hp blade server with two 10gb/s speed NIC cards. Now eth0, eth1 & bond0 ethernet's speeds are showing similar(10GB/s on all 3 ethernets). I though 802....
0
votes
1answer
331 views

bridge0: received packet on bond0 with own address as source address

I have created a bond using netplan (ubuntu 18.04) which shows the same MAC address for the two member physical NICs and the bond itself. I configured a bridge on top of that, for use with KVM/Qemu ...
2
votes
0answers
172 views

netplan apply breaks bonding

Whenever I change my Network configuration on my Ubuntu 18.04 Server and apply it using netplan apply command, the bonding interface is no longer usable. While the IPs are correct, there is simply no ...
0
votes
0answers
16 views

what is the advantage to configure the network ETH with UUID?

what is the advantage to configure the network with UUID? uuidgen eno093736 1b64d026-c6a6-447c-85aa-40c5d2db2c4e for example we want to configure BOND under /etc/sysconfig/network-script what is ...
0
votes
0answers
39 views

Unable to set up bond interface from 2 vlans

Can someone help me to set up a bond interface from 2 vlans using teamd daemon. This is how i'm trying to do: # ip link add link eth1 name vlan50 type vlan id 50 # ip link add link eth2 name ...
0
votes
1answer
14 views

Bonding SWITCH XS (incoming packets)

I would like to bound 2x10Gb/s of a Linux server to receive/inbound more than 10Gb/s on a virtual interface send by a unique client. The client will probably send more than 10Gb/s (probably bonded ...
1
vote
0answers
316 views

Issue with bond + vlan + bridge on top of systemd-network

We are using two switches (let's call them A and B), and each host (running debian 9) has 2 nics (eno1 and eno2), connected to A and B. Those interfaces are bonded together (bond0) in active-backup ...
0
votes
0answers
233 views

Unequal load balancing with balance-rr mode on Ubuntu 18.04

Have two network cards bonded in a balance-rr configuration: root@server:~# ip link show 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000 ...
0
votes
0answers
233 views

How to have multiple routes to the same remote VPN in pfSense?

We have a pfSense server in two offices. Our main office has a VPN server configured, and our satellite office has a VPN client configured, using the IP 123.156.88.253 (just an example). We have just ...
1
vote
1answer
2k views

LACP 802.3ad load balancing (bonding) on Ubuntu 18.04 not balancing evenly

I upgraded to Ubuntu 18.04 and the new Netplan configuration, but my (2) network cards stopped sharing the load evenly. In my network configuration, I have many connections to many different servers; ...
0
votes
1answer
100 views

ESXI NIC Teaming Policy x 2 physical swith x Shaper\BGP router

I have a BPG/Shaper with 2 interfaces configured in Bond0 (Loadbalance-RoundRobin)then connect one to each switch (one in Red one in Blue). ESXI is the same thing, 2 interfaces in one vSwitch NIC ...
0
votes
0answers
29 views

Re-using a bond slave

Is it possible to create multiple bonds on the same slaves? We have two ethernet ports on each server. We'd like to have one ethernet port with a public address and one ethernet port with a private ...
2
votes
2answers
380 views

Network bonding modi balance-rr / 802.3ad layer3+4

What is the difference between balance-rr and 802.3ad with xmit_hash_policy set to layer3+4 https://www.kernel.org/doc/Documentation/networking/bonding.txt This algorithm is not fully 802.3ad ...
1
vote
2answers
131 views

How to create a link aggregation (NIC TEAM) between bare metal, with Hyper-V 2016, and the switch

I started using Hyper-V a short time ago, I only have experience with ESXi. I'm trying to do a link aggregation with the 4 network interfaces between bare metal with Hyper-V and the switch. I've ...
0
votes
1answer
123 views

Bonding 802.3ad and HPE switches: ingress and egress traffic not in the same interface

I have LACP configured between my server (802.3ad, layer2, so based on source MAC and destination MAC) and my switch. Recently I saw that ingress traffic for a network peer is using one interface (...
0
votes
0answers
69 views

Netgear GSS116E LAG and Ubuntu 14.04 bonding mode

I have a GSS116E Prosafe managed switch and a managed to enable LAG on the switch and bonding on ubuntu. Currently I have bonding running at bond_mode 2 (balance-xor). I read here that that this ...
3
votes
2answers
71 views

Could it be that no link detected until bond configured?

Could it be that the: ethtool ethx | grep detected shows "no link detected" if the bond0 isn't configured yet on OS (linux) side? isn't ethtool showing a physical state?
2
votes
1answer
176 views

bonding-rr vs single 10G for NFS NAS - pros and cons?

I'm standing before choice of NICs and switch for storage server and virtualization hosts and I can't decide between 10G and quad gigabit with bonding-rr. 10G is noticeably more expensive solution and ...
0
votes
1answer
434 views

What is “currently active slave” in Linux bonding & adaptive load balancing

My understanding of adaptive load balancing for NIC bonding was that it would dynamically abuse ARP requests to cause traffic ingress and outgress to come from different slaves to attempt to optimize ...
0
votes
1answer
437 views

Bonding 4 Gigabit ethernet and 2 Fiber SFP+

We received a DL380 with 4 Gigabit Ethernet (normal CAT6), and 2 Fiber SFP+ (HPE 10Gb SR SPF+). I've successfully managed to bond the 4 Gigabit Ethernet together, and put in place some LACP on our ...
1
vote
2answers
900 views

Linux bond mode 802.3ad not activated

on a server running Debian Stretch I configured a bond0 with the 802.3ad mode as following: auto bond0 iface bond0 inet manual slaves eth0 eth2 bond_miimon 100 bond_mode 802....
3
votes
2answers
312 views

Bonded Gigabit Interfaces capped at ~500mbps each

This issue has been driving me nutty for days now! I recently bonded the eth0/eth1 interfaces on a few linux servers into bond1 with the following configs(same on all systems): DEVICE=bond0 ONBOOT=...
0
votes
2answers
260 views

XenServer Nic Bond; Guest Network Speed?

In my XenServer 7.3 I have 4 Intel 1G network adapters. I configured Nic1 as Management and Nic0 & Nic2 as a LACP Bond based on IP and port (On my Cisco L3 Switch I did the same for the two ...
1
vote
1answer
346 views

Is Debian package ifenslave really necessary for bonding?

This piece of Debian documentation states that package ifenslave is necessary for bonding: First install the ifenslave package, necessary to enable bonding Yet I know of two Debian 7.10 (wheezy) ...
1
vote
1answer
68 views

Cisco SG550X LACP standby member even if link is UP

I configured a LAG into a stack composed by 2 x SG550X-48 (Units 1/2) and 2 x SG550X-24 (Units 3/4). The LAG1 is configured with LACP on GE3/4 and GE4/4 ports. The problem is that the GE4/4 port is ...
1
vote
0answers
134 views

Teamed port with activebackup and arp-ping link checking fails when one port dies

I have two machines which are interconnected over 2 ports and I want both ports to be teamed to have a single interconnect link. I've configured the team runner to be activebackup and the link state ...
-1
votes
1answer
3k views

Using bonding in debian 9?

debian 9 is installed by default without net-tools (deprecated). If you try to install ifenslave, it will install net-tools (i don't wan't this). How can i do this ?
1
vote
1answer
822 views

Network interface periodically going down with speed changed to 0 kernel errors

Over the last couple of days, the bonded network interface on one of our servers has stopped responding. Looking through the kernel logs, I notice when the interface goes down, we are getting lots of ...
1
vote
1answer
657 views

CentOS bond networking can't work after reboot

I create a NIC bond with two NICs with mode 6 in Cent OS 6.5. This is the configuration file: # cat /etc/sysconfig/network-scripts/ifcfg-bond0 DEVICE=bond0 ONBOOT=yes TYPE=ethernet BOOTPROTO=static ...
0
votes
1answer
119 views

Intel Network Card on Linux server - limited performance despite bonding ports

I took over a Debian 7 server with an Intel NIC where the ports are bonded together for load balancing. This is the hardware: lspci -vvv | egrep -i 'network|ethernet' 04:00.0 Ethernet controller: ...
0
votes
1answer
124 views

ethernet bonding in Centos 7 - testing without network connections

I'm configuring a Centos 7 box to do Ethernet bonding of 2 nic's. I've edited the ifcfg files by hand and said no to NetworkManager. But it's not coming up. I'd like to eliminate the config on the ...
0
votes
1answer
41 views

Is Level One's Trunking feature like LAG/Etherchannel or is it used for VLANs?

I have a couple of Level One GSW-2476 switches. They allow setting a port's membership in one of eight trunks. Up until now, I thought of trunking as being like LAG groups, i.e. load balancing/...
7
votes
2answers
879 views

Baffled with a simple bond throughput, can't get more than a Gig

I have DL380 server with QLogic Gigabit Ethernet installed. Simply trying to create a bond but can't seem to get throughout more than 1 Gig link. All 3 cables from 2 servers are connected to S40 ...