Questions tagged [centos]

CentOS is a free (as in beer and speech) GNU/Linux distribution that is community driven and based on source code released from RedHat.

2,034 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
8
votes
0answers
1k views

CentOS 6 local update repository and security updates

I know that official CentOS 6 (even 7) update repositories does not provide security information. The consequence is thatyum-plugin-security plugin and yum check-update --security command does not ...
8
votes
0answers
4k views

teaming with nmcli: bringing connection down and up again fails

On a centos 7 virtual box, I create a team like this: nmcli connection add type team con-name team0 ifname veteam0 nmcli connection modify team0 team.config roundrobin.conf [root@rhce1 ~]# cat ...
7
votes
1answer
6k views

How to use more than 3 virtual disks in Linux using CentOS and XenServer

I've attached 5 virtual disks to a Virtual Machine in Citrix XenServer. The VM has the xs-tools installed. Initially it said that it couldn't add so many disks. After I installed the xs-tools, it ...
6
votes
1answer
636 views

Intermittent munin-cron error “There is nothing to do here, since there are no nodes with any plugins”

We've installed munin monitoring on one of our servers. Generally it seems to be working well but occasionally, 4 times in 2 months to be exact, munin-cron has generated the following error: [...
6
votes
1answer
19k views

God Process Monitoring - CentOS - Event System Not Found

I have god installed on at least a dozen (or more) servers running CentOS 5.5 in both i386 and x86_64 flavors that work perfectly. I just setup two new CentOS 5.5 x86_64 servers and installed God, but ...
5
votes
0answers
2k views

Change default certificate signing algorithm in ssh-keygen

Presently, OpenSSH 7.8 (Fedora 28/Arch) is unable to negotiate with a OpenSSH 7.4 (CentOS 7) server utilizing a certificate signed key, as described in a bug filed on redhat's bugzilla. OpenSSH ...
5
votes
1answer
196 views

Server computational slowdown when RAM is used extensively

I have problem with server slowdowns in very specific scenario. The facts are: 1) I use computational application WRF (Weather Research and Forecast) 2) I use Dual Xeon E5-2620 v3 with 128GB RAM (...
5
votes
1answer
989 views

Proper way to override Mysql my.cnf on CentOS/RHEL?

Context: I'm porting an opensource server software (and writing associated documentation) from Debian/Ubuntu to CentOS/RHEL. For the software to run correctly, I need to add a dozen of specific ...
5
votes
0answers
381 views

Low Entropy on Container

I am thinking my entropy level may be low? $ cat /proc/sys/kernel/random/entropy_avail I am around 132-178 on average. Pool size is default 4096 (this is a container on a virtualizer by the way). ...
5
votes
0answers
3k views

Wrong filename encoding/decoding when downloading recursively with wget

I'm downloading files from a remote directory recursively using wget and whoever created the folders and files, used special characters such as è or Ó, when I download a single specificating the full ...
5
votes
1answer
4k views

L2TP over IPSec VPN with OpenSwan and XL2TPD can't connect, timeout on Centos 6

I'm setting up LT2p over IPSec on my Centos 6.3 fresh install. I have iptables flushed, permit all. Whenever I try to connect, i get a 'no reply from vpn' and nothi Here's my ipsec.conf file (...
5
votes
0answers
5k views

Corosync unicast issue with different nets

I'm using a setup (on our staging-system) with 2 root-servers and 1 fail-over-ip. As software we use corosync and pacemaker. Corosync is configured for multicast communication via port 5405. --> ...
5
votes
1answer
847 views

Are there RPMs for GlassFish v3?

It seems that the GlassFish project itself does not provide RPM packages, and neither does JPackage (http://jpackage.org/). Is someone else providing ready-built RPM packages for RHEL/CentOS? On a ...
4
votes
1answer
98 views

Kickstart password hashes from EL 6 and 7 not working in 8

Thanks to the answers to this question, I've been happily generating Kickstart files for Scientific Linux 6 and 7 for the past 5 years. However, we're now starting to build out some test systems with ...
4
votes
0answers
33 views

A little confusion about DBM files and how they work

I have apache 2.4 and am using RewriteMap DBM files. ie: <IfModule mod_rewrite.c> RewriteEngine On RewriteMap examplemap "dbm:/etc/httpd/conf/rewrite.dbm" RewriteCond ${examplemap:$...
4
votes
1answer
276 views

nano very slow over ssh

Recently nano has started to be very slow when editing files over ssh. It's particularly slow when editing large files with syntax highlighting. It's most noticeable when yanking lines. There can ...
4
votes
1answer
7k views

OpenSSL keeps telling me 'unable to get local issuer certificate'

I'm using CentOS, which has OpenSSL 1.0.2k-fips installed, and I've built and installed version 1.1.0g alongside it as part of a HTTP2 install outlined here: https://www.tunetheweb.com/performance/...
4
votes
1answer
1k views

CentOS virtual host Server DNS could not be found

I want to deploy my project in virtual host in CentOS running server. I have this <Directory /> #change value of next line from none to all AllowOverride none Require all denied </...
4
votes
1answer
1k views

AWS EC2 - CentOS 7 Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I have an EC2 Instance with CentOS 7, after rebooting and stop - start, the instance cannot run anymore. I got this error, what cause this and how to fix it, thank you: [ 1.601892] List of all ...
4
votes
0answers
396 views

How can I track down why the rpm DB on my servers keeps getting corrupted?

Running Centos 7 (various versions) The rpm DB on my servers keeps getting corrupted. It seems like every few weeks I have to do an rpm rebuild on a server or two. Where should I look to see what ...
4
votes
1answer
887 views

HSTS header not being sent though rule is present and mod_headers is enabled

We enabled HSTS in httpd.conf in the Virtual Host handling port 443. We tried with and without the <IfModule mod_headers.c>: <IfModule mod_headers.c> Header set Strict-Transport-...
4
votes
0answers
213 views

Bind notifies on DNS views

I have configured two Cent OS based DNS servers one for master and one for slave with internal and external views for a domain. The problem is that i get notifies and automatic zone updates when i ...
4
votes
0answers
823 views

HAproxy and nginx RTMP

I am trying to use HAproxy in front of an RTMP nginx server. It does connect but it does not play the video. I have 2 servers: one with nginx using RTMP and another one with HAproxy. This is the ...
4
votes
3answers
2k views

Redis: Error moving temp DB file on the final destination: Operation not permitted

I have a nodeBB install which relies on Redis as the data store. Its just a test install at the moment while I iron out any problems. The Redis instance stayed up for a few days but then fell over ...
4
votes
0answers
247 views

journalctl prints the entire system log when following

[root@utility ~]# uname -rv 2.6.32-042stab093.5 #1 SMP Wed Sep 10 17:39:49 MSK 2014 [root@utility ~]# cat /etc/redhat-release CentOS Linux release 7.1.1503 (Core) [root@utility ~]# journalctl --...
4
votes
1answer
275 views

NGINX Worker Process, Burst Read Speed to only 1918kb/s

I am running an NGINX/1.8 server on Centos6.6 with multiple worker_processes, however while observing iotop I notice they burst up to 1918kb/s Read speed and rarely if at all pass that limit. I want ...
4
votes
0answers
542 views

pppd terminated bya SIGTERM in Centos 7 — who's sending it?

Folks, I created a script to keep a persistent "emergency" connection with a 3G modem, so I can access my CentOS 7 makeshift server remotely if the usual network fails. Everything works for a few ...
4
votes
1answer
1k views

difference between ifdown, ifconfig stop and ONBOOT=no

my ifcfg-eth1 config as below DEVICE=eth1 TYPE=Ethernet UUID=5e4f36f8-14eb-4f0c-8fa9-3af9be3899a7 ONBOOT=no NM_CONTROLLED=yes BOOTPROTO=dhcp DEFROUTE=yes IPV4_FAILURE_FATAL=yes IPV6INIT=no NAME="...
4
votes
0answers
5k views

CentOS kickstart automated setup with parted / RAID

I'm trying to use parted to partition my entire drives automatically during the CentOS kickstart install, however, I'm getting two issues with my install. I want to kickstart my installs across ...
4
votes
0answers
728 views

Sendmail on CentOS 6, with SRS

I do some mail forwarding, but I'm also a big fan of SPF; I'm aware that I have a problem. While my mail server was running Centos5, I was using pysrs as a milter, and it worked well - but it hasn't ...
4
votes
1answer
1k views

Linux cgroups cpuset w/ subs causes cgconfig not to start

I am having a problem trying to separate 2 groups using cpuset subsystem. This works fine, however if i go to add a subgroup to that group (in this case -- user1), cgconfig will fail to start with "...
4
votes
1answer
278 views

tape changers on Centos 6 enter flurry of activity upon boot, at udev start

I have two tape-changer robots (Quantum Superloader 3), one with parallel SCSI connectivity, the other with SAS. They were connected to a Centos 5 server, and boot would proceed normally. They are ...
4
votes
1answer
708 views

Intranet corporate SSO for webapps against Active Directory

I am trying to plan and implement a SSO solution in a corporate environment that serves intranet web applications running on CentOS: Corporate portal (Drupal backend) Project management (Project.NET) ...
4
votes
1answer
164 views

Apache rewrite works under FreeBSD, not under CentOS

I have 5 production servers which are running FreeBSD 9.2, but we are planning on transitioning to CentOS. Because of this, I am attempting to set up some virtual machines to emulate our production ...
4
votes
1answer
2k views

CentOS7 systemctl calling ExecStop on reboot after my procceses are already killed

I have a systemd script which is as follows: [Unit] Description=My sites Before=shutdown.target reboot.target halt.target [Service] Type=oneshot ExecStart=/bin/bash -c '/etc/xxx/mySites start' ...
3
votes
0answers
330 views

Are there any known common causes of “Cannot kill process: Success!” in error.log?

Operating system: CentOS Linux release 7.6.1810 (Core) Error log: /var/log/httpd/error.log Apache version: Apache/2.4.6 In attempting to debug a PHP cron task, I am seeing some segfaults in error....
3
votes
1answer
160 views

OpenVPN Traffic Control on CentOS 7

I'm trying to give my OpenVPN some bandwidth limitation. I would like for example for each user give 10Mb/s for upload and download. I tried the following answer I found (Automatically Call a Script ...
3
votes
0answers
117 views

Libreswan Testbed in VirtualBox

I'm currently working to create a testbed in VirtualBox for two VMs with an isolated opportunistic IPSec network with LibreSwan. All services are coming up fine, but network traffic between the two ...
3
votes
2answers
150 views

CentOS 4.6 Time Drift

I have a CentOS 4.6 box that was previously a physical device, and has been made into a VM, that has a cronjob to restart the server everyday at 23:00. Which is fine. However, since the shift to ...
3
votes
1answer
2k views

Getting error when installing php in Centos 7.4 OPENSSL_1.0.2

I am trying for a couple of days to install php without any luck. The process which usually takes 2 minutes. I have CentOS 7.4.1708 and Apache 2.4.6. When I install php using yum install php and run ...
3
votes
0answers
2k views

How to make a RAID disk light blink (on Linux)?

I have a RAID10 hot-swap disk that is about to fail (according to smartctl -a /dev/sdc. The disk is mounted in a rack 4U server). Unfortunately, the disks are not marked, so I'd like to get the disk ...
3
votes
1answer
2k views

Is it possible to install Samba 3 on CentOS 7?

Trying to address a compatibility problem with Samba 4, that comes with CentOS 7, I consider downgrading to Samba 3. However, based on this page https://pkgs.org/download/samba, and elsewhere I ...
3
votes
0answers
81 views

Is it OK to prepare drives in mdadm RAID in LinuxMint live and then run CentOS7 installer?

I am planning to setup a CentOS7 server with software RAID. Since the CentOS7 installer isn't particularly good at preparing the disks, I wonder if it would be OK to boot up a LinuxMint 18 live, do ...
3
votes
0answers
48 views

Hyper-V Migration Windows 10

I'm trying to import an exported VM from a Microsoft Hyper-V instance running on a Windows 10 node to another Windows 10 node. As far as I know the 2 hosts are exactly the same in terms of hardware. ...
3
votes
0answers
2k views

Blocking ALL outgoing traffic Using firewalld to dedicated network subnets?

I have several RHEL7/CentOS7 servers on which I need to block all OUTGOING traffic to dedicated machines or dedicated network subnets e.g. CIDR 168.192.10.0/24. For the moment I tried with firewall-...
3
votes
1answer
495 views

Have Kickstart automatically generate a root password on install

I am currently working on multiple Kickstart configs for my company to allow for easy VM deployment. I cannot find any documentation showing how to have Kickstart generate a root password. Is it ...
3
votes
1answer
3k views

packets transmitted, 0 received (no internet connection) on centos 6.6 vps

I have centos 6.6 vps server. When I use command: yum update get error: Error: Cannot find a valid baseurl for repo: base when I check for ping and use command: ping -c4 google.com get error: ping: ...
3
votes
0answers
3k views

Centos 7 SSSD based user access stops working after AD password change

We use SSSD to provide AD authentication, and kerberos TGT acquisition, on Centos 7.3 build 1611. This works correctly for 99% of users most of the time, but we've hit an issue where post-password ...
3
votes
0answers
2k views

centos: fusermount: fuse device not found, try 'modprobe fuse' first

while trying to mount google bucket or set sshfs up I am getting following error: fusermount: fuse device not found, try 'modprobe fuse' first modprobe fuse command does not show anything: [user@...
3
votes
0answers
422 views

Can't backup Cisco configuration with tftp

I get the following error: SW-AL710-1#copy running-config tftp: Address or name of remote host []? 10.0.1.130 Destination filename [sw-al710-1-confg]? %Error opening tftp://10.0.1.130/sw-al710-1-...

1
2 3 4 5
41