Questions tagged [debian-buster]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
1answer
28 views

How do you port forward a privileged sub-1024 port to a non-privileged 1024+ port with firewalld?

The Question How do you port forward a privileged sub-1024 port to a non-privileged 1024+ port with firewalld? The Reason Why we are doing this? We want to be able to switch the non-privileged 1050 ...
0
votes
1answer
57 views

How do I forward all traffic arriving at a given port to another port?

How do I forward all traffic arriving at a given port to another port? Define the layout and the problem The layout Here is the layout of what I am trying to do... +--------+ +-----------------...
1
vote
1answer
1k views

After upgrade from Debian 10 Buster to Debian 11 Bullseye security updates 404 not found

Doing recommended upgrade path, TL;DR: Backup data, then apt update apt upgrade apt dist-upgrade reboot Also disable all non main stream packages if any. Then preparing APT for new distribution: sudo ...
1
vote
1answer
24 views

Reload Apache Using ACME User

I run a web server on Debian 10 (Buster) and Apache 2.4.38. I created a special user acme that runs scripts for renewing TLS certificates. $ cat /etc/passwd | grep ^acme acme:x:1002:1002::/var/acme:/...
0
votes
0answers
60 views

rsyslog seems to be triggering sdhci dumps when writing in external storage

Acording what I read, rsyslog is usually used to process logs and send them to another locations, either local (external storage, specific partition, etc.) or remote (logging server, for example). ...
2
votes
0answers
47 views

libreswan with Ikev2 client and plain text password

I need to set up a connection to VPN server with Libreswan. I can't use strongswan, since they are not working well together when installed on the same OC. My system is Linux Debian 10 (Buster) Kernel ...
0
votes
0answers
393 views

System has not been booted with systemd as init system (PID 1). Can't operate. ( Openvpn )

I'm pretty new to Linux and i'm still learning the ropes of it. I tried starting the openvpn service using both "systemd start openvpn@server" and "sudo systemctl start openvpn@server&...
0
votes
0answers
147 views

MariaDB crashes frequently

I'm suffering from MariaDB crashing issue for a weeks running on VPS Debian 10. I searched a lot in the internet ,but couldn't found any solution. I tried this , this, this etc... but seriously I didn'...
0
votes
1answer
174 views

Is it possible to install MySQL5.7 on Debian 10/buster?

I have tried two times and it always fails. According to this little guy debian stopped packaging mysql-client as of buster. I tried to cope with it by installing MariaDB but I struggle to find a ...
0
votes
1answer
140 views

Proxmox VE 6.4 kernel panic during backup to NFS/CIFS

For a few weeks, we experience systematic kernel crashes during the backup of two distinct Proxmox VE fully-updated 6.4 hosts running on 5.4.114-1-pve Linux kernel. Backups are using the stop mode and ...
1
vote
2answers
77 views

Rudder-Server can't receive pending nodes : There is no readable input file at '/var/rudder/cfengine-community/inputs/failsafe.cf'

I've installed Rudder-server on a debian buster container, the software works fine : every services rudder-* have active status without error and I can access the web interface. The debug rudder ...
0
votes
0answers
135 views

Installing Postgres 14 on debian buster from postgres apt repository

I'm trying to install the recently released Postgres 14 beta into a debian buster based docker image from postgres' apt repository. I'm using the following docker file: FROM node:15.4-buster AS build ...
0
votes
1answer
40 views

VPS Resolv And Static IP

I have a vps server hosted with an internationally, very well-known hosting provider, and oddly enough they seem disturbingly incapable of troubleshooting their own system. There are two specific ...
3
votes
2answers
182 views

rudder-relayd.service: Failed at step NAMESPACE - Permission denied

I'm trying to use rudder-server on a Debian buster at work, the webapp works fine but one of the rudder services does'nt work and I can't receive reports from other nodes : ● rudder-relayd.service - ...
1
vote
0answers
87 views

Separate server for gitlab-pages

I am trying to configure a setup, where gitlab-pages is being server from separate gitlab instance. I have followed steps described in official docs (all with NFS shares, and same UIDs on both ...
1
vote
1answer
54 views

Connecting to db via SSH on docker fails

I'm trying to connect to a database via SSH from my docker container. I'm getting an error could not connect to server: Connection refused Is the server running on host "0.0.0.0" and ...
0
votes
1answer
47 views

Bad configuration option: GlobalKnownHostsFile

My sshd refuses to start when I set the option GlobalKnownHostsFile. When I run /usr/sbin/sshd -T it says “Bad configuration option: GlobalKnownHostsFile”. Any ideas why this happens? According to the ...
-1
votes
1answer
30 views

Can I get ip lease from DHCP router for linux virtual interface?

I have a mikrotik router that acts as a DHCP server. I created some virtual interface on my raspberry pi using : interface eth0:1 static ip_address=192.168.88.5/24 static routers=192.168.88.1 static ...
0
votes
0answers
27 views

404s don't have trailing slashes

I have set up my site so that if someone tries to look at forbidden content they will get a 404 error instead of a 403, but when they do this, a trailing slash is added to the end of the URL. Also, if ...
0
votes
1answer
375 views

virt-install error to create instance in qemu-kvm

OS: Debian 10.4 libvirtd version: 5.0.0 Hello! I need to create a instance in qemu-kvm. With this command: virt-install --connect qemu:///system --virt-type kvm --name test01 --ram=2048 --vcpus=2 --...
0
votes
0answers
51 views

Debian 10 VPS inaccessible through SSH with linux-image-cloud-amd64 kernel

I can't log in through SSH when VPS is running the cloud-amd64 kernel from Debian 10. VPS boots fine, VNC allows logging into VPS and sshd shows active and running properly, but I can't SSH remotely ...
1
vote
0answers
25 views

Network interfaces get stuck and need to turn off/on to resume traffic

I am using Asterisk on Ubuntu 18.04 and on Debian buster. The network interfaces (for SIP Signaling and RTP) get stuck after sometime (2-3 hours) and need to turn off/on the interfaces to resume the ...
0
votes
0answers
86 views

change umask in profptd for sftp

I want to give group write permissions to new directories created by sftp, tried the following: set umask in /etc/proftpd/proftpd.conf Umask 002 002 disable sftp ...
0
votes
2answers
2k views

How to install mysql workbench on linux debian 10 (Google Pixelbook) [closed]

I first asked this question on StackOverflow but someone told me there that I have a better chance of getting an answer here I am trying to install MySQL Workbench on my Google Pixelbook. It runs ...
0
votes
0answers
141 views

Sending mail with msmtp failed -no such file or directory

at the moment I try to send mails with msmtp from my Debian Buster vServer to my mail address. I've installed and configured msmtp like many tutorials. But when I test it I just get the error message ...
0
votes
0answers
73 views

Nginx and secondary IP addresses on EC2 instance running Debian Buster

I have an EC2 instance running Nginx on Debian Buster. I added multiple private IPs to the instance (to allow nginx to host multiple websites) using the AWS web console. I then created the script /usr/...
-1
votes
1answer
55 views

Best way to lock out a group once per week [duplicate]

A SSH server I admin is to be allowed login from a group of users all days of week except sunday. How would be your elegant solution to this? Thanks any input on comments or creative +and+ secure ...
0
votes
0answers
25 views

ZFS Failed Multiple New Drives

It was decided to replace our aging primary NAS, consisting of three 48 drive SAS expanders of 4TB drives, with a similar system of 12TB drives while reusing some of the newer hardware, one expander ...
0
votes
1answer
608 views

zabbix : prob.... with defaults entries ; TTY=unknown ; PWD=/ ; USER=root ;

Zabbix sends me those annoying emails with body: zabbix : problem with defaults entries ; TTY=unknown ; PWD=/ ; USER=root ; Now I do not have sssd installed, nor do I have sss word in /etc/nsswitch....
1
vote
1answer
121 views

debian preseed select smallest drive for OS

So in my case I have a box with 2 drives 1 SSD small , usually 120 Gb and the rest bigger 500 or bigger, I need the OS always to be installed in the smallest drive and the second one to be left for ...
1
vote
2answers
32 views

New virtual host on apache returns the default vhost, other times returns the normal content

I'm having some really strange behaviour on one of my Debian servers. When requesting stuff.com ( example ) or stuff.com/image.jpg, let's say 50% of the times I have the correct response, the other 50%...
0
votes
0answers
42 views

LVM IO Errors Xen Guest (Buster)

I have been running diagnostics on all of my disks, and am down to 2 new seagate 4TB drives, and a Samsung EVO 850 SSD. These all report no errors when running a thorough diagnostic in the Dell Setup ...
0
votes
0answers
148 views

OpenVPN configuration works under CLI but not on NetworkManager (TLS handshake failed)

sudo openvpn --config [VPN-NAME].ovpn: works NetworkManager configuration: doesn't work (while being the same, copypasted config) [VPN-NAME].ovpn: dev tun persist-tun persist-key ncp-disable cipher ...
1
vote
2answers
857 views

Is it safe to apply fail2ban on sshd "Received disconnect/Disconnected ... [preauth]" logs?

I'm seeing a lot of logs like these in /var/log/auth.log (Debian Buster): Jan 2 17:10:17 mybox sshd[16304]: Received disconnect from 1.2.3.4 port 37792:11: Bye Bye [preauth] Jan 2 17:10:17 mybox ...
1
vote
1answer
139 views

KVM quests "stuttering"/"freezing" intermittently on Debian 10

I'm using KVM on Debian 10 as host and for now two guests that are Debian 10 as well. The guests are "stuttering" frequently, what I mean by that is that like at least several times an hour ...
0
votes
1answer
399 views

Tunneling cannot be enabled without the local_ip

I am trying to get an OS instance up&running on my local infrastructure (currently VirtualBox VMs only) using the official install-guides for Debian/Ubuntu as I am running on Debian 10 (Buster). ...
0
votes
2answers
672 views

Trouble installing packages from the Debian buster repository

Solved! See comments below for the solution. I'm trying to install i3 on Debian buster and it can't find the package. I'm not sure what I'm missing so I can install this package. These are the errors ...
3
votes
0answers
214 views

unattended-upgrades conffile prompt

To enable unattended-upgrades for packages which can show dpkg config change menu, one has to configure apt and dpkg with these config options: Dpkg::Options { "--force-confdef"; "--...
1
vote
2answers
64 views

BIND in a dedicated VM?

Recently I took up maintenance of another company network where BIND has been installed in a dedicated VM (ostensibly for security). The company uses Debian as a system for servers. I have to say the ...
0
votes
1answer
443 views

how does isc-dhcp-server start on debian 10 with systemd

I'm on a beaglebone black running a debian 10 console image. A bit of an odd setup that I have, but I need to make it run that way. The issue: isc-dhcp-server fails to start at boot, but does start ...
1
vote
0answers
551 views

Error installing chrome remote desktop on headless debian buster linux host

I have a debian buster host (not on Google Cloud) and I am following the steps in this tutorial: https://cloud.google.com/solutions/chrome-desktop-remote-on-compute-engine However, when trying to ...
0
votes
0answers
68 views

Booting Debian netinst over PXE with rescue mode

I configured booting Debian netinst minimum image over PXE. It works until I'm asked to select mirror to download release from. Whatever mirror I select, including deb.debian.org, it fails like this: ...
0
votes
1answer
140 views

Having startup messages on virtual tty (monitor) AND serial console

I have enabled serial console over null-modem cable in Debian 10 like this: /etc/default/grub: GRUB_CMDLINE_LINUX="console=ttyS0,115200n8" GRUB_TERMINAL=console then systemctl enable serial-...
1
vote
1answer
56 views

Boot without nftables | Debian 10

While rebooting our newest strorage servers, we're experiencing a kernel error (probably) caused by nftables. Please see attached call trace: After configuring the server (incl nftables), everything ...
2
votes
0answers
1k views

apt-get: libc6 upgrade needed but can't be installed; Kernel update needed but can't be done like anything else

Hello serverfault community! After upgrading to Debian Buster apt doesn't seem to work in any way. I've read and tried several solutions but none of these worked. Output when I try to install any ...
0
votes
1answer
351 views

Change password length for MariaDB

I'm currently working with mariadb and phpmyadmin on my debian 10 server. For some reason mariadb only allows passwords with a maximum length of 79 characters. If I specify a password that is longer ...
0
votes
0answers
29 views

Double // and triple /// in image urls,

I'm running an opencart website and I've noticed my images are loading in rather slowly. I copied the direct image link from the page and I've noticed something strange is going on. A sample of an ...
0
votes
1answer
220 views

Kernel IP forwarding not enabled for ethernet interface on boot

To enable IP forwarding on boot in Debian, you put the following in /etc/sysctl.conf: net.ipv4.ip_forward=1 I've done it thousands of times, and it has always worked without issues. But there is this ...
0
votes
0answers
186 views

realtek r8168 debian buster lost connexions on add-on card

We want to use 2 double port ethetnet card in lenovo M720e. cards are dexlan ref FG-ENW02C-1-UC04 / pcie 1x dual giga ports. we install debian 10. we change grub so we have ethX and not enpXs0. first ...
0
votes
0answers
69 views

Sendmail relay office365 (gmail works)

I have a virtual Debian 10 machine which I want to configure to send emails using office365 smtp relay. I set up and configured sendmail, but when I try to send a test email, the log file says DSN: ...