Skip to main content
OverflowAI is here! AI power for your Stack Overflow for Teams knowledge community. Learn more

Questions tagged [echo]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
-1 votes
2 answers
84 views

echo. is not recognised as the name of a cmdlet

I am observing an odd behaviour in PowerShell. I can echo hi but I can't echo. to get a newline: It does work in Command Prompt: One answer suggests that the .ps1 file might have a BOM in it. I ...
Danny Beckett's user avatar
-1 votes
2 answers
550 views

nginx echo while processing not working but the same server with apache can echo while processing

PHP 8 I'm using the newest NGINX feature un WHM 96.... I can flip switch on or off to have nginx cache everything and it's working well and very fast. **** BUT : when I have a script that does lots of ...
Jintor's user avatar
  • 139
0 votes
1 answer
321 views

assigning aliases in .bashrc via echo '...' >> .bashrc

running cat .bashrc gives me these two lines at the end: alias remove='rm -i' alias chamber='ls -a -i -l' when I run remove followed by a file name I get a successful removal with confirmation ...
Joel's user avatar
  • 1
0 votes
0 answers
514 views

How to use pam_echo.so in /etc/pam.d/sudo

I want to be able to echo a simple message in between password authentication and yubikey challenge response authentication when using sudo. I've tried multiple ways to do it, such as pam_echo.so and ...
David's user avatar
  • 101
1 vote
0 answers
35 views

If an echo from tunnel interface IP is successful but an echo from the tunnel interface source fails, is that an outage with ISP?

Trying to track down an outage. Our Cisco ASR has a tunnel configured as IP: 100.64.#.# Source: 192.#.#.# (Amazon DX block, this address is also configured as a loopback on another interface) ...
screampuff's user avatar
2 votes
1 answer
488 views

fdisk with a a single command fail in the second execution

I ran a script to format a disk with fdisk like this: (echo n; echo p; echo $number_part; echo $firs_sector; echo $second_sector; echo t; echo $format; echo p; echo w) | fdisk /dev/$disk when i ...
BrennQuin's user avatar
  • 135
1 vote
0 answers
686 views

xinetd: udp service returning just a string

I'm using xinetd to provide a simple service, that basically only needs to return a string value. The service is required to support tcp and udp. The tcp services looks like this, and works as ...
soey's user avatar
  • 111
0 votes
4 answers
251 views

Command echo still working as normal after removing

I want to remove echo command (which is located in /bin/echo), but the command echo still work as normal. When I use which command, it confirm that echo was removed /usr/bin/which: no echo in (/...
Waveter's user avatar
  • 574
-2 votes
1 answer
222 views

Add date using echo without calculating [closed]

I should add the line to /var/spool/cron/crontabs/root on my ESXi: /bin/echo "0 3 * * 6 /ghettoVCB-master/ghettoVCB.sh -g /ghettoVCB-master/text.conf -f /ghettoVCB-master/text.list > /var/log/...
A_buddy's user avatar
  • 35
1 vote
2 answers
91 views

Echo Variable - Same way, different output

I wrote a shell script with the following content: #!/bin/bash value=`cat test.txt` echo "Output: $value" >> currentOutput.txt By executing this script in shell, it writes correctly the value ...
Tyralcori's user avatar
  • 125
0 votes
1 answer
62 views

Find difference in file encoding

I am sending email from the cmd with msmtp for that I do cat > test1 << EOF >From: "Tester" >test >EOF cat test1 | msmtp [email protected] This works while: echo -e 'From: "Tester"\...
Nabil Sham's user avatar
2 votes
3 answers
23k views

Can't pipe echo to netcat?

I have the following command: echo 'HTTP/1.1 200 OK\r\n' | nc -l -p 8000 -c and when I curl localhost:8000 I am not seeing HTTP/1.1 200 .. being printed. I am on mac os x with netcat 0.7.1 Any ...
Tinker's user avatar
  • 171
5 votes
1 answer
939 views

`psql` expanded mode equivalency for `mysql`

Am frustated by things like: 0:33:1407402356:root@ahost:~# echo 'use wordpress_3_6_1; select * from wp_posts;' | mysql -u mysqluser -pmysqlpasswdord | wc -l -L 42 40585 SQL query results being ...
178024's user avatar
  • 36
24 votes
2 answers
43k views

Send echo message to graylog2 via GELF TCP 12201 port

I need to send a message to graylog2 server via echo to test if the %{@type} for facility is corrent, but once I do the echo thats in GELF support does not arrive in to my graylog2 server. If it ...
cr0c's user avatar
  • 988
1 vote
1 answer
157 views

How to generate a signature with a launchd plist? [closed]

Is it possible to implement the following shell script completely as a launchd plist to generate a signature with timestamp in the StandardErrorPath / StandardErrorPath files? #!/bin/sh echo "Hi, ...
user3077223's user avatar
1 vote
2 answers
3k views

Strip out the 'n' \ new line out of the echo to a file [closed]

I have a bash script that pulls a bit of text from an external MySQL database. Most of the times it are 4 lines, each one on his own line. This text (in total) has to be placed into a file. The script ...
Jona Koudijs's user avatar
57 votes
6 answers
119k views

How to automatically close netcat connection after data is sent?

I am executing the following command from a script: echo '{"hostUp": true}' | sudo /usr/local/bin/netcat localhost 8001 However, the netcat client stays open indefinitely. How can I close the ...
Justin Meltzer's user avatar
3 votes
2 answers
196 views

supress expansion of * in echo

I am working on a script which dynamically executes some queries on daily basis. These queries are coming from a table in the database. Here is the sample output of the query table: +---------------+...
divinedragon's user avatar
4 votes
2 answers
6k views

Getting error "Invalid command 'echo'..." when restarting apache when trying to use SSLPassPhraseDialog

Using a solution to another answer, I added the following to my apache config: SSLPassPhraseDialog exec:/path/to/passphrase-script And in that script, I placed this: #!/bin/sh echo "put the ...
David Legatt's user avatar
0 votes
2 answers
462 views

echo without newline

-bash-4.1# cat output "/root/mail/domain.com/root/Archive Dir.2012.04 April" for i in `cat output`; do echo "$i"; done "/root/mail/domain.com/root/Archive Dir.2012.04 April" I want them on a ...
w00t's user avatar
  • 1,164
1 vote
1 answer
189 views

echo + append string + linux

please advice how it can be - ( this action was on linux machine ) why the string - "append" that I add with echo is after the line "spb_IP=172.17.100.122" and not under the line - "spb_IP=172.17....
yael's user avatar
  • 2,473
0 votes
1 answer
134 views

How do I use the excape characters properly in csh's builtin echo command?

I'm trying to build my fstab during install with a script, so I want to have something like this: printf '# Device\t\tMountpoint\tFSType\tOptions\t\tDump\tPass#' >> /mnt/etc/fstab printf '\n/...
Utkonos's user avatar
  • 426
1 vote
1 answer
132 views

How do I use a shell builtin command rather than the system command?

I'm specifically asking about FreeBSD. I am using the default /bin/csh as my shell. There is a binary version of echo at /bin/echo, and there is an echo command built into the shell. The system ...
Utkonos's user avatar
  • 426
10 votes
2 answers
12k views

Need a live UDP echo Server IP and port

I require to test my UDP program using echo server. I have tested this application in LAN but now I require it to test it in Internet. Is there and globally recognize freely available well known ...
Amit's user avatar
  • 221
1 vote
1 answer
207 views

How to feed the variable with end of lines to standard input of other application in bash?

Is there a (simple) way to feed variable with end of lines to other program in BASH? Consider example: flist=$(ls -l) echo $flist echo will replace all end of lines with spaces, so my output will be ...
Alex Gitelman's user avatar
0 votes
2 answers
453 views

Issues with echo commands?

I run this script as quanta suggest me #!/bin/bash EDATE=$(tail -1 a | awk '{ print substr($4, 2, length($4)) }') EEPOCH=$(date -d "$(echo "$EDATE" | awk 'BEGIN { FS = "[/:]"; } \ { ...
matarsak's user avatar
2 votes
3 answers
6k views

Bash Script Echo -n

I am writing a bash script, and I want to echo a string, but without a newline automatically added to the end. Reading the man page it says the flag is -n. The problem is, when I do: echo -n "My ...
Justin's user avatar
  • 5,468
1 vote
2 answers
406 views

echo with each parameter on its own line

I would like an output similar to ls -1d, but I don't want to check if each file exists. I would prefer to just list the files. I could use echo, but echo only puts a space between files. How can I ...
700 Software's user avatar
  • 2,283
0 votes
1 answer
396 views

How to control echo reply source IP in suse linux

The Client, running Suse 10. The Server, also running Suse10, and is a Cluster with a float IP. Now there is a problem about the echo communication: Client send echo request server's float IP, and ...
Mingo's user avatar
  • 139
1 vote
2 answers
2k views

Lighttpd broken when serving from Virtualbox shared folder [closed]

I've got a lighttpd web server set up on a Debian 6 guest in Virtualbox 4. I've got the www directory in a virtualbox shared folder, so that I can develop a website in the Windows host. My problem is ...
KJ Tsanaktsidis's user avatar
0 votes
2 answers
1k views

diable display command output on screen?

when i write bash the output appear on th screen ....i don't want to display the command and the command output on screen how i can do it ?
Mohammad AL-Rawabdeh's user avatar
1 vote
2 answers
13k views

Strange problem with crontab and echo

$ echo -e "test1\ntest2" > logfile $ echo -e "test1\ntest2" >> logfile $ cat logfile test1 test2 test1 test2 $ rm logfile $ crontab -e * * * * * echo -e "test1\ntest2" >> logfile $ ...
aidan's user avatar
  • 615