Last call to make your voice heard! Our 2022 Developer Survey closes in less than a week. Take survey.

Questions tagged [fork]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
42 views

In Linux/bash how can I prevent asynchronous commands?

I have a makefile that calls external build scripts. Some of these scripts (which I can't change) make use of commands that are forked / backgrounded (or asynchronous as the bash manual names them) ...
user avatar
  • 348
1 vote
1 answer
2k views

Docker-compose // OCI runtime create failed // pthread_create failed

Recently I have rent a VPS as private playground and for learning docker. I want to host a few webservices behind nginx-proxy together with docker-letsencrypt-nginx-proxy-companion. Setup The Server ...
user avatar
  • 148
0 votes
1 answer
898 views

Hitting a process limit, but unsure how

I run a server, mostly for using with random Docker containers and as a Gitlab-CI runner. Every once in a while, when the server has been running for a week or so, I run into process resource limits. ...
user avatar
  • 161
0 votes
1 answer
58 views

Unable to fork children even after exiting previous ones

I have a CentOS VM on which I'm running a php socket server, that forks on every connection. The child process does its job and then exits. The parent is also waiting to reap the dead zombie process (...
user avatar
1 vote
1 answer
532 views

Do Zombie Process have adverse effects?

Yes, I have gone through a lot of answers, but they don't really specifically say if Zombie Processes will have any adverse effects in the longer run or not. I have an application that creates a ...
user avatar
0 votes
2 answers
839 views

Is there any way to start mongo-connector in linux as a background process?

I am using mongo-connector to synchronize data between MongoDB and SOLR. I am working in RedHat 7 OS Server, I wanted to run the mongo-connector command as fork process in Server OS, since i need a ...
user avatar
2 votes
0 answers
33 views

Forking loads disk

I have a prefork/fork daemon. By atop I see, that master-process often consumes disk: PID TID RDDSK WRDSK WCANCL DSK CMD 16830 - 7264K 48696K 18624K 10% our daemon From strace I see, that it ...
user avatar
2 votes
2 answers
433 views

Find out what processes are forking

My server seems to be a bit slow, so I decided to install munin to see what is happening. One statistic that stands out is that the server is forking 50 times a second, which seems a little excessive ...
user avatar
20 votes
5 answers
40k views

APT FATAL -> Failed to fork

I saw a lot of questions regarding this, but mine seems a little different. Here's what I receive: /etc/cron.weekly/apt-xapian-index: FATAL -> Failed to fork. run-parts: /etc/cron.weekly/apt-...
user avatar
0 votes
0 answers
273 views

fork/vfork are failing but return an out of bounds errno

I have a piece of software running on a 64 bit Cent 5.8 Final box, kernel 2.6.18. This piece of software using fork and vfork. Recently some failures occurred, and in my logging I can see that fork ...
user avatar
  • 192
0 votes
1 answer
137 views

How Puppet handles manifests in terms of processes?

I want to find out how Puppet handles manifests: in master process or Puppet forks it to execute in child process? It necessary for me to know what exactly do puppet master while handling manifests, ...
user avatar
  • 397
-2 votes
2 answers
230 views

Ignoring fork-bomb in Ubuntu [closed]

I got an homework assignment to write a program that checks how many process a user can create (working in Ubuntu). I wrote the code which seems fine in theory. The problem is that when I run it, the ...
user avatar
  • 1
3 votes
3 answers
248 views

How do you manage software's local forks?

As a system administrator, I often have to modify programs for my company. Example: We're using an web interface to manage our local DNS. After downloading and extracting the tar.gz file from the ...
user avatar
  • 1,326
2 votes
1 answer
225 views

Upstart, no feedback whether starting failed

I have a daemon in /opt/xyz/bin/xyz. Unfortunately it cannot fork itself into background and will not be able to do so within the next half year. My problem is the following: Entering service xyz ...
user avatar
8 votes
1 answer
5k views

Rsync and "ssh_exchange_identification: Connection closed by remote host"

I have a script which rsync's a local directory to about 10 remote servers. It basically has a list of the servers and for loops through each of them doing the rsync. To speed up the process I have it ...
user avatar
0 votes
1 answer
1k views

Forking and memory allocation question

I have inherited a Perl script that runs on an EC2 instance which basically crawls a bunch of URL's for data (aka scraping). The way this script is invoked is via a shell script that forks multiple ...
user avatar
  • 103
-1 votes
1 answer
2k views

How can I know the maximum allowed number of forks for a process in Ubuntu?

I am using process control in PHP to create forks. My server's operating system is Ubuntu. How can I know what is the capacity of my server in handling those forks? Is there a limit? And if so, can I ...
user avatar
1 vote
1 answer
5k views

fork: Resource temporarily unavailable running JVM

I'm running a Tomcat 6 instance on a 34 GB EC2 instance. I've been struggling to keep the memory down but this thing services a lot of requests and the heap frequently gets up to 13 GB. But the heap ...
user avatar
  • 411
22 votes
4 answers
8k views

What's the best way to clean up after a fork bomb?

$ ls bash: no more processes Uh oh. Looks like someone made a fork bomb. Where I used to work, this pretty much meant that the shared server would need to be power-cycled, since even the sysadmins ...
user avatar
  • 987