Questions tagged [hostkey]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer

Host key changing during reboot

I have four Azure VM machines running Ubuntu 20.04.3 that I regularly shut down. Yesterday I shut them down, and early today I restarted them. Usually this presents no problems. Today, one of the ...
  • 4,000
1 vote
1 answer

Adding a ssh host key for a server name to `known_hosts` idempotently?

ssh-keygen -R $HOSTNAME can remove the ssh host key(s) from one's known_hosts. Can I add a specific host key (for a hostname/ip) to a known_hosts in an idempotent way? I want to script ssh'ing into a ...
  • 30.3k
2 votes
2 answers

Google cloud server ssh host key changed unexpectedly?

I have a Google cloud server that currently runs Ubuntu 16.04. I have not done much to it in years and it always ran great. Somehow or other, for the first time, it experienced downtime today of ...
2 votes
1 answer

autofs can't mount a remote dir with sshfs on the host with deprecated key algorithm

Here is my configuration: /etc/auto.master /mnt/10 /etc/auto.10 uid=0,gid=0,--ghost /etc/auto.10 root -fstype=fuse,allow_other,follow_symlinks,ssh_command=/etc/ssh/ :sshfs\#...
  • 185
12 votes
3 answers

SSH host key checking cannot disable when using proxy jump

I am trying to SSH through a jumpbox, but SSH seems to be intent on checking host keys for the jumpbox, even though I'm telling it not to, using the normal -o StrictHostKeyChecking=no -o ...
  • 529
1 vote
1 answer

Upgrade path for HostKeyAlgorithms

I'd like to change the default setting for HostKeyAlgorithms for all SSH connections to prefer ssh-ed25519 over ecdsa-sha2-nistp256. But I currently have ecdsa-sha2-nistp256 host keys for many hosts ...
1 vote
0 answers

Warning: Remote host identification has changed (SSH)

Most likely someone did a server update last night, because when I try to do a rsync (from win 7) I get the message (short version): WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! It is possible ...
  • 275
5 votes
2 answers

What could cause an SFTP host key fingerprint mismatch?

A remote user has tried to connect to my SFTP/SSH server for the first time, using the "Transmit" client under Mac OS X, and has found that the host key fingerprint doesn't match the expected value. ...
  • 395
20 votes
1 answer

ssh command line specify server host key fingerprint

Using ssh command line (OpenSSH), can I specify the server's host key fingerprint? This is possible with using (e.g.) -hostkey="ssh-rsa 2048 AA:BB:CC...etc I have read the man page a ...
  • 303
0 votes
2 answers

Ignore or replace host key if it differs

Quite often i put servers into a rescue mode and that obviously changes the host key. So there are situations when i know that SSH host key will be changed temporarily or permanently. And each time i ...
  • 33
15 votes
2 answers

Why does Google recommend removing SSH keys from GCE for security?

The below reference to Google documentation is no longer true. Google recommends removing SSH keys from GCE instance to secure SSH. That does not make any sense to me. The keys are there for a ...
4 votes
2 answers

SSH key and ip address

A co-worker keeps mentioning SSH keys being associates with an IP address but Im not sure what it exactly means. So i tried generating a SSH key and it had my host name at the end of the file. This ...
  • 187
9 votes
2 answers

SSH host key seems to be changing unexpectedly

I rolled out a new /etc/ssh/sshd_config with Puppet on an Ubuntu 12.04 test server. The config was exactly the same as the previous config, except it had removed the following line: HostKey /etc/ssh/...
  • 93
2 votes
1 answer

Known Hosts ECDSA Host Key Multiple Domains on One IP

Hello, world!, I have a VPS set up with multiple domain names pointing to it. Arbitrarily, I like to access it via SSH through the domain name I'm dealing with. So for example, if I'm doing ...
  • 169
4 votes
5 answers

How to allow SSH host keys on Linux (Fedora 10 & CentOS 5.2)

I'm trying to set up SSH host keys from our Mac OS X 10.5 Leopard Server-based central backup server to our two Linux servers running Fedora 10 and CentOS 5.2. The process we usually take works and ...
  • 1,460
63 votes
6 answers

How to remove strict RSA key checking in SSH and what's the problem here?

I have a Linux server that whenever I connect it shows me the message that changed the SSH host key: $ ssh root@host1 @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ WARNING: ...