Questions tagged [kvm-virtualization]

KVM (for Kernel-based Virtual Machine) is a full virtualization solution for Linux on x86 hardware containing virtualization extensions (Intel VT or AMD-V). It consists of a loadable kernel module, kvm.ko, that provides the core virtualization infrastructure and a processor specific module, kvm-intel.ko or kvm-amd.ko. KVM also requires a modified QEMU although work is underway to get the required changes upstream.

650 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
4
votes
0answers
872 views

How to set Rx Queue = N in linux / in Qemu / KVM?

I have configured 8 multiple queues on my CentOS VM box (running on KVM). <interface type='direct' trustGuestRxFilters='yes'> <source dev='ens113f0' mode='passthrough'/> <model ...
4
votes
0answers
545 views

KVM: What is stored in var/lib/libvirt/qemu

My Question is "What is stored in the /var/lib/libvirt/qemu folder?" Is this used as somekind of backup folder ? Backgroundinformation: I have a Debian Server with a running KVM installation(+libvirt)...
4
votes
0answers
375 views

Convert qemu syntax to virt-install or virsh xml

I have parameters for qemu-system-x86_64, which attach unix socket as interface into VM: qemu-system-x86_64 -chardev socket,id=char1,path=/tmp/sock0,server \ -netdev type=vhost-user,id=...
4
votes
0answers
2k views

Libvirt & USB Hub Passthrough

I have a virtual machine which I wish to have a USB Hub and all of its devices allocated to a virtual machine. The Hub in question is a USB hub which itself is plugged into one of the ports on the ...
4
votes
2answers
2k views

Creating a virtual network for KVM guests spanning multiple host machines

I have 5 physical machines running Ubuntu 14.04, all of them are together in a network. These all have static IP addresses. Each of these machines has 1 to 4 virtual machines via KVM/QEMU running ...
4
votes
3answers
12k views

Promiscuous mode in KVM

I have cloud system based on Openstack Icehouse-version. Now I want to test newer version of Openstack (Juno) inside my existing cloud. All hosts and guests use Ubuntu 14.04 as their OS. KVM is ...
3
votes
0answers
848 views

Windows 10 KVM guests cause Ubuntu 20.04 host to crash (revised)

I got extremely confused and decided to re-write the question from scratch, so if some of the comments do not make sense, that is why. Apoplogies to anyone whose time I wasted. I am having a problem ...
3
votes
0answers
493 views

Connect from Windows host to QEMU inside Docker

I am trying to establish a connection between Windows 10 running Docker container (Linux), which runs QEMU to host a QNX OS. This picture should make it more clear: Structure I would like to ...
3
votes
0answers
447 views

How to provision DRBD to libvirt storage pool?

I want to expose DRBD replicated storage (2 nodes Active/Passive) to libvirt as a storage pool for qcow2 files. However, I have the following error message: virsh pool-create-as qcow2 --type=logical -...
3
votes
0answers
996 views

Qemu packer ssh failed connection reset by peer

I am trying to get packer to create a qemu/kvm image. I feel like it should be fairly straightforward but my build keeps failing on ssh. Here are the relevant files template.json: { "builders": [ { ...
3
votes
0answers
2k views

QEMU USB passthrough is not working

I stuck at getting USB passthrough working with Windows 8.1 guest OS on Ubuntu Server 14.04. I started by installing qemu using the Ubuntu Documentation (https://help.ubuntu.com/community/KVM). The ...
3
votes
0answers
1k views

KVM NIC passthrough “device already in use”

I have a server with 2 NICs 01:00.0 Ethernet controller: Intel Corporation Ethernet Controller 10-Gigabit X540-AT2 (rev 01) 01:00.1 Ethernet controller: Intel Corporation Ethernet Controller ...
3
votes
0answers
3k views

Please help recovering lost volume group

After a reboot, the volume group on my server completely disappeared. [root@dal01 log]# vgdisplay No volume groups found [root@dal01 /]# lvdisplay No volume groups found [root@dal01 ~]# pvdisplay (...
3
votes
0answers
859 views

How to configure opennebula for allowing a cluster private network to host images with public IPs

I am installing open nebula 3.4.1 for running virtual machines a (kvm based) cluster made of 5 computers: a front-end machine having 2 network interfaces and 4 slaves machines with a single network ...
3
votes
1answer
747 views

KVM guests are very slow after host upgrade to Debian Squeeze

Yesterday I upgraded a Debian Lenny server to Squeeze. This server hosts two KVM guests. One has run Debian Squeeze itself all along, the other was originally Debian Lenny, upgraded to Squeeze the day ...
3
votes
1answer
313 views

KVM QEMU looses USB devices

I have a KVM Qemu setup. I'm mapping a USB device to a VM running windows vista. I get the device mapped, and all is well for some time. Suddenly the device disappears in Vista. If I do "lsusb" in ...
2
votes
0answers
51 views

Same sysctl kernel parameters for KVM host and guest

I need to set up a KVM guest with the following sysctl kernel parameters: net.core.rmem_max = 16777216 net.core.wmem_max = 16777216 net.ipv4.tcp_rmem = 4096 87380 16777216 net.ipv4.tcp_wmem = 4096 ...
2
votes
0answers
46 views

How to diagnose and fix issues causing libvirt guests to become unbootable after many reboot cycles?

I have encountered a couple of times that a previously functioning Guest simply starts freezing on boot. (I have now reverted my VM to a previous working snapshot, so I cannot directly start up the ...
2
votes
0answers
85 views

Debian KVM Server - Add Secondary Subnet

I have a Debian 10 server (from Hetzner) that I want to set up as a KVM host to set up virtual machines for myself. The server itself has a static IP like so: auto lo iface lo inet loopback iface lo ...
2
votes
1answer
183 views

ubuntu KVM guest with no network connection after configuring network bridge

I am trying to add KVM guest (Ubuntu 18.04) to local network like other real servers in the network. I configured KVM bridge interface in the host system (Ubuntu 18.04) and it works fine with ...
2
votes
0answers
501 views

KVM live migration for non shared storage

I am trying to live migrate my KVM based VM from one host to another for non shared storage using virsh migrate. I have set both the hostnames at /etc/hosts on each of the host. Also I have set ...
2
votes
0answers
82 views

Virtual machine network issue with host and ping service checks (within Nagios Core and from command line)

I have got a Ubuntu server guest virtual machine (installed via virt-install) which runs Nagios Core monitoring but there is a major issue with the monitoring (i.e. ping packet loss / RTA or ...
2
votes
0answers
657 views

virt-install Couldn't find hvm kernel for Ubuntu tree

I'm trying to create a VM using KVM and virt-installer. When i use virt-install I get the following error: Starting install... Retrieving file .treeinfo... ...
2
votes
0answers
356 views

Repeated loss of network connectivity to QEMU/KVM/virt-manager VM

I'm having frequent network connectivity failures under the QEMU/KVM/virt-manager stack on openSUSE Leap 15.1. I have a single VM running a software firewall, which is losing connectivity every few ...
2
votes
1answer
1k views

Inter-Guest Network in KVM without a Bridge

I would like to have a psuedo-wire between two guests in KVM. I cannot use a bridge of any type as the guest VMs are actually virtual switches themselves. Conceptually, it seems that a veth-pair is ...
2
votes
1answer
820 views

How can I make my libvirt/KVM guest see all IPv4/UDP multicast traffic?

I have an issue with IPv4/UDP multicast traffic not being fully visible from within a KVM guest. The guest has a dedicated NIC which is attached using MacVTap. Both the host OS and the OS in the ...
2
votes
0answers
45 views

I'm getting error during HA configuration for KVM on CentOS

After adding all nodes and resource agents in my cluster I'm getting this error please someone suggest me something. Please take a look in the image-
2
votes
0answers
1k views

Migrating from libvirt + iptables to libvirt + nftables

I'm about to migrate a Debian Stretch host using qemu-kvm to Debian Buster. I've seen people complaining on the Internet about issues due to nftables becoming default in place of iptables and libvirt ...
2
votes
0answers
386 views

QEMU-KVM bug: guest interface locks up a core with soft interrupts

Bug: I have a qemu-kvm on Ubuntu (host 14.04.5 LTS 3.13.0-95; cannot upgrade; , guest Ubuntu 18.04.03 LTS 4.15.0-65) Guest has two network interfaces, directly (VEPA) connected to two separate host ...
2
votes
0answers
1k views

Configure netplan to use a different interface for bridge

I'm setting up a virtual machine host on Ubuntu 18.04.3. I installed KVM and have succesfully set up a qemu vm which connects through a bridged network. It shows up as a regular machine in my network. ...
2
votes
0answers
348 views

How to fully emulate VM hardware?

How do I fully emulate, pass through, or spoof all the hardware for a virtual machine? I want to set up a few guest VMs in such a way that they do not have any special drivers or odd hardware info. ...
2
votes
0answers
2k views

XP KVM stuck at “Booting from Hard Disk”

Just to see if it could be done (and if so, move other physical XP machines to VM environments), I took the hard drive out of a decommissioned laptop, captured a WIM of it, and applied it to a QCOW2 ...
2
votes
0answers
861 views

Kernel panic when booting qemu virtual machine

I usually install template virtual machines on a dedicated server and then copy the disk to other production servers. It has worked for years and still works today in all cases but one. I have ...
2
votes
0answers
263 views

Is it possible to capture traffic on host when using KVM passthrough?

I have a KVM guest which uses PCI passthrough for its network interfaces: <hostdev mode='subsystem' type='pci' managed='yes'> <source> <address domain='0x0000' bus='0x05' slot='...
2
votes
1answer
1k views

centos 7 kvm error trying to guestmount qcow2 image

I have a CentOS 7 KVM host. A partition on one of the VM's seems to be corrupt. Image is qcow2. When trying to mount the image to troubleshoot I receive the following error: [root@vmhost02 images]# ...
2
votes
0answers
565 views

KVM/QEMU: cannot attach-device (disk) to a live domain

I'm trying to add a new disk to a running guest/domain (Win10) I succeed in using virsh attach-disk... --live and also using virsh attach-device.. --config But using: virsh attach-device SRV13 /tmp/...
2
votes
0answers
490 views

Frequent page allocation failures on a KVM

Lately my server has been going down quite often. It happens almost every day early in the morning. Looking at the syslog, I found a lot of these: Oct 11 06:51:12 pleskvm kernel: [1895007.359087] ...
2
votes
0answers
2k views

KVM/QUEMU guest slow disk performance

I'm really confused of QEMU/KVM behavior. I have a server - about 100GB RAM, 2 CPU - 6 core + HT, and three HDDs - one for root, and two for BTRFS-mirror for virtual machines (HGST HDN724030ALE640 if ...
2
votes
0answers
82 views

Convert VM (redhat virtualization 3.5) to a physical server

I have a virtual machine running on red hat virtualization 3.5, i need to convert that VM to a physical server. (mainly due to a performance issue) my volume groups as follows NAME ...
2
votes
0answers
3k views

Ubuntu KVM - Can't access network through bridge from guests, no DHCP, no ping

I have a laptop running Ubuntu 16.04.3 LTS graphical (so has Network-Manager et al installed). I think I've got KVM and QEMU installed correctly. When trying to set up a Debian VM from the netinstall ...
2
votes
0answers
905 views

Ubuntu KVM virsh console domain connects, but does not load console

I installed a copy of Ubuntu 17.04 using virt-install, on my server (non desktop). sudo virt-install --connect qemu:///system -n wiki -r 4096 --vcpus=2 -f /dev/mapper/vgpool-wiki --network=bridge:br0 ...
2
votes
0answers
2k views

Linux KVM QEMU Host with high CPU load

I have a machine running Ubuntu 16LTS with KVM/QEMU for a hypervisor. It has 1 guest running right now (A Ubuntu Server) that is using less than 1% of it's CPU and about 100MB of the 1000MB RAM ...
2
votes
0answers
3k views

No network connectivity in KVM guest

I'm attempting to set up my first guest set up under KVM and am having trouble getting the network working. The host machine "vm_host_box" has a static IP of 4.4.4.185. The guest I am setting up ...
2
votes
1answer
960 views

(KVM on Centos 7) Cannot ping to Guest or vice versa with single NIC Host

I have single NIC Host on Centos 7, which I want to make virtualization using KVM-Qemu. HOST The Host IP is 192.168.1.110 and the interface is enp0s31f6 I have deleted the "default" NAT ...
2
votes
2answers
308 views

Bridged routing with KVM and independent IP addresses

I have a dedicated Server (at Hetzner), with Debian Jessie and und KVM for virtualization. For the two Virtual Machines I have two additional IP addresses (with extra MAC addresses), which are not ...
2
votes
0answers
549 views

kvm virtio disk performance scales badly with iozone workload

I'm conducting a number of tests in order understand why some of our workloads generate a really poor "user experience" with db related activities. We have a dl160g9 server with a B140i controller (4 ...
2
votes
1answer
652 views

Routed bridge networking for KVM guests along with eth1 alias interfaces for shared hosting with dedicated IPs for each virtualhost

First question here on serverfault, so kind of a newbie, all feedback is welcome. I have a dedicated server running Debian GNU/Linux 8.4 (jessie) with one public IP and multiple additional public IPs ...
2
votes
0answers
3k views

Linux swap partition not mounted by systemd on boot after dist-upgrade

Recently, I performed a dist-upgrade from Debian Wheezy to Jessie. The upgrade was performed without any error but after the upgrade the swap partition was no longer mounted/activated. The mentioned ...
2
votes
1answer
1k views

How can I reconfigure a Linux guest in Proxmox to use a virtio-based HDD instead of IDE?

I'm running Proxmox 3.3.1 to host a virtual machine running Linux (64bit, kernel version 3.2.0). The virtual machine uses a 512GB HDD which was unfortunately configured to use the ide driver when ...
2
votes
0answers
1k views

Proxmox/KVM: Can not clone VM

I would like to create a clone of a KVM machine - yesterday I was able to create a clone of the same machine within some minutes. Now it takes hours and is still stuck an "0%": create full clone of ...

1
2 3 4 5
13