Questions tagged [libc6]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
3answers
300 views

Can't upgrade certbot because of libc6 version

I am trying to update Certbot from 0.10.2 to some version with support to ACME 2 in Debian 9.1 with Python 2.7.9. apt-cache policy certbot certbot: Installed: 0.10.2-1 Candidate: 0.28.0-1~deb9u2 ...
0
votes
1answer
1k views

libc6 dependency mismatch in Debian 9.12 stretch

I have the following libc6 dependency problem in Debian 9.12 stretch. sudo apt install libc6-dev Reading package lists... Done Building dependency tree Reading state information... Done Some ...
0
votes
0answers
183 views

librt.so not found: usr/bin/ld: cannot find -lrt

I tried to compile a project that uses librt library. However, I get an error in the make phase indicating /usr/bin/ld: cannot find -lrt. /usr/bin/ld: cannot find -lrt collect2: error: ld returned 1 ...
0
votes
0answers
770 views

Downgrade to previous Linux kernel or libc6 version on OpenVZ (libc6 issue)

Recently i've tried to upgrade my server OS from Ubuntu 16.04 to Ubuntu 18.10, then i've found out that i'm on OpenVZ virtualization and it's impossible and stuck in the middle. Now apt-get install/...
0
votes
1answer
372 views

Debian Packets fix - locale not working - cant install packets - Librarys broken

I did something horrible and hopefully didnt destroy my Debian 9 Strech... I googled like 2 Hours to fix this but nothing has helped... What I Did: my ClamAV was outdated, and I added a testing ...
8
votes
3answers
35k views

safely upgrade glibc on CentOS 7

I've tried a python application on my CentOS machine and it gives me the following error: ImportError: /usr/lib64/libc.so.6: version `GLIBC_2.18' not found (required by /tmp/_MEI2BYIr4/libstdc++.so.6)...
0
votes
1answer
329 views

Is it possible/advisable to try and update libc6 without rebooting the machine?

I want to update the libc6 package on a running production server without incurring downtime. AFAIK pretty much everything on the system depends on libc6 either directly or indirectly: $ sudo apt-...
2
votes
0answers
944 views

Segfault in libc-2.19.so with Webmin

I recently upgraded the kernel one of my Debian 8 servers which has Webmin+Virtualmin installed on it. The server had usual Virtualmin backups setup which used to work fine before the upgrade, but ...
2
votes
0answers
364 views

debian wheezy requiring libc6 >= 2.14

Yesterday I tried to upgrade my debian wheezy to jessie version and it was unsuccessful - server does not boot anymore. I connect to shell, tried to reverse upgrade, but unfortunately, made everything ...
4
votes
0answers
7k views

CURL PHP can't resolve host [closed]

I'm trying a php script that is doing requests with CURL. But I get the error Couldn't resolve host 'example.com' $ch = curl_init(); curl_setopt($ch, CURLOPT_HEADER , true); curl_setopt($ch, ...
1
vote
1answer
638 views

“broken packages” when using apt-get

I've tried to install MIME::Base64 with cpanm, which gives me the error that sys/types.h is missing. I then try to install libc6-dev which fails with the error message Reading package lists... Done ...
1
vote
2answers
2k views

Unable to install libtirpc1 due to dependecies error

I want to run some binary (which is definitely working on another PC) on virtual Debian PC. Debian 7.5 stable with added testing and unstable repositories. (I'm not an expert in this) This binary uses ...
1
vote
0answers
1k views

libc/libcstdc++ issue - GLIBC_2.18 not found

After some package update on my Debian (Sid) machine I started to experience errors like: Error message from server: ERROR: could not load library "/usr/lib/postgresql/9.1/lib/postgis-1.5.so": /lib/...
-3
votes
1answer
2k views

libc6 was broken. fix it

After updating python version libc6 was broken on my Ubuntu 12.04 I have libc6 2.18-4 and it broken. It was installed from unstable repo. From precise repo I see 2.15.0 version of libc6. But if I ...
0
votes
2answers
314 views

Ubuntu 11.04 no command working anymore

I accidentally removed libc6 and now every command returns "No such file or directory" example: "bash: /bin/ls: No such file or directory" Is there anything that can be done to reinstall libc6? P.S....
6
votes
4answers
16k views

Can't upgrade libc6 on Debian Wheezy

I tried to upgrade few packages and then it's failed on libc upgrade. And now it's impossible to upgrade anything at all. here's things I've done: # apt-get dist-upgrade Reading package lists... ...
0
votes
1answer
3k views

Debian apt dependency mismatch (libc6)

Earlier, I tried to install package via apt-get (cython), but it failed with the Errors were encountered while processing: message, and since then, apt is refusing to install anything. apt-get check ...
0
votes
2answers
1k views

Can't work with server after modifying /lib/libc.so.6

I have a CentOS server, VPS. After running this command I can't work with server and get the same error in all actions (SSH, Login, ls and ...) The command: ln -s /lib/libc.so.1 /lib/libc.so.6 -f ...
3
votes
2answers
487 views

Broke /lib64, salvageable? (ubuntu/mint12)

In a misguided attempt to recompile ld with debug symbols, I ended up with a /lib64 that was not symlinked to /lib (Debian 64-bit libs are in in /lib/x84_64-linux-gnu). I attempted to reinstall libc6 ...
0
votes
2answers
758 views

Broken Dependencies on Debian

Currently running Debian Lenny (5.0.9). I added the following test repos to install a specific package; deb http://ftp.debian.org/debian/ testing main contrib deb-src http://ftp.debian.org/debian/ ...
0
votes
2answers
2k views

Debian Stable: Can't update kernel, libc won't update

I use Debian Stable (squeeze) on a virtual host where I can't touch the kernel, it's stuck (and will be for some time as support told me) at Linux 2.6.18-028stab070.3 #1 SMP Wed Jul 21 18:33:27 MSD ...
7
votes
6answers
5k views

Unable to force Debian to do unattended install… libc6 wants interactive confirm

I'm trying to create a script that forces a Debian Lenny install to install the latest version of CRAN R. During the install it appears libc6 is upgraded and the install wants interactive confirm that ...