Questions tagged [libvirt]

libvirt is an API and toolkit for developing applications which manage virtual machine hypervisors, the virtual machines running under them, and virtual machine storage.

Filter by
Sorted by
Tagged with
4
votes
3answers
3k views

Restrict access to KVM virtual machines to specific users

On my server I have a KVM virtual machine called "cards2". It was created by executing (as root): # virt-install --connect qemu:///system --virt-type kvm --name cards2 --ram 2048 --disk /var/kvm/...
1
vote
1answer
174 views

libvirt TCP tunneled network only works for 2 VMs

I'm setting up some VMs with libvirt (qemu driver). One VM is meant to be the gateway and is thus configured with two network interfaces. One interface is bridging into my real LAN and the other uses ...
0
votes
1answer
741 views

SCSI virtual disks not showing up on RHEL 7.X KVM guests

For whatever reason I can't get my virtual disks to show up on any of my RHEL 7.X guests (libvirt + KVM). The XML is configured just like my other guests so I know it isn't an issue on that end. It ...
0
votes
1answer
2k views

OpenStack instances power off by itself

Already asked this over on ask.openstack.org but I figured it would get more views here too. I am running OpenStack Mitaka on a 5 node cluster, 1 controller/network node and 4 compute nodes. I am ...
1
vote
0answers
367 views

KVM/libvirt: NAT forwarding virtual bridge to host bridge

I currently have a VM setup where only a few 'special' VMs are allowed to have outward facing IP addresses and the rest aren't. All of them are configured with two interfaces attached to a virtual ...
2
votes
1answer
1k views

libvirt: set hostname using dhcp in virtual network

I've configured a host-only (aka private) network for a group of VMs on a CentOS 7 host. I've created static leases in the DHCP section for the virtual network. The IP address is getting set ...
2
votes
1answer
520 views

OpenStack Juno Live-Migration never completes for instances with high load and size >64GB

I have run into situations where live migrations never seem to complete or error out. Here is how I have been able to reproduce the problem. Here is the instance I am migrating: [root@osc1-mgmt-001 ...
1
vote
0answers
277 views

Gentoo virt-manager IO throttling

I have a problem with virt-manager (or qemu/libvirt) installed on gentoo. Here is My virt-manager installed on Debian Jessie: There I have IO throttling but not on my Gentoo: I tried to search in ...
0
votes
0answers
142 views

KVM - libvirt qemu script make duplicates in iptables

OS: CentOS 7 Firewall: iptables libvirt: 1.2.17 Problem: I used guide to make port forwarding from host to gues machines. Link to guide: http://wiki.libvirt.org/page/Networking#...
0
votes
1answer
138 views

Nova Computer Service WIll Not Start: libvirtError: XML error: Missing CPU model name

I am having a problem with the Nova compute service not starting. I found tons of other people with this question, but nobody seems to have figured out the problem: systemctl status openstack-nova-...
3
votes
4answers
5k views

iptables / KVM forward port

I have a server with one external IP address (e.g. 1.2.3.4). On that server I use libvirt to run virtual machines. Now I want to access a virtual server on my host via ssh (port 1234) from the outside....
3
votes
1answer
3k views

Clone KVM virtual machine with snapshots

I've created a virtual machine using virt-manager and saved a snapshot of it's current state. Now I'd like to create an exact duplicate machine with all snapshots from the first machine. How could I ...
0
votes
1answer
2k views

QEMU, Virsh and SMBIOS tables edit

I am currently running qemu-kvm on an Ubuntu server box and I use libvirt with Virsh to create, manage, start and stop VMs. I edited VM's XML configuration through virsh edit command to change CPU ...
1
vote
1answer
2k views

Install virt-sysprep on Ubuntu 14.04

I'm using vagrant with vagrant-libvirt and I want to create a package via the command-line: vagrant package --output ubuntu14-base.box I've got an error around virt-sysprep being absent (confirm ...
0
votes
0answers
602 views

KVM/libvirt: Using virtio disk driver in Debian installer

I try to install Debian in a KVM-based VM using the virtio disk driver/bus and virt-install to run the installer. However, it seems that the installer lacks the virtio driver. Once I switch to bus=...
1
vote
2answers
1k views

Accessing linux guest OS filesystem in qcow2 image

I'm attaching VM qcow2 image to get access to files which inside: modprobe nbd max_part=63 qemu-nbd -n -c /dev/nbd0 /var/lib/libvirt/images/vm-image.qcow2 scanning for volume groups vgscan: ...
1
vote
1answer
718 views

CentOS 7.2.1511 libvirt firewall configuration

I have a few CentOS7 setups in which I use iptables to forward ports from host to guests. Recently, i updated to 7.2.1511 and it seems libvirt insists firewalld to be active vs using iptables command ...
0
votes
2answers
7k views

virsh qemu kvm editing xml has no effect

When I try to add a network section to a kvm/qemu xml, the xml wont update with the information. When I edit the uuid, or make a mistake, i get an error. if i change the memory amount, it reverts to ...
1
vote
1answer
967 views

Modifying libvirt firewall rules between virtual networks

On my my VM host, I have two libvirt virtual networks: virbr0: 192.168.122.1/255.255.255.0 virbr1: 192.168.130.1/255.255.255.0 I have a VM behind each of those virtual networks. Machines can see the ...
1
vote
1answer
94 views

Creating libvirt “mcast” networks using virt-install?

I would like to create virtual machines with mast network interfaces. This is possible to by first creating a guest using virt-install, then modifying the domain XML. Is there a way to do this from ...
1
vote
1answer
323 views

virsh net-define for CoreOS cluster

I have a kvm/qemu/libvirt host with several VMs running happily on br0 with IP addresses that are in the same network as the host they run inside, 192.168.10.0/24. So I'm playing with CoreOS and ...
4
votes
0answers
1k views

Libvirt & USB Hub Passthrough

I have a virtual machine which I wish to have a USB Hub and all of its devices allocated to a virtual machine. The Hub in question is a USB hub which itself is plugged into one of the ports on the ...
1
vote
0answers
520 views

VNC not working on XEN/libvirt domU - debian jessie

Hi recently configured a brand new server for testing purpose: debian jessie (8.3) xen 4.4 (xl toolstack) virtinst I created and started a new domU through virt-install: virt-install \ --...
0
votes
1answer
286 views

Creating a new domain in libvirt from a base domain

TL;DR at bottom I am building a web interface for libvirt as a project. I am using libvirt-php as the language binding to libvirt and everything is working, except for domain creation, sort of. The ...
0
votes
1answer
102 views

same libvirt config, one machine boots, the other does not

I am migrating a bunch of vms from an old machine to a new one. The old one was using some in-house scripts and lvm logical volumes, the new one uses libvirt and plain files. The configs are rather ...
1
vote
1answer
290 views

Libvirt does not see updated LVM volume

All VMs run off an LVM pool. I resized one of the LVM volumes to increase VMs drive copacity. Resized it with lvextend as usual. Everything is successful and lvs shows the new size. Libvirt does not ...
1
vote
0answers
354 views

How does Qemu handle memory?

I'm having a real hard time understanding something and I was wondering if anybody has any experience with this and is able to help. I have two KVM VMHosts, one running qemu 2.4.1 and the other ...
0
votes
1answer
703 views

Correct virtio setup on Ubuntu 14.04 64-bit host

At the present moment, my guest is running inside qemu and host is kvm intel, running Ubuntu 14.04, kernel is 4.3.0 stable. From within the guest, when I run "hdparm -i /dev/sdb" on the guest, I get:...
2
votes
1answer
2k views

How to create a new domain from an existing base image in virsh

Is there a way of creating a domain with virsh from a base image? I have looked around and found that it is possible using virt-install, however I would prefer it if this was done purely through virsh,...
2
votes
1answer
922 views

KVM bad IO sync performance in Linux guest

I'm setting up virtualized Ubuntu 15.10 guest inside Ubuntu 15.04 server using libvirt and KVM. Storage in host system: # mount | grep ext4 /dev/sda1 on / type ext4 (rw,relatime,errors=remount-ro,...
7
votes
3answers
7k views

WARNING KVM acceleration not available, using 'qemu'

Running debian (Linux Rick 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) x86_64 GNU/Linux) Looking at my cpuinfo I can see I have vmx support: flags: fpu vme de pse tsc msr pae mce ...
2
votes
1answer
275 views

kvm snapshot-create-as failed

I have Ubuntu server with qemu/kvm. I'm try to create snapshot (for further backup) using libvirt and get this error: # virsh snapshot-create-as --domain 56 --name copy_snap --no-metadata --disk-only ...
2
votes
1answer
6k views

KVM guest cannot connect to host, but works vice versa

I have debian 7 on my host machine and I run a KVM vm on it. My hosts network configuration is this (the relevant parts): br0 Link encap:Ethernet HWaddr 68:b5:99:ae:8f:11 inet ...
1
vote
1answer
3k views

Libvirt guest destroyed after shutdown

I have created a VM withLibvirt and when I shut it down whether forcefully or with ACPI, it gets deleted. I create it: <domain type='kvm'> <name>deneme2</name> <memory>...
1
vote
1answer
251 views

Enabling Nesting for Xen-in-Xen via Libvirt xml

I'm trying to get nested Xen-In-Xen via libvirt. Can someone confirm that adding hap and nestedhvm to the features element in the domU xml config is what is required to get nesting working? Am I ...
1
vote
1answer
920 views

Backing up Xen Guests from dom0 with disk image file

I have a Xen server dom0 with a number of guests installed and am struggling to find an easy way to manage backups from the dom0 side. Guest scripts: Of course I could run backup scripts on each of ...
2
votes
2answers
1k views

how to enable L3 cache on kvm guest?

I start a kvm guest(centos6.5) on a Intel machine(centos6.5),use libvirt, the guest's xml as follow <domain type='kvm' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'> <name>...
1
vote
1answer
226 views

Golden image updates in qemu

Consider that there are 100 windows virtual machines coming from a single base image and each vm is added to domain along with minor other machine specific settings which can be done by a script. ...
-1
votes
1answer
102 views

KVM/libvirt: Guest monopolizes bridge

I'm having a problem in which the first guest started on a VM host can send traffic through both of its assigned interfaces, but subsequent guests can only send traffic through one interface. My VM ...
1
vote
1answer
326 views

Libvirt with Xen fails to start correctly Ubuntu 14.04

At the moment i'M really feeling a little helpless: I tried to setup Ubuntu 14.04 with Xen and libvirt for management. I created a VM but I did not auto-start (altough autostart is checked). If I do ...
1
vote
1answer
942 views

How can I add a usb device to a domain xml from an image file?

I don't (repeat DONT) want to passthrough a physical usb device. I'm making a usb img file like so: dd if=/dev/null bs=1K of=/tmp/test_usb.img seek=2040 mkfs.vfat /tmp/test_usb.img I am then ...
1
vote
2answers
5k views

dnsmasq on virbr0 (libvirt) and network manager

I want to run dnsmasq on my local machine in order to configure a wildcard to resolve to 127.0.0.1 for testing purposes. However, when I went to start dnsmasq with systemd I got the following error ...
2
votes
1answer
43 views

libvirt lxc container won't use statically assigned address at startup

I have an LXC OS container (CentOS 7) configured via libvirt (CentOS 7): <domain type='lxc'> <name>lxc-test1.example.com</name> <uuid>5a715193-55ef-49d7-a4f6-ac5c27bce838&...
2
votes
0answers
203 views

noVNC console on Openstack Dashboard is rendering garbled UI on RHEL7

I am running nova-compute on RHEL7. Openstack dashboard's noVNC console is rendering garbled UI for any instance having a UI console. Can somebody please help out? This is working just fine on RHEL65
1
vote
1answer
677 views

port forwarding with libvirt

I'm trying to get port forwarding working through libvirt on top of QEMU and KVM. I found this article (https://snippets.webaware.com.au/howto/running-qemu-with-port-redirection-through-libvirt/), but ...
1
vote
2answers
1k views

How do I connect to my libvirt/qemu/guests ? (with no ip address)

I have inherited the administration of a trusty ubuntu server with several virtual servers, also ubuntu using libvirt and qemu. I have the problem I cannot connect to these virtual servers/guests. ...
2
votes
1answer
3k views

Best options for KVM/qemu/libvirt VM migrations without shared storage

My team has recently been tasked with improving the virtualization infrastructure at the company and one thing we're looking into doing is speeding up migrations. We use local storage only on all VM ...
1
vote
2answers
1k views

qemu-kvm take 100% cpu during start Win 7

I have Centos 6 with qemu-kvm version: qemu-kvm.x86_64 2:0.12.1.2-2.448.el6_6.4 On Dell Precision with 2x Xeon 5110 When I run VM qemu-kvm process take 100% of CPU and starting Windows on ...
2
votes
1answer
623 views

XFS/EXT4: Why is actual file size on disk larger than apparent size? Clarification

On a CentOS 7.1.1503 (3.10.0-229.el7.x86_64) system running KVM/qemu on an XFS filesystem, I'm attempting to work out what specifically is adding additional space to a VM diskimage file. $ ls -ls --...
0
votes
2answers
845 views

Forward Port on Guest Operating system With Libvirt

I am currently running a Xen Hypervisor underneath Ubuntu 14.04. On the host machine I am running a guest VM. From what I understand, In order to be able to receive incoming connections on the ...