Questions tagged [litespeed]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
10 views

Resource limit reached with 503 error

I received the following error on my website 503 Error litespeed log : -- Failed to start one instance. pid: -62 Resource limit reached! -- The server specifications are as follows cloudlinux LVE ...
-1
votes
0answers
25 views

Docker container OpenLiteSpeed SSL ERR_CONNECTION_REFUSED

so long story short, I have an application (bit on the older side) that runs in docker. Web server is implemented with OpenLiteSpeed application but its versioned at 1.4 or something like that because ...
0
votes
1answer
52 views

How to use LiteSpeed server with Apache?

On my search i've got only info about replacement of Apache with LiteSpeed. My question is rather: how to use them together? I think about a similar setup, where Apache is used together with Nginx, ...
0
votes
0answers
24 views

Strange download speed

I have a problem with download/upload speed. If I try to download a file from my server I have really low speed like 1 mb/s, on this server I have 1 gbit uplink. If I do a speedtest-cli the network ...
0
votes
0answers
16 views

Anyone saw this Powered byNsfocus Collapsar before? [duplicate]

While visiting one of my Websites i saw this black screen in the Screenshot attached. It was just for some seconds. Anyone know what it is? is it a hack? Im running on Centos8, with Litespeed and ...
0
votes
1answer
73 views

Factors of slow TTFB comparing between two VPS providers

I set up two VPS with the same (databases and hosting control panel). VPS company 1: based in california | 1 gbs | 2 core intel(R) Xeon(R) | 2 gb Ram | using Cloudflare VPS company 2: based in ...
0
votes
1answer
167 views

Migrate vhosts from Apache to OpenLiteSpeed

I was under the impression from reading the LiteSpeed web server doc, that LiteSpeed was using the same syntax for vhosts config than Apache ones, thus the migration was easy. However, after ...
0
votes
1answer
42 views

404 on LiteSpeed vhost

I just installed OpenLiteSpeed 1.6.17 on my dedicated server running Debian 10, with the goal to replace my Apache 2.4.38 in the future. I have access to OpenLiteSpeed WebUI, didn't changed the ...
0
votes
1answer
38 views

OpenLiteSpeed slow after IP change

I tested this multiple times, I created an image of perfectly working OpenLiteSpeed server on EC2, and when I deploy it, it doesn't connect or it connects but extremely slow (it takes around 1 min for ...
1
vote
1answer
262 views

CyberPanel LiteSpeed htaccess not working

I'm using CyberPanelthat it work with litespeed, I want to use .htaccess but it seems not reading any command in htaccess. for example I set: Deny from all But it not affacted. here is vHost conf: ...
0
votes
2answers
318 views

Installation OpenLiteSpeed Web Server on Amazon Linux (RHEL)

I'm just trying to install OLS on my Amazon Linux 2 instance, but i received errors at first and all last steps. Here is the explaination about: When i added recommended by guide repository, i ...
0
votes
0answers
140 views

HTTPS redirect is not working

I just migrate my WordPress website to google cloud using openlitespeed server. After setting up SSL my website is not redirecting to HTTPS although I set https redirect on my .httaccess. Also when a ...
1
vote
1answer
49 views

Serve website from different directory based on URL string parameter

I would like to learn if I can serve the website from 2 different versions according to URL string parameters. Example: I have two installs on my server: example.com/website-1/ and example.com/...
1
vote
1answer
246 views

How To Use Wget Command To Check Server Cache Settings

I'm having trouble with a server side cache with an OpenLiteSpeed server. I've tried the following .htaccess trick to try and turn this cache off. Can you tell me a wget command I can use to test my ...
0
votes
1answer
339 views

OpenLiteSpeed file_put_contents Permission Denied Error

New to OpenLiteSpeed, I received a permission denied warning error when trying to write a file in the website subdirectory using file_put_contents() API from PHP. I thought perhaps I needed to adjust ...
2
votes
1answer
5k views

Litespeed vs Nginx high-traffic server performance? [closed]

Most top-level (high-traffic) websites use Nginx web servers. This community has many members who are experts about systems and servers, so I want to ask for feedback on which server can handle top-...
0
votes
1answer
385 views

Openlitespeed view nodejs stdout/console.log logs

I am trying to setup a nodejs server with openlitespeed as proxy server on digital ocean using the one click litespeed nodejs image from their marketplace. Everything is working fine. I just want to ...
2
votes
1answer
490 views

Too many open files error on webserver with wordpress site on litespeed server

I am running a wordpress site on a litespeed webserver, caching enabled using the litespeed plugin, with cloudflare as a CDN. Every few days or so, the logs start filling with the below error. Not ...
0
votes
1answer
272 views

openlitespeed mongodb extension installation for lsphp

I'm trying to use mongodb with lsphp. Currently I've manually compiled mongodb.so following this and I can see mongodb.so at /usr/local/lsws/lsphp7/lib/php/extensions/no-debug-non-zts-20160303 . Now, ...
0
votes
1answer
396 views

Openlitespeed as a WebSocket Proxy

I am building web applications related to the socket. And my application runs well without https, if it has https, it will not connect. And as guidance on nginx must configure additional proxy. But ...
0
votes
1answer
97 views

Litespeed cache – also for resources?

I'm trying out litespeed cache. Sounds promising. I added this to my .htaccess: ######### Begin - Litespeed cache <IfModule LiteSpeed> CacheDisable public / RewriteEngine On RewriteCond %{...
0
votes
2answers
308 views

LiteSpeed ignore PHP header 404 status

After moving my website to a webhost which uses LiteSpeed it seems PHP header is ignored. I have tried these variations: $s = "HTTP/1.1 404 Not Found"; $s = "HTTP/1.0 404 Not Found"; $s = "Status:...
0
votes
0answers
64 views

Appending HTML to pages when specific IPs request them?

I host three websites on the same physical server, and of course by the Host header I know which website the user requests. For the sake of the example these are the domains: blog.website1.example ...
1
vote
0answers
1k views

Apache .htaccess works fine, 404 with Litespeed

I'm using litespeed on shared hosting (unfortunately), and I'm trying to use .htaccess to rewrite http to https NON www - and change domain.com/index to domain.com/my-string for SEO purposes. This is ...
0
votes
1answer
125 views

Migrating from LiteSpeed to Apache special characters in image names 404

On my host running LiteSpeed, images with special characters in filenames like "é" work just fine. When i migrate the site to my local development stacks, be them WAMP clones or even a Vagrant VM on ...
0
votes
1answer
769 views

Lightspeed vs Apache for WP/WooCommerce?

I currently run a wp/woocommerce site that's been optimized as far as I can take it for an Apache server: MySQL memory optimized WP Rocket MaxCDN VPS: 2 cores 2 gigs of ram SSL The site offers ...
0
votes
1answer
111 views

Why there are a lot of log with the ip address of the server in litespeed?

I have a server with Litespeed web server. When I check the access logs of a domain there are a lot of lines like the following: 188.165.x.x - - [04/Feb/2017:10:16:16 +0330] "GET /assets/source/...
0
votes
2answers
648 views

.htaccess php_value and php_flag being ignored in sub-directory

I have an .htaccess file in my public_html directory with the following rules: <IfModule litespeed> php_flag zlib.output_compression On php_value zlib.output_compression_level 2 php_value ...
2
votes
2answers
6k views

What rule can I use in ModSecurity to log POST payload for a specific site?

I need to inspect POST payload for a specific website (the server is rather busy and I wouldn't turn on POST logging for the entire server). The server is LiteSpeed 5.0.7. SecRequestBodyAccess is set ...
0
votes
2answers
3k views

Your PHP installation appears to be missing the MySQL extension

Your PHP installation appears to be missing the MySQL extension which is required by WordPress. This is what I get when I try to install WP. The server is running. Centos 6.7 x64. Litespeed ...
0
votes
2answers
2k views

Restrict Location Match by IP via .htaccess

I have a url path defined in rewrite rules ('/admin') which I would like to restrict access to only 1 ip address. I'd image the best way would to use .htaccess rather than coding it in. I've tried ...
0
votes
1answer
340 views

Will HTTP/2 work with Apache acting as a reverse proxy to an OpenLightSpeed server?

Before wasting my time and doing something I figured I would ask the question first. I really want to try out HTTP/2 and since Apache does not have a module for it yet I figured I would use ...
0
votes
0answers
1k views

Open LiteSpeed permission problems

I recently moved to open litespeed from apache and i can no longer create files. When i do a file_put_contents i get permission errors. lsphp and litespeed both run under user nobody. Doing a chmod ...
9
votes
4answers
3k views

How to fix Image Swapping Issue in iOS 8 with keep-alive + HTTP Pipe-lining?

Ever since iOS8, the sites I managed are experiencing an intermittent problem in which images are swapping locations with other images. This has been mentioned in a number of places, but with no ...
-3
votes
1answer
1k views

High Memory server, apache not using All ram [closed]

I have 64G Memory, 12coreX3CPU , SATA HDD... But memory using %5 ?? How to increase this limit? htop http://i.stack.imgur.com/STqtm.png top -c http://i.stack.imgur.com/TpjAx.png [root@ns228430 ...
1
vote
1answer
494 views

Open litespeed and additional engines in subfolders

Last night I spent more time than I should have trying to get a. New VDS up and running with percona and open litespeed. The site I want to run ok there is structured as follows Webroot - index.php - ...
1
vote
1answer
991 views

How can I deny access to a folder in OpenLiteSpeed similarly to the way Apache does it?

I'm trying to deny access to a folder for a website that is hosted with OpenLiteSpeed v1.4.2, but I'm have trouble. I take it that .htaccess isn't supported in OpenLiteSpeed so I am unable to just put ...
-1
votes
1answer
1k views

How to enable SPDY in LiteSpeed?

I have the latest LiteSpeed Enterprise running on my server. It was not installed with SPDY enabled. How do I enable SPDY? The server got lots of IPs and SSL certificates. I've seen that it might ...
0
votes
1answer
3k views

Denying access to website via htaccess based on http header

I've been trying for ages to get this to work and I can't put my finger on it. What I'm trying to do is block access to a site from a number of countries, based on the CF-IPCountry header added by ...
1
vote
1answer
831 views

Enable FastCGI on Litespeed

How would I enable my Litespeed server to process .fcgi files using a FastCGI module? I tried setting the handler to fcgid-script already but that doesn't work. Syntax: AddHandler fcgid-script ....
2
votes
2answers
3k views

Does OpenLiteSpeed support Apache rewrites?

I have been getting some conflicting information - official OpenLiteSpeed pages say both that: OpenLiteSpeed supports Apache rewrites, and OpenLiteSpeed does not support .htaccess A bit confused......
0
votes
1answer
2k views

How can I exclude the admin area from the litespeed cache when running Magento?

I have litespeed on my server and am trying to use the cache system. I have followed the wiki instructions. And have this in my Magento .htaccess RewriteRule (.*\.php)?$ - [L,E=Cache-Control:max-...
0
votes
2answers
467 views

server load, litespeed, scsi, nameserver fail: all messed up

First of all: I have very basic knowledge about linux servers. Here is our dedicated server details: Intel(R) Xeon(R) CPU X3450 @ 2.67GHz Total processor: 8 OS: Centos 32bit release 5.8 (Final) ...
2
votes
1answer
3k views

LiteSpeed enable Access-Control-Allow-Origin (no response header on CORS request)

Seriously, I can't find a single page discussing this for litespeed. Using this format in the htaccess "Header set Access-Control-Allow-Origin http://aSite.com" (and https) sends the setting in the ...
0
votes
1answer
688 views

SSL certificate error

New to SSL. I had a certificate signed and I am trying to get the cert I generated loaded into LiteSpeed. However I have one issue. 2012-11-01 20:30:33.121 NOTICE [PID: 28139]: start cgid: 28140, /...
4
votes
3answers
2k views

More than 3 seconds “Initial Connection” time (webpagetest.org)

I'm having a weird issue with a vBulletin forum, on a 2х Xeon E5645 w/ 16GB RAM CentOS 6.3 x86_64 web server with cPanel and LiteSpeed; It takes too long to start loading... When I tested it with ...
2
votes
0answers
887 views

litespeed issue with content-type

I am running magento with litespeed. The problem I am facing is that ajax call is being made of which header is set as x-json, but lightspeed is setting another header of text/html content type I've ...
0
votes
2answers
282 views

Rewrite rule www.example.com to example.com/www without changing url in browser

I want to make a rewrite that under the url www.example.com will be site example2.com/www but I want it not to change the url in browser to example2.com/www/. So after entering in browser http://www....
1
vote
3answers
610 views

Why does litespeed show PHP source, instead of interpreting?

I have this issue on my server. It happens sometimes when I refresh my webpages. It seems litespeed wont pass file.php to php compiler and instead of rendering HTML and interpreting PHP, I will see my ...
1
vote
1answer
344 views

Wildcard SSL certificates, EV

I run a Magento e-commerce store with multiple subdomains for an affiliate program, plus a main store. Example, foo.example.com and bar.example.com are affiliates, www.example.com is my main store. ...