Questions tagged [loopback]

In TCP/IP a loopback device is a virtual network interface implemented in software only and not connected to any hardware, but which is fully integrated into the computer system's internal network infrastructure. Any traffic that a computer program sends to the loopback interface is immediately received on the same interface.

Filter by
Sorted by
Tagged with
0
votes
1answer
40 views

Gigabit RJ45 loopback not working (100 Mbps ok)

I made myself a loop back plug as per When I plug it into a 1Gbps port on 100/1G switch the port does not light up. 100 Mbps port on 100 Mbps switch lights up no problem. The obvious problem could ...
0
votes
1answer
49 views

What is the difference between the loopback interface and the 127.0.0.1 IP address?

I am trying to allow connections between softwares running on the same machine in iptables. The following kill my internet connectivity: # The following rules doesn't allow the VPN connection to be ...
0
votes
0answers
36 views

Does DPDK/RDMA between 2 machines gives lower latency than local host ping

I know loopback will go through the kernel network stack until reach IP layer, including syscall overhead and some memory copy overhead. DPDK and RDMA use different technology to avoid these. So let'...
1
vote
1answer
32 views

How to assign an additional IP to loopback

I have a few docker containers which are supposed to access a shared PostgreSQL running on the Gentoo host. This works well if the dockerized apps connect to the database using the public IP of the ...
0
votes
4answers
110 views

Is a loopback interface just another term for virtual interface?

I've been reading through many forums and many questions here on loopback interfaces and a point that is constantly iterated is that a loopback interface is a virtual interface. In hypervisors like ...
-2
votes
3answers
259 views

Forward packet from loopback interface based on routing table

I have a problem in which I need to process some packets and send out to more than one interface/network. My solution is to send the packet to a loopback/dummy interface and based on the Linux routing ...
0
votes
0answers
31 views

Can't track applications network communication under same machine

I have a network application environment of 7 applications communicating with eachother through UDP and TCP. All of them using either the machine's local network IP or 127.0.0.1 (localhost) to listen ...
0
votes
1answer
57 views

two tap device connect each other in same pc

What I want to implentent is something like below. 192.168.1.1 192.168.1.2 +--------+ +----------+ +-----------+ +---------+ ...
0
votes
1answer
126 views

changing netmask of loopback interface

I can change netmask of loopback inteface (usually lo interface has 127.0.0.1/8): pi@raspberrypi:~ $ ifconfig lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 ...
1
vote
0answers
41 views

How can I capture traffic for a daemon listening on a cloned loopback IP address?

I have a daemon listening on a virtual IP address attached to a cloned loopback interface (lo1) on FreeBSD 11.x. Inbound traffic for that daemon could arrive on several different physical interfaces, ...
0
votes
0answers
72 views

iptables loopback opens all ports

I have a strange problem with iptables and my loopback interface. ifconfig says: lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 inet6 ::1 ...
3
votes
2answers
2k views

ssh -R binds to 127.0.0.1 only on remote

I'm running ssh -N -f -R127.0.2.3:23000:127.1.2.3:23000 user@remote , and I expect the tunnel on remote has opened on 127.0.2.3:23000, but it only opens on 127.0.0.1:23000, and it's inconvenient ...
0
votes
0answers
179 views

Loopback interfaces is not pinging on both pcs for packet tracer

I am trying to ping my isp ip address (aka loopback 1) and loopback 10 to PC1 and PC2. Whenever I ping both ip addresses and default gateway from pc1 to pc2 it works. However, when I'm trying to ping ...
1
vote
2answers
316 views

I have a loopback traffic in linux involving port 631 and I have no idea what is causing it

So I did some packet capturing in my networking and everything else is actually fine except for this weird communication where source and destination is literally 127.0.0.1, source port is 631, and ...
1
vote
0answers
91 views

Loopback adapter cannot connect to the domain network

I am working on a project creating Microsoft Print Server Farms with High-availability. It works perfectly with the Loopback adapters in the servers and a network load-balancer. The Loopback adapters ...
1
vote
1answer
76 views

Calculate pm2 ram consumption on basis of hit or traffic

I have deployed loopback backend application in ec2 instance. I am using Pm2 server. How can I calculate ram and cpu for traffic or hit ?
2
votes
1answer
1k views

IP Address is very slow compared to loopback address

I have an AWS EC2 VM. I want to run a bunch of scripts on a PostgreSQL server hosted on the same machine. When I use the IP address of the server in scripts, it took almost 5 seconds per script. But ...
1
vote
2answers
612 views

Network loopback device missing in Ubuntu 14.04

I want to program an FPGA via JTAG and the xmd script connects to 127.0.0.1:3121 to do so. That worked nicely for months. After a reboot this connection suddenly didn't exist any more, I cannot ping ...
3
votes
1answer
3k views

Add-NetNatStaticMapping not port forwarding to local VM

I'm running windows 10 build 1809 and have hyper-v installed. I have a Linux machine running behind a NAT with internet connectivity working on IP 10.0.5.5. I basically followed instructions on the ...
2
votes
0answers
34 views

Does Loopback able to support all TCP/IP protocols

Does a Windows loopback adapter supports ACD and duplicate IPs. Say we have a code that supports full TCP stack and we bridge the program to loopback using PCAP. If in case I set both the address ...
0
votes
1answer
428 views

How can I count / view all fast-path sockets on windows server?

In case you're not familiar, fast path loopback sockets: https://blogs.technet.microsoft.com/wincat/2012/12/05/fast-tcp-loopback-performance-and-low-latency-with-windows-server-2012-tcp-loopback-fast-...
0
votes
2answers
662 views

Windows Loopback adapter not participating in local network

I have created a Windows loop back adapter with 'Obtain IP address Automatically' enabled. ipconfig /all Ethernet adapter LL Address: Connection-specific DNS Suffix . : Description . . . . ....
1
vote
1answer
764 views

ip command equivalent to `ifconfig lo x.x.x.x up`

I am trying to set bind loopback to an IP address with ip link set lo 10.254.254.254 up but keep getting the error Error: either "dev" is duplicate, or "10.254.254.254" is a garbage. I googled the ...
1
vote
1answer
347 views

Corosync cluster will not bind vips to loopback, so apache fails to start in CentOS 7

I have a problem getting apache to work in a corosync cluster. I probably sifted through more than hundred web pages and a couple of dozen Google Searches, and was not able to find any matching ...
2
votes
1answer
768 views

How can I give access to loopback devices which are created dynamically to a Docker container?

I have a small Docker container from which I can access /dev/loop0. For this I've added to docker run: --device=/dev/loop-control:/dev/loop-control \ --device=/dev/loop0:/dev/loop0 \ On this ...
1
vote
1answer
3k views

Add second ip to loopback on Centos

We currently run Suse servers and add the following to the loopback interface: vi /etc/sysconfig/network/ifcfg-lo # Loopback (lo) configuration IPADDR=127.0.0.1/8 IPADDR_2=192.168.0.91/32 NETMASK=...
-1
votes
1answer
698 views

Nat Loopback - Access external IP from internal

I have a static IP and I've made a webserver that is running fine from WAN (domain points to my IP). However, when I access my external IP/Domain from my LAN, it redirects me to my router login page. ...
-1
votes
1answer
2k views

Err-disable in Switch 2960 [closed]

I have a problem. I have a Cisco 2960, this switch conect 23 Macs. The problem is that a pc puts the port in err-disable. When I put the command "show interfaces status err-disabled" the output is ...
0
votes
0answers
22 views

Kubuntu 17.04 on VM: loopback interface routed “outside”

Disclaimer: Yes, I know my problem description might be not very accurate and my terminology as well. Can not change that since I am new to this topic and do not know it yet. But I apprechiate ...
-1
votes
1answer
609 views

How to change loopback network mask or redirect subnet to another interface [closed]

I have the following problem. First of all. Here are my interfaces. # ip addr ip addr 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd ...
1
vote
0answers
137 views

A looped hub connected to a switch

---- We don't want to block the use of Hubs --- If two switches are connected to each other via a hub, STP detects and blocks alternate link (if available). But if a hub is connected to even one (...
1
vote
2answers
4k views

iptables dnat not working for https

I have an http server listening on ports 8080 (http) and 8081 (https) on 127.0.0.1 I have these iptables rules to redirect from/to $external_ip: iptables -t nat -A PREROUTING -i eno1 -p tcp -d $...
3
votes
2answers
2k views

Heavy TCP traffic on loopback

While trying to generate some test traffic on my loopback interface, I noticed there was so much noise there that the output from Wireshark was essentially useless, with tons of SYN/RST, ACK packets ...
1
vote
2answers
2k views

Why adding external IPs to loopback (lo) works just like adding to ethX

For ages(>7yr) my automation scripts were adding new external IPs to the servers in this way ifconfig lo:0 11.22.99.44 netmask 255.255.255.255 ifconfig lo:1 11.22.33.44 netmask 255.255.255.255 ......
0
votes
2answers
6k views

How do I force localhost resolution to be 127.0.0.1 instead of ::1?

I'm running Windows 10 x64 and I have a legacy application that doens't work fine with localhost being translated to ::1, but instead it works for 127.0.0.1. How do I force Windows 10 to resolve ...
2
votes
0answers
164 views

TCP packets dropped in ipv6 loopback

Just logged in to a Windows host, I noticed an unexpected CPU usage. I quickly found out the processor was being hogged by the Windows firewall services. I enabled logging, and I started to see ...
1
vote
2answers
81 views

using ethernet ipv4 as internal bus while allowing the full ipv4 address range for the external interface

We have designed a device to be used as one device, but using ethernet ipv4 inside to communicate with internal not linux-based ipv4-speaking peripherals, juste like what we could do using pci or usb, ...
2
votes
1answer
2k views

Is it important to use localhost/127.0.0.1 rather than machine's own IP address?

I'm on Amazon AWS EC2 running Amazon Linux, though that may not be significant to the answer. Say I have three hosts, H1, H2, H3, with private IP addresses of 10.0.0.1, 10.0.0.2, and 10.0.0.3. This ...
1
vote
1answer
700 views

Ubuntu rename loopback interface

I have a Linux box with Ubuntu 16.04. I've noticed some odd behavior when I needed use the loopback interface. So I checked with ifconfig first and it showed that: rename1 Link encap:Local ...
2
votes
1answer
1k views

Can't access server on loopback address, only on private address

I am running a rails web app server bound to 0.0.0.0 on port 80 like so: sudo rails s --port=80 --bind=0.0.0.0 I can access it at my private address http://192.168.0.13/, normally I can access at ...
1
vote
0answers
235 views

How to create image file and mount via. loopback (Ubuntu to remote backup space)

I've been fiddling around with the Hetzner Backup Space and I want to use rsync via. rsnapshot in order to back up my files (more info at their Wiki here) They state in their documentation: The ...
1
vote
0answers
423 views

Slow “ifconfig lo”

How can I diagnose a slow loopback interface? Here is what I see on my Fedora23 box: $ time ifconfig lo lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 ...
0
votes
0answers
2k views

Server send TCP ACK with wrong number after receiving SYN

I have a client establish new TCP connection then sends request to a server per second. Both client and server are on the same linux box (via loopback interface). The client periodically reports ...
0
votes
0answers
609 views

Two loopback adapters communication in windows 7 or 8

Once our development systems are upgraded from windows XP to windows 7, my debug setup has stopped working. Steps followed in original setup (Windows XP): Add two loopback adapters Assign ipv4 172.16....
3
votes
1answer
17k views

Centos 7.1 Create Loopback Interface [duplicate]

I'm trying to alias an ip address onto Lo or create a new loopback interface such as lo:1 I've created /etc/sysconfig/network-scripts/ifcfg-lo:10 DEVICE=lo:10 IPADDR=192.168.10.1 NETMASK=255.255.255....
7
votes
3answers
4k views

Why only a single loopback address on IPv6?

IPv4 allocates a whole block of IPv4 loopback addresses, 127.0.0.0/8. IPv6, in contrast, only allocates a single loopback address, ::1. This seems surprising that IPv6 would be so stingy in its ...
1
vote
0answers
248 views

Network Traffic fluctuating, even with loopback

I am using iperf tool to benchmark my network interfaces on two identical machines (Dell Blade Server M620). Both have given different results. On 1st machine, I ran server and clients as: Server ==>...
3
votes
1answer
3k views

Loopback Processing Merge Mode

I am part of a team of IT Engineers who are currently revamping a large organisation. The previous IT department had some Group Policy objects in place for installing software(s), applying security ...
3
votes
0answers
217 views

Why is the loopback device needed on a client side of Stunnel?

This SANS Institute guide states that "On the client side, a port listening on the loopback interface of the local system would send/receive data on the clear-text protocol and tunnel out on ...
1
vote
1answer
615 views

Why does 0.0.0.0 resolve to the loopback device?

Why does 0.0.0.0 resolve to the loopback device? $ curl --verbose 0.0.0.0 * Rebuilt URL to: 0.0.0.0/ * Hostname was NOT found in DNS cache * Trying 0.0.0.0... * Connected to 0.0.0.0 (127.0.0.1) ...