Questions tagged [mcollective]

The tag has no usage guidance.

12 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3
votes
0answers
914 views

MCollective server cannot connect to ActiveMQ broker

I've been trying all do to set up MCollective on my puppet cluster. No matter what I do, I can't seem to get the MCollective server to connect. The MCollective server(s) are running mostly on Ubnutu ...
3
votes
0answers
66 views

Creating a CA signing chain when there wasn't one before

Here is the problem... 3 years ago we created a multi-datacenter setup, with as little cross-DC resource dependencies as we could make. Different AD sites. Different puppetmasters. Different syslog ...
2
votes
0answers
431 views

mco ping not responding for one node

We have configured 12 servers with Puppet/MCollective . All the servers are rspodning to mco ping . But we had a patch update for OS and after that one of the node is not responding. $ ...
1
vote
0answers
479 views

mcollective can't find puppet ddl, though it exists

[vagrant@puppetserver ~]$ ls /usr/libexec/mcollective/mcollective/agent/ filemgr.ddl nettest.ddl package.ddl puppet.ddl service.ddl filemgr.rb nettest.rb package.rb puppet.rb service.rb [...
1
vote
1answer
60 views

mcp puppet runonce not executing manifests

I am using mcollective with puppet . The setup is successful . But when I apply manifests , the manifests is not getting executed . My manifests is as follows: node default{ } node 'Node-009....
1
vote
1answer
335 views

mcollective - different ruby path/environment

How do I tell the mcollective server to use a different ruby path, or otherwise control the ruby environment? I'm running on Centos 6.5, and have installed the ruby193 collection onto the servers and ...
1
vote
0answers
171 views

Mcollective Does Not Return Hosts Matching Class Filter

Whenever I execute the command $ mco service cupsd status --with-class mcollective I receive the message: No request sent, we did not discover any nodes However, if I remove the class filter, ...
1
vote
1answer
159 views

Is it possible to use different connectors on MCollective client and server side?

Is it possible to use the STOMP connector on client side and ActiveMQ on server side? Here are my configurations: #client.cfg connector = stomp plugin.stomp.host = localhost plugin.stomp.port = 6163 ...
0
votes
0answers
739 views

mcollective ping not working

I am facing the below error while setting up mcollective activemq setup on centos, could you please let me know what went wrong in the setup? mco ping The ping application failed to run, use -v for ...
0
votes
1answer
319 views

MCollective metadata refresh returns: Host name lookup failure

With puppet installed, the command /opt/puppet/sbin/refresh-mcollective-metadata is run every 15 minutes. It loggs hostname: Host name lookup failure when it runs. hostname, hostname -i, and hostname ...
0
votes
1answer
725 views

MCollective with RabbitMQ stops responding

Using MCollective (2.2.3) with RabbitMQ (3.1.5) on RedHat 6.5, MCollective stops responding after a first successful ping. When I restart RabbitMQ, it works again. root@rabbitmqserver# /etc/init.d/...
0
votes
1answer
128 views

Mcollective responds to ping but not puppetd

I'm working with a colleagues setup, so I'm hoping things were setup correctly; however I'm having some issues. When on the Puppet Master, if I run mco ping then I get a list of agents; however if I ...