Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [modprobe]

The tag has no usage guidance.

0
votes
0answers
4 views

Conflicting commands in CIS Benchmarks for modprobe

I was going through for the CIS Benchmarks for Oracle Linux 7. For a certain section, it recommends running these : 1) add the following to /etc/modprobe.d/CIS.conf install cramfs /bin/true 2) ...
1
vote
2answers
879 views

Docker service not able to start anymore because of modprobe error

I just ran in some issues with my server running docker that I cannot fix myself. Im using Docker version 18.09.0, build 4d60db4 with Ubuntu 16.04.5 LTS. During the day I noticed, that my docker ...
0
votes
1answer
296 views

CentOS 7: sshfs can't find fuse, even though fuse is loaded

When I try to run sshfs, I get the error fuse: device not found, try 'modprobe fuse' first. I already ran sudo modprobe fuse, but it just returns immediately without any output and the error persists: ...
0
votes
0answers
130 views

Need to Rebuild Kernel Modules After Kernel Upgrade?

I am using CentOS 7.5. I noticed that as soon as I upgraded from kernel-3.10.0-693.el7.x86_64 to kernel-3.10.0-862.2.3.el7.x86_64. Some of the kernel modules aren't there (e.g. all the modules in /...
0
votes
1answer
767 views

Where to place modules settings, /etc/modprobe.d or /lib/modprobe.d?

My man modprobe.d says the following: NAME modprobe.d - Configuration directory for modprobe SYNOPSIS /lib/modprobe.d/*.conf /etc/modprobe.d/*.conf /run/modprobe.d/*....
-1
votes
1answer
1k views

IPMI : FATAL: Error inserting ipmi_si

i have a problem with ipmi: i've already install ipmitool, ipmi_devintf, ipmi_msghandler, but when i try to install ipmi_si i receive this message: $ modprobe ipmi_si module FATAL: Error inserting ...
0
votes
1answer
483 views

Error: Socket failed: Connection refused ltsp + update-rc.d errors

I am installing a LTSP server, everything works, the pxe.linux.0 gets found, but the client gets stuck at this error: Modprobe: module overlayfs not found in modules.dep Error: socket failed: ...
3
votes
0answers
1k views

centos: fusermount: fuse device not found, try 'modprobe fuse' first

while trying to mount google bucket or set sshfs up I am getting following error: fusermount: fuse device not found, try 'modprobe fuse' first modprobe fuse command does not show anything: [user@...
0
votes
0answers
843 views

Module ip_tables not found

since my last reboot i cannot use iptables anymore. When i enter iptables -S i get modprobe: ERROR: ../libkmod/libkmod.c:508 kmod_lookup_alias_from_builtin_file() could not open builtin file '/lib/...
1
vote
0answers
88 views

Create IFB with name or ID in Ubuntu server

I am doing some work relate to limit income bandwidth (ingress) of a NIC in Ubuntu 16.04. Seem like we cannot limit the income bandwidth directly but have to use IFB. In this this post we have a good ...
1
vote
1answer
1k views

Modprobe doesn't create nbd device

I am running a server with Debian 8, and after running modprobe nbd, the program runs just fine. However, the device is not created since /dev/nbd0 does not exist. What should I do to get modprobe to ...
0
votes
0answers
5k views

*-network UNCLAIMED : How can I fix this issue

Out of the blue my second ethernet port stopped working. Both of them are part of the motherboard. I can see both of the ports in bios. They were working, but I was using only one of them up to now. ...
0
votes
1answer
1k views

How to reliable re-install nf_conntrack module after removal?

I want to remove the nf_conntrack module from debian. However I don't want to do this until I know how to get it back (if I have to), and currently am not confident about this. The steps another ...
-3
votes
1answer
393 views

how to do ipmi for fencing, hardware specific requirement?

i'm a total noob about ipmi, fencing and ha, i want to create node with high availability. wanna fencing node with ipmi. root@proxmox01:~# ipmitool sensor Could not open device at /dev/ipmi0 or /dev/...
2
votes
2answers
2k views

preventing ipmi kernel drivers from loading

I'm trying to prevent the ipmi kernel modules from loading on a server with a SuperMicro X8DTG-D motherboard running Ubuntu 14.04. My motivation for doing so is that the modules sometimes seem to take ...
1
vote
1answer
634 views

Fuse module for s3fs

I am trying to install the s3fs software. I however keep coming upon this error: $ sudo /usr/bin/s3fs bucketname /mnt fuse: device not found, try 'modprobe fuse' first $ modprobe fuse FATAL: Module ...
2
votes
1answer
158 views

at what level modprobe operates ? - linux

I have a machine with Ubuntu 12.04 64 bit, i have the need for blacklisting a module, i have blacklisted it in blacklist.conf but nothing happened; i have solved my problem passing modprobe.blacklist=&...
6
votes
2answers
12k views

modprobe not found at all

I know that a lot of people had problems finding modprobe which was mostely due to an unconfigured $PATH. This time however I logged into a machine (Linux mymachine 2.6.32-6-pve #1 SMP Mon Jan 23 08:...
0
votes
1answer
654 views

Unknown modprobe causing high load average

For about the last 6 months, and for about a year before that (with a 6 month hiatus), one of my servers has had a consistently high load average: 13:37:34 up 192 days, 5:44, 2 users, load ...
2
votes
1answer
3k views

modprobe inside an LXC container

I need to run a WebDAV server inside of an LXC container, but I'm being told that modprobe is not available (even as root). I've seen that this was requested by developers, but how can I get around ...
1
vote
1answer
1k views

modprobe amd-rng fails, No such device

When trying to install hw_random to a 2.6 kernel, modprobe returns a FATAL error "No such device" on both CentOS 5.7 and Fedora 15. Both are using the latest kernel, respectively. The .ko file exists,...
11
votes
2answers
31k views

What is the correct way to load modules for iptables on Centos 6

Where should I load iptables modules, for example ip_conntrack and ip_conntrack_ftp. Places I have found that might be candidates, but are they? The IPTABLES_MODULES variable in /etc/init.d/iptables ...
2
votes
2answers
18k views

how to configure modprobe to recognize newly installed driver for eth1 on bootup?

I have a server running Debian 6. My motherboard has two interfaces, eth0 and eth1. Debian does not have a driver for eth1 (e1000e), so I installed the driver provided by Intel (e1000e-1.4.4). ...
0
votes
1answer
226 views

How to get rid of this error message?

I have this error message popping up in my /var/log/messages file: modprobe: FATAL: Could not load /lib/modules/2.6.33.7.2-rt30-xxxx-std-ipv4-64/modules.dep: No such file or directory My OS is ...
0
votes
2answers
1k views

Enabling 8021q on a nic

I'm trying to get a vlan interface on a bonded nic (Centos 5.5) and whilst the interface has been very happily created with vconfig I'm seeing no traffic on it at all. Running tcpdump and tshark on ...
2
votes
1answer
1k views

Ubuntu: Modprobe on startup

First, this is strange. I have two laptops running Ubuntu 10.10. On one of them, when connecting my 3G modem, it just works out of the box. For the other one, I need to modprobe option to register it ...
1
vote
4answers
9k views

Persistent changes to /proc/sys/sunrpc/tcp_slot_table_entries

I'm trying to make a persistent change to sunrpc.tcp_slot_table_entries on a Linux CentOS 5.5. This value has been found important for the performance of our NFS clients, and must be set before the ...
1
vote
2answers
2k views

when /etc/modules is used?

"# /etc/modules: kernel modules to load at boot time." my question is when and where the module loading job done? my first guess is some init scripts in /etc/init.d/ but grep got none. then i think ...
3
votes
3answers
2k views

Ubuntu Server: Networking fails with MODPROBE option in /etc/network/interfaces …?

For some reason (which I haven't been able to determine yet), yesterday morning the networking service on our web server (running Ubuntu 8.04.2 LTS -- hardy) wouldn't start, and our website went down. ...