Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [openstack-neutron]

Neutron is a virtual network service for Openstack. It is an OpenStack project to provide "networking as a service" between interface devices (e.g., vNICs) managed by other Openstack services (e.g., nova).

0
votes
0answers
15 views

Providing IP to VMs in Openstack

This could be a silly question, but I didnt get an accurate answer. So, my question is how to assign public IP address to a VM in Openstack? I need to know end to end process for the same. Let's say I ...
2
votes
0answers
534 views

OpenStack Hyper-V vSwitch not being selected

I'm updating this, as the original did not get much support. And, I'm not seeing that error anymore since restarting with a fresh install using packstack. To help try to "help you, help me." I am ...
0
votes
0answers
6 views

Routing Destination to Null0 in Openstack Environment

I runnning openstack, and recently found that some of my VMs are attacking to some external IP addresses(3 IP Addresses which belongs to China). i have blocked the destination on my router, and ...
0
votes
0answers
19 views

Not able to connect provider (physical) network

Background: I have an OpenStack installation (rocky release). The configurations made are: One controller node One compute node Self service (networking option-2) Problem: When I create a private ...
1
vote
0answers
54 views

openstack shared PCI between numa with SR-IOV

I'm building SR-IOV supported compute node on HP 360g8 hardware and i have Qlogic interface card, my compute node has 32 core & 32GB memory. Problem: when i launch vm-1 (with flavor 16 vCPU core)...
0
votes
0answers
74 views

How to Access Openstack on my local mechine from External network?

I deployed a private cloud in openstack with the help of packstack,Everything is working fine,i can create new instances,Launch it,use it to install software from internet and delete it,All the set up ...
1
vote
0answers
104 views

Openstack Mitaka - Networking Controller and Compute node on different network Segments

I'm fairly new to Openstack and have very limited insight into Advanced networking concepts. I'm trying to setup a simple Openstack Mitaka setup for work, following the official installation guides. I ...
0
votes
0answers
31 views

Terraform VIO - Making network 'external'

Building out some networks with Terraform on VIO. Unable to mark the network 'external' without going into the gui and checking the box. Has anyone been able to mark a network as 'external' direct ...
0
votes
1answer
44 views

kolla-build Error installing fluent-plugin-rewrite-tag-filter serverengine requires Ruby version >= 2.1.0

I am using kolla/kolla-ansible 5.0.0 and I just built all the container images and pushed them to my local docker registry. There is one image that kolla fails to build which is the fluentd image. ...
0
votes
0answers
1k views

Why does “Watchdog: BUG: Soft lockup CPU” errors occur when running openstack containers in docker

I just deployed openstack using kolla and kolla-ansible stable/pike version. I deployed on one control node and one compute node. Both nodes are Dell PowerEdge 2950 servers that are running Centos 7. ...
2
votes
2answers
3k views

Cloud-init not finding metadata server (Openstack)

I am trying to understand why my server is failing to connect to the metadata server (and thus not able to log in with the SSH key). Similar problems online seem to be caused by Security Group ...
0
votes
1answer
312 views

How to connect to OpenStack instance (Ubuntu LXD Single Machine setup with conjure-up)

I installed Openstack on a single machine on Ubuntu 16.04 following the instructions from https://www.ubuntu.com/download/cloud/try-openstack. I found the LXD IP for Horizon and I'm able to create ...
0
votes
1answer
165 views

Openstack Neutron - error creating network - DBError Constraint Failed

I'm having an issue trying to create a network in Openstack Newton, tried with horizon and with the cli and both fail. > openstack network create --project admin --provider-network-type local --...
0
votes
0answers
35 views

Directing traffic to inactive pool on openstack

We have an openstack setup where a load balancer is directing traffic to the default pool (lets call it green_pool in this case). During deployments we place the new build on the inactive pool (...
0
votes
0answers
64 views

Configuration for connecting to subnet

I need to connect two virtual subnets. Hare is my topology on openstack: Network Topology There are two routers attached to blue network. First is external router on 192.168.9.1 gateway and second is ...
0
votes
0answers
73 views

Can openstack neutron integrate with an ethernet tap?

In our use case, we regularly need to capture traffic between every one of our nodes (telecom use, all signaling data is captured for generation of ladder diagrams/problem diagnosis/QoS validation). ...
0
votes
1answer
294 views

Openstack installation on Debian 8 networking fails

I'm trying to install Openstack using this manual. I have two virtual nodes: controller1(controller) and cmp1(compute). Both of them have 2 interfaces. Eth0 of both nodes are in same bridge br0 on ...
0
votes
2answers
392 views

Change Openstack Instance's Image

When creating an instance on openstack, it is automatically assigned an IP address on the subnet. I have an instance that has a bad image. The network is configured for the given IP address. Is ...
0
votes
0answers
457 views

Why on network node not create tap* interface when created instance?

OS RHEL 7.2, openstack release - kilo. I have 4 node: controller, network, compute and block storage. I have some problem. When I create instance on Horizon, he get IP, but in network node not create ...
1
vote
1answer
1k views

openstack: can't launch instance, multiple errors

I'm working with Openstack Mitaka, at the point to try launch an instance. When creating the instance it hangs in ERROR-state , just after built. I collected the errors from the logs, but so far I ...
0
votes
1answer
382 views

How can i set rules on a NW interface to drop all DHCP/BOOTP messages

I have an openstack environment with a provider network scenario implemented using openvswitch. My openstack is installed on allinone node setup. Is there a way that i can disable/drop all DHCP ...
0
votes
0answers
563 views

OpenStack Mitaka - Instances have no net connectivity

I've followed the Mitaka setup guide for my first OpenStack cloud. This all went ok (2nd time around!), however i'm now having issues with networking. The instance launches ok, and it's assigned an ...
1
vote
0answers
106 views

Setting dnsmasq_config_file with Puppet managed OpenStack installation

Our OpenStack installation is rolled out with Puppet. We use the excellent puppetlabs-openstack module for that. Due to the slow turnover cycles we are still stuck with version 5.0.2, right now we ...
0
votes
1answer
2k views

Openstack Neutron - Connection Refused when Creating Instance - I'm Out of Ideas

I've setup OpenStack - my first time. I've followed the installation guide (on Ubuntu 14.04) and I believe I've got everything correct. However, when trying to create an instance I get the error: ...
0
votes
1answer
669 views

How to install ncclient correctly on CentOS7?

I am able to install ncclient within a virtual environment on Ubuntu 14.04 server using python pip. Also need to install ncclient within virtual environment on CentOS7 Gnome Desktop platform. But I ...
0
votes
1answer
2k views

QoS/traffic-limit on internal ports in OpenVSwitch

I am currently trying to put traffic control on our OpenStack cloud and my questions in one sentence would be: is it possible at all to rate-limit particular port with type internal? The whole story ...
0
votes
0answers
591 views

Traffic Control in OpenStack Neutron with either TC or OpenVSwitch

As far as I know, QoS in OpenStack Neutron is still under development and not production-ready (I could be wrong on this point though, shout at me if so...), but we are required to implement traffic ...
4
votes
1answer
167 views

Is it possible to monitor how OpenStack is allocating virtual infrastructure on a physical one?

I've been wondering whether there's a tool for monitoring how OpenStack is using physical resources (cluster [cpus, ram], network [interfaces, switches]) for its virtual infrastructures? The virtual ...
1
vote
0answers
572 views

VM instance is not accessible by floating ip

I have an open stack VM instance having two NICs added from same Sub-Net. Both nics are configured for DHCP. When i start VM instance it gets one DHCP ip on each interface. I am able to ping this VM ...
1
vote
0answers
935 views

Multiple networks per interface in OpenStack in Hetzner

I'm trying to run a small OpenStack setup over a few servers hosted in hetzner.de, I'm currently deploying a basic setup to two servers. All servers are running Ubuntu, they are connected to each ...
1
vote
1answer
7k views

openstack installation on ubuntu. Neutron connection issue

I try to configure on a single node openstack by following this tutorial: http://docs.openstack.org/juno/install-guide/install/apt/content/neutron-controller-node.html My installation is done in a ...
-1
votes
1answer
346 views

Openstack Neutron on top of Amazon VPC

Is it possible to run Openstack Neutron within an Amazon VPC and still be able to use all of Neutron's features (GRE mesh network, etc)? I do know about Amazon's ENI and networking tools within a VPC ...
1
vote
1answer
2k views

Openstack Neutron stabilty problems

I have a fairly simple Openstack setup for a PoC. 2 nodes, both running Nova, and everything else on node 1. It is running CentOS 6 and was set up using RDO. Importantly I am using Neutron for the ...
1
vote
1answer
754 views

PackStack issues with neutron router-gateway-set

Using centos 6.5 I'm setting up PackStack on a single node with one network interface. I'm following these instructions http://openstack.redhat.com/Quickstart That works fine then I get to http://...