Questions tagged [pecl]

PECL (PHP Extension Community Library) is a repository of PHP Extensions.

Filter by
Sorted by
Tagged with
0 votes
0 answers
172 views

Amazon Linux 2 PECL_HTTP install fails

Attempting to install pecl_http using Apache 2.0 & PHP 8.0.8 on Amazon Linux 2 AMI. Full install below: [ec2-user@ip-xxx-xxx-xxx-xxx ~]$ sudo yum install php-pear Loaded plugins: ...
user avatar
  • 1
0 votes
0 answers
55 views

Centos 7 pecl install mysqlnd_azure failed to install

In Centos 7.9 with PHP - 7.4 enr, I want to install below Pear Extension https://pecl.php.net/package/mysqlnd_azure/1.1.1 However When i run below to install it gives me that package is not found. Any ...
user avatar
  • 3,875
0 votes
1 answer
83 views

Need to add older version of IUS repo in order to install specific PHP 7.2 packages

The Issue: Without unnecessary detail, I have two servers that are nearly identical. However one has its yum repos configured such that php 7.2 packages imagick and sodium are available for install, ...
user avatar
0 votes
0 answers
573 views

Can't execute `pecl upgrade-all` - stream_socket_enable_crypto(): this stream does not support SSL/crypto

I tried to execute pecl upgrade-all but I get: Warning: stream_socket_enable_crypto(): this stream does not support SSL/crypto in PEAR/Proxy.php on line 105 PHP Warning: stream_socket_enable_crypto():...
user avatar
  • 410
0 votes
0 answers
93 views

PECL install with clang instead of gcc or optimize gcc

I just tried to PECL install mongodb and phalcon, but the build process ran out of memory with a nice error: cc: internal compiler error: Killed (program cc1). I just found out clang is much better at ...
user avatar
  • 113
1 vote
2 answers
2k views

Where is the Redis module for PHP on CentOS 8 (php-pecl-redis)?

I can't find the package php-pecl-redis on CentOS 8 with EPEL repository enabled. Apparently EPEL no longer provides it. I've only found it on REMI repository, but I would have to replace my entire ...
user avatar
0 votes
3 answers
2k views

oci_connect(): Error while trying to retrieve text for error ORA-28547

I have this connection string on an older server which works fine and connects to a remote oracle server. On this new server I installed oracle instant client simple and devel and php pecl oci8. ...
user avatar
  • 568
1 vote
2 answers
4k views

Installation of pecl_http on PHP 7.3 / Debian 9 Stretch fails

I am trying to install pecl_http in PHP 7.3, however, there is an error: root@dev:/etc/php/7.3/mods-available# pecl install pecl_http downloading pecl_http-3.2.0.tgz ... Starting to download ...
user avatar
1 vote
1 answer
1k views

php error installing imagick

System - CentOS 7.5.1804 PHP Version - 7.0.3 So, I'm trying to install Imagick in order to be able to render/make an image off the first page of a PDF. I'm tried to understand how it is setup, but ...
user avatar
  • 113
2 votes
1 answer
5k views

How to install PECL when using PHP5.6 from http://ppa.launchpad.net/ondrej/php/ubuntu

I've installed PHP 5.6 from the PPA http://ppa.launchpad.net/ondrej/php/ubuntu. All the packages are called php5.6-whatever. There is no php5.6-pear in that PPA. How can I install php5.6-pear?
user avatar
  • 1,968
0 votes
1 answer
849 views

Issues using PHP Trader Functions: Call to undefined function trader_ma()

I'm attempting to install the Trader extension on my mac, currently using MAMP. I believe the install was done correctly but can't seem to use them. Here is my feedback from terminal sudo pecl ...
user avatar
  • 101
-1 votes
1 answer
177 views

Install kadm5 php extention

System is: openSUSE Leap 42.2 php 5.5.14-77.3.1 I want to install the kadm5 extention for php5 and have so far failed to do so. As https://codex.wordpress.org/User:Hakre/HowTo_PECL_on_Opensuse ...
user avatar
0 votes
1 answer
867 views

Installing GnuPG extension for PHP on Centos 6.9 Multiple PHP versions

I am trying to install gnuPG pecl module for PHP on a server where multiple PHP versions are install 5.3, 5.6 and 7.0. I was able to just use pecl install gnupg for the base 5.3 install. However ...
user avatar
0 votes
2 answers
145 views

IP2Location PECL Extension won't install on Mac can't link to bundle only dylib

I've been trying for the past 2 days to install IP2Location on my Mac. I've managed to install IP2Location C Library, now PECL extesion is causing issues. I've ran phpize and then 'sudo ./configure' ...
user avatar
  • 809
0 votes
1 answer
145 views

Tell APT to use package installed from source for a dependency

I'm on a raspberry pi (which I'm using as my web server for my consulting business) and I'm trying to install package php7.0-dev. However if I have this problem: sudo apt-get install php7.0-dev ...
user avatar
0 votes
0 answers
514 views

Unable to install pecl imagick

Environment: CentOS 6.8 PHP 5.6.5 (installed via Software Collections) I'm getting the following error when trying to install imagick: [root@vm ~]# pecl install imagick No releases for package "...
user avatar
  • 406
0 votes
2 answers
889 views

PECL install imagick using wrong php version

I'm running a server on centos 6.8, and running a magento 2 site on this. The default version of php is 5.3.3, however the site itself is running on 5.6.5. The latest upgrade to magento2 requires the ...
user avatar
0 votes
2 answers
359 views

Make fails attempting to install svn-1.0.2

Trying to figure out whats going on with this error so we can successfully install svn-1.0.2 I am using the command, echo -e "\n" |pecl install svn-1.0.2 root@us-east-1d-tengu-queuerunner-prod-141-8....
user avatar
  • 577
3 votes
2 answers
4k views

Install MongoDB extension on a specific PHP version

I have a Debian web server on which I installed Apache/Mysql/PHP5 around ISPConfig 3. I manually installed an additionnal PHP version (PHP 7.0.5) in order to have one website on PHP 5, and one website ...
user avatar
1 vote
2 answers
5k views

pecl install pecl_http fails - upgrading to php7 and http.so makes trouble

Similar issue: pecl_http failed to load So I wanted to upgrade to PHP7.0 and I believed all was fine. But I think I was missing somepages packages because i.e. I was not able to login into my ...
user avatar
  • 150
0 votes
1 answer
680 views

pear/MDB2_Driver_oci8 requires PHP extension "oci8"

I got this Error: unable to find package 'MDB2_Driver_oci8' file 'MDB2/Driver/oci8.php' so I tried to install it with pear install MDB2_Driver_oci8-1.4.1 but following Error is showing up pear/...
user avatar
1 vote
0 answers
1k views

Install Pecl PAM authentication Apache

I want to setup horde webmail 5.2.9 on my server (debian Jessie). When I go to localhost/horde/test.php I get: PAM Support (PECL extension): No The PAM PECL extension is required to allow PAM ...
user avatar
  • 21
0 votes
0 answers
459 views

How to Install Imagick PHP extension on Centos 5?

Can anyone advise me if it is possible to install the Imagick PHP extension on CentOS 5, running PHP 5.3, and if so, how? When I try to use pecl to install Imagick using sudo pecl install imagick I ...
user avatar
  • 111
7 votes
3 answers
14k views

Error with PECL command in PHP7

I've upgraded php to version 7 and now I have problems with pecl command. When I run sudo pecl install mongo I get long list of errors: Warning: Invalid argument supplied for foreach() in Command.php ...
user avatar
  • 229
1 vote
0 answers
678 views

PHP unable to load dynamic library's library

I have been trying to get imagick to work on a normal lamp server. What I did: sudo apt-get --purge remove "imagemagick" sudo apt-get --purge remove "php5-imagick*" service apache2 restart (lib not ...
user avatar
2 votes
3 answers
3k views

How to install PHP xdiff extension on Debian?

I am trying to install the PHP xdiff extension on Debian with Apache 2 and PHP Version 5.4.44, but I can't get it working. I tried the following pecl install xdiff But I got errors: […] checking ...
user avatar
  • 141
-1 votes
1 answer
721 views

Having issues installing Pecl Phar package - make failed

On Centos 6, php 5.5 I am trying to install the PHAR package with PECL. During the installation I get an "make failed" error: creating libtool appending configuration tag "CXX" to libtool configure: ...
user avatar
  • 99
0 votes
0 answers
393 views

Upgrade SQLite Library for php 5.4

My php version is 5.4 This is what I get in phpinfo pdo_sqlite PDO Driver for SQLite 3.x enabled SQLite Library 3.6.20 I really need to update this driver. On PHP 5.3 you could do this with ...
user avatar
0 votes
2 answers
2k views

Undefined php function http_post_data on Ubuntu server

Added the following under Dynamic Extensions in both php.ini's (Apache's, and the normal one found with: sudo updatedb && locate php.ini) extension=raphf.so extension=propro.so extension=http....
user avatar
  • 242
0 votes
1 answer
472 views

Call to undefined function apd_set_pprof_trace()

have hundreds of php files which initiates mails throw SMTP server using "mail()" function. Now the this SMTP is shutting down in few-days and we are asked to contact external EmailWebService to send ...
user avatar
2 votes
0 answers
1k views

config variable php_suffix does not match

I have a php instance on Webuzo (centos-6-x86_64.openvz) in /usr/local/apps/php54/. It already has pecl and phpize in /usr/local/apps/php54/bin/. When installing igbinary with command `/usr/local/...
user avatar
  • 211
2 votes
0 answers
1k views

Instal pecl_http: raphf installed but ./configure isn't seeing it

I'm trying to install pecl_http as an extension to php. phpise is working fine as I'm getting the configure file out. When I go to type ./configure I get the following error message; ... checking ...
user avatar
  • 149
44 votes
1 answer
57k views

how to install an older version of a pecl package

I have this code $passengerId = new \MongoId(oPassenger->getId()); return $this->createQueryBuilder('Device') ->update() ->multiple(true) ->field('...
user avatar
  • 1,067
0 votes
1 answer
2k views

Install a pecl package (gmagick) without PHPize

I am running Debian Wheezy with PHP5.5 (not the default PHP version of Wheezy). I want to install gmagick (already installed graphicsmagick from aptitude). So I did this command line : pecl install ...
user avatar
  • 145
0 votes
1 answer
432 views

Missing PHP libevent functions

I've instaled php-pecl-event library, but I cant see any library function: [root@server ~]# php -r "var_dump(function_exists('event_free'));" bool(false) [root@server ~]# php -r "var_dump(...
user avatar
  • 665
0 votes
0 answers
129 views

install ImageMagic library to php

When i try to sudo pecl install imagick i get this message: Can't find PHP headers in /usr/include/php The php-devel package is required for use of this command. ERROR: `phpize' failed And sudo yum ...
user avatar
  • 101
54 votes
7 answers
69k views

PECL command produces long list of errors

Currently running PHP 5.4 on CentOS 6.5. I installed the webtatic php55w package then installed PEAR+PECL without issue along with redis and mongo through PECL. Shortly after, I realized 5.5 is not ...
user avatar
  • 951
0 votes
2 answers
2k views

Apache fails to start after PHP upgrade on CentOS 6.5 x64

I have a developer server with CentOS 6.5 and PHP 5.5.11 (latest from REMI repos). Today I did: yum --enablerepo=remi,remi-php55 update That updated Apache and some other libraries like Mongo for ...
user avatar
  • 690
0 votes
0 answers
361 views

uploadprogress.so is installed, but does not appear in phpinfo

I'm on RHEL6 (Red Hat Enterprise Linux Server release 6.5 (Santiago)), but I've upgraded PHP to version 5.4.16. I've downloaded and installed the PECL uploadprogress library version 1.0.3.1 that is ...
user avatar
-1 votes
1 answer
7k views

how to install pgsql_pdo? [closed]

I need to install pgsql_pdo but getting this error via root@server5 [~]# pecl install pdo_pgsql root/tmp/pear/PDO/pdo_dbh.c:1139: error: ‘zend_internal_function’ has no member named ‘...
user avatar
  • 11
0 votes
1 answer
1k views

SQLite on latest PHP (>= 5.4)

http://www.php.net/manual/en/sqlite.installation.php Beginning with PHP 5.4, this extension is available only via PECL. http://pecl.php.net/package/SQLite This package is not maintained anymore ...
user avatar
0 votes
2 answers
1k views

nginx returning error 502 when get not exist key on memcached

I use nginx 1.2.3(php-fpm) php 5.4.7 pecl memcached 2.1.0 memcached 1.4.15 If memcached service stops or gets a not found key, nginx returns 502 error and in error_log I see: 2013/11/19 17:37:04 [...
user avatar
  • 1
0 votes
1 answer
2k views

Wrong php_sufix config variable in MAMP [closed]

I've just installed MAMP and I'm trying to install the Mongo extension via pecl but I'm getting an error: jonesy:bin Billy$ sudo pecl install mongo downloading mongo-1.4.4.tgz ... Starting to ...
user avatar
  • 239
1 vote
1 answer
1k views

Why mongo pecl module looses its connection after Primary stepDown?

I run an Apache 2.2.22-13 with pecl module "mongo 1.4.4". It connects to a MongoDB 2.4.6 sharded cluster. When a stepDown occurs, the mongo module seems to stay on the mongod node which was the ...
user avatar
  • 1,385
5 votes
2 answers
977 views

Amazon Linux pecl_http installed but not providing functions

I've installed PHP's pecl_http extension using the Amazon Linux php54-pecl-http Yum package. php -i shows the http.ini file loaded http.ini has the extension=http.so line in it php -m shows the HTTP ...
user avatar
  • 32.2k
1 vote
2 answers
2k views

Error while installing php extension 'expect'

I got some serious error while installing expect extension in PHP. I ran sudo pecl install channel://pecl.php.net/expect-0.3.1 I got error like this while running make, running: make /bin/bash /tmp/...
user avatar
-1 votes
1 answer
4k views

pecl can't find PHP - 'No such file or directory'

I have updated PHP on a CentOS install to PHP 5.5 via the Remi repository. The php-pear package is installed. However, when I try and run pecl, it can't find the PHP install; [root@box etc]# pecl /...
user avatar
1 vote
1 answer
2k views

How to install pecl spidermonkey on CentOS 6

Running the following command: > sudo pecl install spidermonkey I receive the following error: ... ... a bunch of successful checks ... ... checking whether to enable spidermonkey support... yes,...
user avatar
  • 191
0 votes
2 answers
6k views

make failed during pecl install oauth

I'm trying to install the pecl oauth package, but get an error: root@ubuntu:/# pecl install oauth downloading oauth-1.2.3.tgz ... Starting to download oauth-1.2.3.tgz (45,531 bytes) .............done:...
user avatar
3 votes
2 answers
2k views

Can't install Imagick for PHP on Debian from source, error says requires 6.2.4 when I have 6.7.7 installed

Pulling my hair out. PHP built from source, everything working. Now need to install imagick and can't get it installed. I am running Debian on kernel 3.7.1 with PHP 5.3.20 (the last version my app ...
user avatar
  • 310