Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [php5]

PHP is a general-purpose scripting language that is especially suited for Web development. The online manual is an excellent resource for the language syntax and has an extensive list of the built-in and extension functions. Most extensions can be found in PECL.

0
votes
1answer
75 views

Yum upgrade php error how to read

I am trying to upgrade php from 5.3 to 5.6 on centos 6.8. I am using Remi repo and have followed the instructions there. However on running: yum upgrade "php*" i get the errors here http://...
0
votes
1answer
392 views

Apache fork hangs on futex system call

We have a LAMP hosting server, Nginx as frontend for static files and reverse proxy for Apache. Apache + mod_php are serving php requests. Apache Server Version: Apache/2.4.10 (Debian) mod_fastcgi/...
0
votes
1answer
1k views

Reducing Apache Memory usage and Average Process Size Value

I know that question is little long but i choosed to describe each and every aspect which i observed from my end. I am using a Linux server, OS used is Ubuntu 14.04, all rest configurations are ...
0
votes
2answers
12k views

enabling mysqli extension on centos server

I want to enable mysqli extension on Centos server where PHP 5 is installed. After searching online, I saw many people talking about uncommenting mysqli related line in the php.ini and I couldn't ...
0
votes
0answers
28 views

Apache - low perfomance [duplicate]

I would like to ask about my problem with apache. Loading times of web pages are offen more than 8s although system resources are in minimum use (about 20% cpu and 3GB ram). It is very old server but ...
0
votes
1answer
2k views

How to change php version used by apache on debian

My server is running debian 7 and I have php 5.4.45 installed via apt-get. I need php 5.6 for some other service to run properly, but unfortunately I couldn't find any way to install it via apt-get. I'...
1
vote
0answers
757 views

PHP gd JPEG image support missing

I have a centos 7 server and need multiple versions of PHP. I am compiling PHP 5.6 and the php application needs to support GD Jpeg. I have the following error. ./configure --prefix=/opt/php-5.6.28 .....
1
vote
2answers
3k views

SMTP connect() failed when request comes from browser

I have a PHP script which send email using PHPMailer library. When I run the script in the SSH using PHP command, it sends email perfectly. But when the request for the same script is coming from a ...
0
votes
1answer
1k views

“Class 'XMLWriter' not found” Error in php | php55w-xml-5.5.24-1.w6.x86_64.rpm is missing

I am getting this error in PHP in server Fatal Error (E_ERROR): Class 'XMLWriter' not found . we are using Cent OS 6 After exploring some sites, we found that we need to install php55w-xml-5.5.24-1....
5
votes
1answer
7k views

php-fpm: unrecognized service

I can't seem to restart my php fpm on my Ubuntu server I did ps aux | grep php-fpm I got root 1543 0.0 0.7 444672 7552 ? Ss Nov10 2:14 php-fpm: master process (/etc/php/5.6/...
5
votes
1answer
340 views

Apapche + php-fpm + mysql too slow on powerful server

I'm trying to test load a LAMP application that my team developed and deployed on AWS ubuntu 14.04 using jmeter. We are using AWS CDN to serve static files, mysql and apache are on the same host. ...
3
votes
1answer
30 views

Certain sensitive PHP files overwritten with garbage. Hard-drive fault? How could this happen? Should I be worried?

I was trying to upgrade a Prestashop store in a local copy in my machine. Running XAMPP under Windows 7. I put that on hold for a while while I browsed some websites with Firefox. When I came back and ...
0
votes
0answers
163 views

Why does the ondrej ppa to install php7 also installs php5?

I'm installing php7 on Ubuntu 14.04 using ppa:ondrej/php and I realised it also installs php5. Is there a reason for that? Should I remove php5 if I'm not going to use it? What's the good practice? ...
0
votes
1answer
59 views

Is it safe for a server running an http API to have 100% CPU usage?

I have an API (based on php, and connecting to separate mysql database server) that is called lots of times, and the software that is calling it can wait for the result for a long time and it will not ...
0
votes
1answer
249 views

Fixing path issues on php application

I've installed a2billing. The problem is that it's showing only blank pages. Here is the apache log: [Sun Oct 23 17:51:17 2016] [error] [clientIP ADDRESS] PHP Warning: include(../lib/admin.defines....
1
vote
1answer
312 views

FreeTDS PHP mssql_connect() 503 on refresh

We have recently installed FreeTDS with php56-mssql onto one of our RHEL7 servers. Everything appears to be functioning correctly except for this strange issue. The first time we load a php page that ...
1
vote
0answers
336 views

MPEG-DASH server 405 error PUT is not allowed for the URL /dash/dash.m4s

I am trying to build an MPEG-DASH server on Ubuntu 16.04. I installed Apache and PHP, but each time I am trying to put files inside the folder dedicated for the segments coming from the encoder, I ...
1
vote
0answers
1k views

php5.6-fpm with Apache 2.4 displays php source on Ubuntu 14.04

My Ubuntu Vagrant displays PHP source instead of interpreting PHP scripts. What am I doing wrong? My apache.conf: <Directory /> Options FollowSymLinks AllowOverride None </Directory&...
1
vote
2answers
131 views

hhvm binding on port 80 preventing nginx from binding on that port

I am running hhvm on ubuntu14 with the following server.ini config: server.ini ; php options pid = /var/run/hhvm/pid ; hhvm specific ;hhvm.server.port = 9000 hhvm.server.file.socket=/var/run/...
0
votes
1answer
634 views

Cannot run Apache 2.4 with libapache2-mod-php5

I have a Vagrant Debian Wheezy running Apache 2.4.10 and Php 5.6.26 I need to install and run libapache2-mod-php5 to make Apache able to read php_value inside an .htaccess file. TL;DR the error is ...
2
votes
1answer
11k views

PHP 5.6 undefined function xml_parser_create

I have a new php 5.6 installation and get the following error from my application: Fatal error: Call to undefined function xml_parser_create() But libxml seems to be OK? phpinfo about libxml is: ...
0
votes
0answers
91 views

apache php server weird logout issue

we have recently moved PHP application on new server,but we are facing weird session out issue on new server, the session.gc_maxlifetime = 86400 in php.ini but the application goes logout in between ...
3
votes
0answers
131 views

How to harden nginx vhosts (hosting WordPress) from other users in hacked WP installs

Overview: I have a dozen or so WP installs hosted on an Ubuntu 14.04 LTS, w/ PHP 5.5.9 & Nginx 1.4.6. MySQL runs on alternate node, not on public network. Goal: To have directories & files ...
1
vote
1answer
102 views

Install php_mailparse extension on IIS Windows 2008 RS2

I can't install the php_mailparse properly in a Windows Server 2008 RS2. I have the error: PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program Files (x86)\PHP\v5.4\ext\php_mailparse-...
-2
votes
1answer
156 views

How can I optimize my web server to run MyBB faster? [duplicate]

I am running a web server with MyBB and Pingdom says it takes 629ms to load my site's index. I was wondering if there is a way to lower this. This is the information I have about page generation time: ...
0
votes
1answer
377 views

Baikal Server 0.4.5 Sync-Error 403 Forbidden

I have some troubles using Baikal Server 0.4.5 getting always some errors, when I want to set up the sync in an app. Environment: CentOS 7 Apache 2.4.6 PHP 5.5 SELinux Enforcing (but same on ...
0
votes
1answer
407 views

apache server hangs php-cgi, how can i debug further

We have Windows Server 2012 R2, Apache 2.2.31 and Php 5.6.18, Zend Server Version: 8.5.3 Apache seems to be hanging more and more frequently, a restart of apache seems to fix the problem most times. ...
1
vote
0answers
17 views

Script file is created to send junk mails [duplicate]

I have installed Joomla 3.3.6 on my ubnutu server 15.04 on cloud. I have noticed some script file created automatically which is sending some junk mail randomly. I have installed maldetect to check ...
-1
votes
1answer
419 views

How to Only install php5-mysql

Server System:Debian 7 My MySQL Server is not the same one for Apache Server,SO ,i want to install php5-mysql to connect mysql ,but when i use apt-get install php5-mysql,it always install mysql and ...
2
votes
0answers
327 views

Compiling PHP 5.5.7 with PDO IBM for IBM DB2

I'm trying to compile PHP 5.5.7 on an Ubuntu 12.04 with ubuntu precise partner repository enabled to allow to install IBM DB2 from db2exc package. When I configure PHP with pdo ibm source /home/...
1
vote
2answers
8k views

PHP parse error syntax error, unexpected end of file

I keep getting this error when i was on a LEMP setup nginx 1.10/PHP 7 and i thought it was because of PHP 7 and now i setup a new server with nginx 1.4.6/PHP 5.5.9 2016/06/19 15:45:18 [error] 4094#0: ...
-2
votes
1answer
113 views

Apache Extended Logs of php files

I am using apache and I want to log each php or any script file with its location which runs for more than 30 seconds or so. I tried to find solutions extensively, but no luck has come true. Is this ...
1
vote
1answer
3k views

Fix PHP error Invalid argument supplied for foreach() after update PHP & Mysql

I have updated PHP from 5.3 version to PHP 5.6.21 (mod_fcgid) on my CentOs 6.5 vps. The vps holds 4 Prestashop and almost works but cart doesn't work as expected. The php error log contains this ...
0
votes
1answer
876 views

Cannot get php5-fpm to work on Ubuntu 14.04 with Apache 2.4.7

I have been trying for two days now to upgrade my regular LAMP stack to use php5-fpm and event-mpm, but it just doesn't want to work! At this point seems like I've tried everything to make it work, ...
0
votes
1answer
35 views

New server worked for a few hours, but now connections time out

I used this guide to set up Apache2 and PHP5: link. I set up a simple PHP script, debugged some permissions issues, got everything working. A few hours later, it stopped working. I could no longer ...
0
votes
1answer
54 views

A Website in my Centos 6 server is picking incorrect PHP version

I have a CentOS 6 server that has PHP 5.6.20 installed: # php -v PHP 5.6.20 (cli) (built: Apr 2 2016 08:28:23) Copyright (c) 1997-2016 The PHP Group Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend ...
0
votes
1answer
3k views

Configuring apache2-mpm-worker with php5

I have a ubuntu 14.04.4 server box and I have installed apache2 and php5 packages but after enabling mpm_worker and restart apache I got following error " Apache is running a threaded MPM, but your ...
1
vote
0answers
437 views

PHP Script sending spams and mail.add_x_header not working

I've got my server hacked lately by some Php64 malware. Since then, I have found a lot of PHP files in my /var/www sub-folders. I am trying to delete each of these or clearing the files when some ...
1
vote
0answers
205 views

apache php-fpm: How to run scripts on same domain w/ different users

I have a number of directories containing php scripts that need to be run as separate users. Example directory structure is as follows: /var/www ├── project │ ├── item1 │ │   └── script1.php │ ...
1
vote
1answer
106 views

MS Native SQL driver 10.0 and SQL Server 2008 connection creation failure

I'm trying to narrow down and debug quite elusive error: State: 08001 Code: 258 Msg: [Microsoft][SQL Server Native Client 10.0]TCP Provider: Timeout error [258]. State: HYT00 Code: 0 Msg: [...
0
votes
0answers
364 views

Nginx and strange file permissions after upload

I am trying to upload files inside of wordpress, but I am getting errors. This is not due to the upload failing, but the upload having the wrong permissions. I can find the uploaded file, and when I ...
1
vote
0answers
389 views

PHP unable to load dynamic library's library

I have been trying to get imagick to work on a normal lamp server. What I did: sudo apt-get --purge remove "imagemagick" sudo apt-get --purge remove "php5-imagick*" service apache2 restart (lib not ...
0
votes
1answer
21 views

Forwarding custom page rule for known ip adresses

I want to add some ip adresses to a blacklist, and i want to show these ip addresses in blacklist a custom web page that includes a "you are in blacklist" message on body. How can i do this? I have ...
1
vote
0answers
191 views

Getting 404 Not Found while PHP works in background - Nginx

I have noticed that I get 404 - Not Found when calling a .php file even if the script works in background. The php file downloads a long Json and populates a db until I close the window. I am using ...
0
votes
1answer
2k views

php:5-apache docker image no /etc/php/apache2/php.ini

I just pulled docker image php:5-apache and it runs well and all but there is no /etc/php5/apache2/php.ini file so I can't add extension=mongodb.so even if it is installed with PECL.
0
votes
2answers
68 views

Create and save mail to inbox locally with Postfix

Apparently it's as simple as just sending an e-mail to a local account, and configuring Postfix to receive mail for the local account. Not too shabby! Original Question This hypothetic server would ...
1
vote
2answers
3k views

Apache webserver HTTPS port redirects to HTTP with port 443

At my work I installed Mediawiki (latest version) on a Apache webserver 2.4.6 with PHP 5. Everthing works fine when I want to access the wiki pages locally and I configure a hostname in Mediawiki $...
0
votes
1answer
88 views

Php can't find hash function

I'm using apache with php on amazon linux. I've updated php from 5.3 to 5.5 and apache from 2.2 to 2.4. Now calling echo hash('sha256','wtf'); is behaving in a strange way. It works for a while and ...
0
votes
0answers
181 views

Apache + PHP Memory Limit Upload Issue

My environment is Fedora 20, Apache 2.4.10, and php 5.5.26 and I am having an issue with uploading a file that is greater than 2 GB's. If I upload a file greater than 2 gb's I'm noticing that while ...
4
votes
2answers
7k views

CentOS 7.2, PHP 5.4 - MySQL extension is missing [closed]

I'm trying to install a Wordpress blog on my Linux server (CentOS 7.2), using PHP 5.4 and MariaDB, but I keep running into this error: Your PHP installation appears to be missing the MySQL extension ...