Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [php5]

PHP is a general-purpose scripting language that is especially suited for Web development. The online manual is an excellent resource for the language syntax and has an extensive list of the built-in and extension functions. Most extensions can be found in PECL.

2
votes
1answer
2k views

Issue installing Ioncube with PHP 5.6.11 with Apache 2.4.16 on centOS 6.7

This is how I am compiling PHP 5.6.11 with apache2 2.4.16 on cenOS 6.7: ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-config-file-path=/usr/local/lib --with-mysql --with-curl --with-...
0
votes
1answer
703 views

Are the php-zts extensions needed when the mpm is event?

my php is correctly installed and working, but at Apache startup I have all the current loaded extensions with warning messages like... [23-Dec-2015 21:47:45 UTC] PHP Warning: PHP Startup: bz2: ...
-1
votes
1answer
99 views

FreeBSD -no internet access -no packages

I just used this command: make -DBATCH install clean and realized that I don't have access to internet from FreeBSD. If I type the address manually the browser doesn't let me see them. Can ...
1
vote
0answers
24 views

Website trying to pull up a page from a different site

We've had an issue come up a couple times in the past month or so, and I don't know what is causing it. After the first time, we wrote it off as a fluke, but it happened again today, so I'm looking ...
0
votes
1answer
3k views

PHP Fatal error: Directive 'register_globals' is no longer available in PHP in Unknown on line 0 [duplicate]

Cron [ -x /usr/lib/php5/sessionclean ] && /usr/lib/php5/sessionclean PHP Fatal error: Directive 'register_globals' is no longer available in PHP in Unknown on line 0 Hi, root get above ...
0
votes
2answers
971 views

Error with apache 2.4 and PHP 5.6.14-0+deb8u1 With fpm

I have a Vagrant machine with: Apache/2.4.10 (Debian) PHP 5.6.14-0+deb8u1 and PHP-FPM. In some case I get this error: 500 Internal Server Error. And I have this in message in php5-fpm.log [09-...
0
votes
0answers
24 views

PHP files downloading instead of executing [duplicate]

I have what I understand to be a reasonably common problem-- Apache is downloading PHP files instead of executing them. I've used the solutions on other threads as best as I was able and learned the ...
0
votes
1answer
202 views

Apache serves PHP file as plain text if %20 is added to the file extension [closed]

I've never seen this before and Google didn't lead to any results so far. I am almost sure it is a mistake so stupid that I should see it but I just don't. I have a very basic Apache server with PHP, ...
1
vote
1answer
1k views

Ubuntu 12.04 PHP 5.3 to 5.5 update fails

on a Ubuntu 12.04 Server I´m trying to update PHP 5.3 to 5.5 this is what I have done: sudo add-apt-repository ppa:ondrej/php5 sudo apt-get update sudo apt-get install php5 unfortuntely the ...
2
votes
1answer
809 views

Inconsistent download size with PHP + NGINX configuration

I'm building a Joomla website using docman for document management/downloading. The site is built on a Ubuntu 14.04 server running Nginx 1.4.2 and PHP5 (FPM). The issue i'm having is that files are ...
1
vote
0answers
137 views

upgrading PHP from 5.3.3 to 5.4.40 breaks

I have a RHEL 6.7 server running: Apache: 2.2.15 PHP 5.3.3 getenforce => Disabled As is, its working fine. The web master for the server tells me that PHP-5.3 will no longer work with Facebook's API ...
0
votes
1answer
3k views

sqlsrv not showing up in phpinfo.

I'm using Win server 2k12, php 5.5.12, on wamp. Edited php.ini (both on apache dir and php dir) to add php_sqlsrv_55_ts.dll and the php_pdo_sqlsrv_55_ts.dll, and configured the extension dir path ...
2
votes
1answer
64 views

Why is my connection to php-fpm.sock being refused?

I've seen a bunch of questions about this problem on here but none of those had answers that helped me out. I kept getting a 502 error from nginx so I took a look at the access.log and saw I kept ...
0
votes
0answers
30 views

webpage issue after enabling ssl, all i see is files and folders on my webpage

I installed Teampass on my lamp server and it was all good on http. now that i have enabled ssl for https all i see are the files on the webpage. not more graphics etc. I need help please.
0
votes
1answer
272 views

PHP session files unable to save after a mass deletion

I had an excess of php sessions files created on a server in /var/lib/php5/ so I deleted them, but now php5-fpm and my server refuse to write sessions files. I assumed that the session files would be ...
0
votes
1answer
782 views

Getting soap to run on a Vagrant CentOs machine

I have a vagrant machine on my local computer and I am testing an API that requires Soap. For the life of me I cant get soap to install on the machine. Checking phpinfo, I note: SOAP Brad ...
-1
votes
1answer
780 views

Bash command in PATH to be run from PHP script [closed]

in Debian 8, I'm trying to create a script I can put under /sbin (which is in my $PATH environment variable), so it can be run, the command is a simple echo of a few lines. I've created a bash script ...
0
votes
1answer
55 views

How is leading slashes handled in server and in client?

I am trying to create a RewriteRule, but it's unreliable and I can't figure out what is happening. Here's my rule: RewriteRule ^docs/(......)/$ index.php?docid=$1 [L] the problem is leading slashes, ...
0
votes
0answers
163 views

How to Install XCache on BlueHost VPS

I have a VPS account on BlueHost. The OS is CentOS6.7 x86_64 and PHP version is 5.4.28. I followed instructions from here to install XCache and the installation failed. The installation failed ...
0
votes
2answers
1k views

symbol xmlOutputBufferGetSize, version LIBXML2_2.9.0 not defined in file libxml2.so.2 with link time reference

I've installed Apache2 and PHP5 via apt-get on Ubuntu 14 (amd64), Tomcat 6, and Postgres 8.4. I get this error message on an attempted restart: apache2: Syntax error on line 140 of /etc/apache2/...
1
vote
0answers
379 views

Installing an intermediate cert on Debian 8 for curl/openssl connections.

I am trying to contact a url via php's stream_socket_client() command which is failing with no error code or msg. Does this use openssl, curl or something else? The site uses https and works fine from ...
1
vote
3answers
4k views

How to disable some extensions in php 5.6?

I have installed php 5.6 in centos 6.7 server using yum --enablerepo=remi,remi-php56 install -y php-mysqlnd php-gd php-mbstring php-mcrypt php-xml php-fpm I have the following php extensions ...
1
vote
0answers
3k views

mod_fcgid: ap_pass_brigade failed in handle_request_ipc function

I have been struggling for weeks with this error: (32)Broken pipe: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function followed sometimes with this error: (104)Connection reset by ...
1
vote
1answer
193 views

virtualbox ansible and PHP

I am trying to install Centos-7 on Ubuntu vivit in Virtual Box using Ansible. I get through a large amount of configuration and set up before it fails with the message below. I have searched for ...
2
votes
0answers
1k views

upload_max_filesize: php.ini or apache virtual host entry

I need a little perspective here as I am a bit confused. I was under the impression that adding a <IfModule mod_php5.c> php_value upload_max_filesize 200M php_value post_max_size 800M </...
1
vote
1answer
197 views

How To Only Restrict PHP5/Apache to Send Mail Only To Local Users

I need some help. I am running lastest stable Ubuntu which hosts Apache/PHP5 and also delivers email. I host some WordPress sites for other users and have been waging a war for months now combatting ...
2
votes
0answers
480 views

php5 not working with nginx 1.9.3

I am new to nginx, and having some trouble with php5. (I had it sorta working, but cant seem to get it working again.) There are 2 files I am woring with, that seem to control nginx, and php5-fpm. /...
0
votes
1answer
1k views

Apache and php5 fail on ubuntu server

I update a PHP 5.5.28-1+deb.sury.org~precise+1 (cli) and have apache Apache/2.2.22 but when run a restart apache2 apache2: Syntax error on line 216 of /etc/apache2/apache2.conf: Syntax error on ...
1
vote
1answer
966 views

Debugging slow server response time [closed]

I'm testing response time of my VPS server: curl -s -w %{time_total}\\n -o /dev/null http://www.example.com The values are typically round 300ms, Google suggests that it should be lower than 200. ...
1
vote
1answer
285 views

“Allowed memory size of 67108864 bytes exhausted” when PHP memory limit is set to 128mb

Forgive me if this is the wrong place; was unsure whether to post this on SO or here. I'm getting the above error from a script, implying that I've reached the limit of 64mb of memory for the script. ...
0
votes
1answer
339 views

PHP 5.4 packages are installed but the server is using PHP 5.3

I'm trying to upgrade PHP 5.3 to 5.4 on a CentOS 6.7 VPS. Followed the Webtatic instructions here: https://webtatic.com/packages/php54/ Now at a stage where the 5.4 packages are installed, but PHP 5....
0
votes
1answer
1k views

Apache spawns bunch of php-cgi processes and they don't exit - webite hangs

Out of the blue, apache started to not to respond when I tried to load my website. Website is based on Drupal just for the information. I checked server status by doing service httpd status and it ...
0
votes
0answers
655 views

Cannot install php-mysql

I have a VPS with CentOS 6.6 x86-64 and ISPManager, PHP 5.4.43, Server version: 5.5.45 MySQL Community Server (GPL) by Remi and an version phpMyAdmin. I upgraded php from 5.3 to 5.4 and mysql from 5.1 ...
0
votes
1answer
565 views

I just installed LAMP on a new CentOS 7 server - why are my php-openssl commands undefined?

I have some scripts that utilize some of the openssl PHP functions, such as openssl_opbkdf2. I am migrating from an Ubuntu server to a newly-created CentOS 7 server with a fresh install of the entire ...
0
votes
1answer
280 views

DefaultType PHP 5.5 (for files that do NOT have any extension, including “.php”)

How can I add PHP to deal with files that do not have any extension? Is there a "DefaultHandler" directive? In Apache 2.2.29, with PHP 5.5, the following does not work: DefaultType application/x-...
2
votes
1answer
487 views

Environment variables for PHP applications

A PHP application requires me to set several environment variables with things like database credentials, SMTP server, etc. Examples of variables include: FOO_DATABASE_URL=mysql://user:pass@host:...
0
votes
1answer
2k views

Laravel: default route will render but others will not. Ubuntu/14.04 / Apache2 configuration issues? Not sure what I am doing wrong

Laravel will render the default / root page normally. but will not render default routes or error pages. My web browser will return with Apache (NOT Laravel) error pages with I try and access /test ...
0
votes
1answer
875 views

Installing PHP 5.2 on RHEL 7.1

We are planning to move to Amazon EC2 server. Our current server version RHEL 5.5 and PHP 5.2. We are planning to configure Amazon RHEL 7.1. Does RHEL 7.1 support downgrading PHP version to 5.2. I'm ...
0
votes
1answer
693 views

Supervisor 3.1.3 installed on Cento OS 6.4 hosted on DigitalOcean giving error while adding process

I have live server on Digital Ocean with Cento OS 6.4 hosted. I am trying to install supervisor for the Laravel-5 processes. But, when I try to add the process it gives me error as undefined process. ...
-1
votes
1answer
801 views

Why do my PHP files show as text in browsers? [closed]

Long story short, my PHP files show as text in browsers rather than running the PHP script. I am aware that there are questions similar to this but none answer my question. I'm lost. I have an Apache ...
2
votes
3answers
4k views

206 Partial Content returned with Content-Length: 0

I'm serving large audio files on an Apache server using mod_xsendfile (version >= 0.10). The files are served fine when I use header( 'HTTP/1.1 200 OK' ); However, those files are served in full. ...
1
vote
1answer
3k views

Apache with PHP-FPM not working

I am following this and this article to setup apache2 and php5-fpm under Ubuntu 14.04, but it always return a HTTP 403 when I run phpinfo(), how do I fix it? I didn't edit the virtual host ...
1
vote
0answers
242 views

How do I troubleshoot an unresponsive Apache2 instance using 100% CPU?

I'm running a Debian 7 server with Kolab Groupware installed and not much else. It works perfectly fine normally, but randomly (always when I'm not looking, of course) the CPU usage will spike to 100% ...
1
vote
1answer
99 views

Protocol-relative URL in CSS file is being overwritten

I have this code: <?php header('Content-Type: text/css; charset=utf-8'); ?> a.logo{background:url(//webzina.net/img/logo.png) no-repeat 100% 0} Locally (PHP Version 5.3.5), I get: a.logo{...
0
votes
1answer
1k views

centos 6.6, sh: zip: command not found [closed]

Centos 6.6 64bit on OpenVZ VPS. I tried a phpinfo.php file using only the following code: <?php var_dump( exec('zip -r domains.zip "domains"') ); // phpinfo(); ?> . The php error log is now: ...
0
votes
1answer
298 views

Installing php 5.5+ on Centos 6 alongside 5.3

How can I install PHP 5.5+ alongside php 5.3 (or 5.4 with the EPEL repository) on a Centos 6 server? I don't want to remove or supersede the default version, but I would like to have both versions ...
1
vote
1answer
1k views

502 errors on random (not all) pages

A few weeks ago I noticed in the Google Webmaster tools that a few of my URL's were returning 502's. One such URL is http://www.sau.com.au/forums/topic/437438-around-the-bay-wrap-up/ This URL ...
0
votes
0answers
797 views

how to update php from 5.3 to 5.4 in ubuntu 14.04

We have a PC installed ubuntu 14.04, but only installed php 5.3.10-1ubuntu3.4, not the last version. Now we want to upgrade to php 5.4. I tried the solution by this post: How do I upgrade from PHP 5....
0
votes
1answer
1k views

APC - tuning apc.mmap_file_mask

When configuring APC as an opcode cache for PHP, there's a configuration setting called apc.mmap_file_mask. From what I've read there are three ways you can configure it but I don't really understand ...
0
votes
3answers
6k views

How do I enable updated PHP 5.5 versions in RHEL 7

As our development projects expand we're finding we often need newer versions of PHP, Python, Ruby, etc than are provided by Red Hat. What are others at NU doing to solve this problem? There doesn't ...