Questions tagged [php7]

Use this tag for questions specific to PHP version 7.

Filter by
Sorted by
Tagged with
0
votes
0answers
24 views

PHP Ajax response sending new line in return data from server

I work with an open source package call OpenEMR https://github.com/openemr/openemr/. I am having a problem with the ACL display screen. It displays this error message. ERROR, unable to collect data ...
0
votes
1answer
24 views

Apache: phpmyadmin on sub-domain “503 Service Unavailable”: php7.4-fpm

I'm having a tough time trying to fix a major problem getting phpmyadmin working again (it used to work on ubuntu 16.04). I upgraded Ubuntu 16.04 to 20.04 yesterday and got the following versions of ...
0
votes
0answers
7 views

php-fpm status page does not display info about Idle processes

I have PHP 5.6 and PHP 7.3 running on my machine. Webserver is Nginx and is using FastCGI (php-fpm). I have setup two php-fpm status pages - one for the www pool of the php-fpm 5.6 and one for the www ...
0
votes
0answers
25 views

PHP-FPM workers timeout times exceeding configuration limits

We are running server with this configuration: Nginx + FastCGI (PHP-FPM) + PHP 7.3 + MySQL 5.7. However, we experience some issues with long running PHP scripts, so we have setup these restrictions: ...
0
votes
0answers
19 views

Compile php 7.4.16 with custom php extension for phpdesktop

I'm trying to compile php 7.4.16 for phpdesktop on ubuntu 20.4, which needs a compiled php-cgi binary. But i want to add a extension to it named php-sweph. I can compile php and add the usual extra ...
1
vote
1answer
54 views

Random Internal Server Error

We are receiving random internal server errors on one of our website. These internal server errors can sometimes appear only on some users but other users are not receiving it (at the very same time) ...
0
votes
2answers
28 views

RHEL PHP 7.3.5 with mysqlnd and apache

I'll start by stating I'm not a server admin by trade, so I've been struggling with this task. PHP 7.3.5 was already installed on RHEL7 running Apache. I have installed MySQL successfully and now I am ...
0
votes
0answers
48 views

Upgrading PHP from 7.0 to 7.4 is not recognized by composer

I have perform an upgrade of the PHP version running in our server from PHP 7.0 to PHP 7.4. The IIS PHP Manager seems to be correct: Checking phpinfo() displays the correct version: also from ...
1
vote
0answers
20 views

Some PHP extensions available only for root user

I have installed PHP 7.4 (from remi) on CentOS 8 since I need that version on CLI. The issue is with extensions, when I check modules (php -m) as root user I for example have redis enabled there, but ...
0
votes
0answers
18 views

Add php7 support on existent Windows installation Apache2.4 and php5.6

I have a Windows server running Apache 2.4 and PHP 5.6 and I'm like to add PHP 7 to have two version on same server. PHP 7 must be run on specific alias. Here my error End of script output before ...
0
votes
0answers
80 views

Set default Php in CentOS 7

I have a centos server 7 with php 7.2 default installation. So, if I run php-v I get as output : PHP 7.2.34 (cli) (built: Feb 3 2021 09:23:21) ( NTS ) Copyright (c) 1997-2018 The PHP Group Zend ...
0
votes
1answer
622 views

How to properly set specific PHP version used by Apache on Arch?

So it appears that after a recent Arch system upgrade, my NextCloud server no longer works, currently giving me "This version of Nextcloud is not compatible with > PHP 7.4. You are currently ...
0
votes
0answers
11 views

Double path directive in php.ini

When configuring path specific parameters within a [PATH="D:\inetpub\website"] inside php.ini, I must specify the path and rules twice, else the main configuration is used. For exemple : [...
2
votes
0answers
73 views

mod_fcgid: can't apply process slot for - error repeats every 6 hour

On server, I run Apache via FastCGI using PHP 7.4.13: /etc/httpd/conf.d/ is configured as this: # Use FastCGI to process .fcg .fcgi & .fpl scripts AddHandler fcgid-script fcg fcgi fpl # Sane ...
1
vote
0answers
106 views

Nextcloud internal server error after server upgrade

I upgraded my server today from Debian 9 to Debian 10 and installed PHP 7.3 with all modules needed for NC but when I try to open the website I get "internal server error. More details can be ...
1
vote
2answers
544 views

Fedora 33/32 - Install PHP 7.3

Seems simple, but I have been unable to install any version other then php 7.4 reliably on fedora 33 (32 seems to have the same issue according to remi). PHP 7.4 is the default install, but the ...
1
vote
2answers
385 views

What is the origin of ZLIB's “Zlib error -2 deflating data”

Some of my sites are getting, seemingly without reason, strange errors like these: [Fri Nov 06 08:29:07.677505 2020] [deflate:error] [pid 23820:tid 140019129566976] [client XXX.XXX.XXX.XXX:XXXXX] ...
0
votes
0answers
56 views

PHP Zip module doesn't load

I use PHP 7.4 and Nginx 1.16.1 and i want to enable php-zip in my server because a wordpress plugin required it: I installed zip module (php-pecl-zip-1.19.1-1.el7.remi.7.4.x86_64). If i type php --...
0
votes
0answers
55 views

Can't run WP CLI due to a Fatal Error

I am attempting to run WP CLI on my server, but I get an error when I try to run it. My server is running on Ubuntu 18.04 and PHP 7.4. When I run WP CLI I get this error: PHP Fatal error: Uncaught ...
0
votes
0answers
26 views

Why is Samba exporting files as directories

I recently rebuilt my Ubuntu server after boot disk problems. There are several other physical disks on the server. Samba now shares most (website I think) files as folders that are marked with a ...
0
votes
0answers
245 views

Installing PCNTL module for PHP7.4 on Amazon Linux

I'm using amazon linux2 and trying to install pcntl extension for php7.4.9. There are no package for pcntl after run yum search pcntl, so I manually copied file pcntl.so to /usr/lib64/php/modules and ...
0
votes
0answers
49 views

PHP settings in apache2 config file completely ignored

On a fresh Debian 9 install, I installed PHP 7.2 and Apache2. php has been installed from the Sury repo with these extensions: php7.2-mysql php7.2-dom php7.2-simplexml php7.2-ssh2 php7.2-xml php7.2-...
1
vote
1answer
5k views

PHP Warning: failed to open stream: HTTP request failed

I have two web servers: www.example.com.ar and eventos.example.com.ar I get the errors such as: [Wed Sep 16 12:11:30.872792 2020] [php7:warn] [pid 17125] [client xx.yy.226.234:48896] PHP Warning: ...
1
vote
1answer
302 views

Can't deploy to Google Cloud Platform on Laravel

I got the following error while deploying laravel on GCP with "gcloud app deploy". ERROR: (gcloud.app.deploy) Error Response: [9] Cloud build ID~~~ status: FAILURE Error ID: 5888fcc4 Error ...
1
vote
1answer
39 views

Centos 7.7 remove dupplicate php 7.2 version

I'm working with centos 7.7 and the client has provided me with a vm where they unawarely installed the same version of PHP, which is 7.2, two times in two different ways, one of which is by remi's ...
0
votes
0answers
145 views

centos8 - error installing php74

I am a newbie in Linux. While trying install PHP-7.4 on CentOS 8 by instruction in https://rpms.remirepo.net/wizard/, I get error Unable to resolve argument php:remi-7.4 at command dnf module install ...
0
votes
0answers
210 views

FastCGI allowed memory exhausted in Wordpress

I have Wordpress running on a Ubuntu 20.04 server with Nginx and PHP 7.4. When trying to generate a feed (by going to a feed URL such as /category/feed) , I receive the following error: 2020/09/11 18:...
0
votes
1answer
174 views

Apache Link to PHP run application/x-httpd-php *

For example: I create a Link to PHP script file to file.php <?php echo 'exaple'; ?>. When I open file online I get the PHP script not exaple. If I open file.php I get exaple. I have tried if ....
0
votes
0answers
51 views

Routing to a PHP website in local LAN

I have an Ubuntu-Apache2/PHP website on a computer in my LAN network which I have trouble accessing through another computer in the same network. As an illustration, the IP address for that webserver ...
0
votes
0answers
17 views

How to disable php 'not found' errors in apache2?

I wrote a script to send me the apache2 error logs in every hour, so if there's any error with my site, I get noticed about it. The problem is I also get errors like this: [Xxx Xxx xx xx:xx:xx.xxxxxx ...
0
votes
1answer
293 views

Apache - Loading is very slow after inactivity. Most states of connections are in K - KeepAlive

I enabled the apache status module, and saw that most of the connections on the apache scoreboard are showing a "K" value. On my server, when I enable KeepAlive, during inactivity it takes a ...
0
votes
0answers
40 views

ElasticBeanstalk and CodegeIgniter

I'm trying to get a code igniter (PHP) site working on Elasticbeanstalk using apache. When i run it using nginx, everything works fine, but with apache, i get the following error: var/www/html/....
0
votes
1answer
149 views

Accidently deleted opt/ folder missing lib librh-php72-php7.so

I accidentally deleted my opt folder. By reinstalling the missing software, i get most of the stuff running. However /opt/rh/httpd24/root/etc/httpd/modules/librh-php72-php7.so is still missing for ...
0
votes
0answers
18 views

How to install a package, which is running only on PHP 7.2, but has default php-mysql as dependency, on Debian Buster?

How can I install a package, running only on PHP 7.2, but having just php-mysql as dependency, on recent Ubuntu (or Debian)? I've added the deb.sury.org repository for PHP, and installed php7.2-mysql ...
0
votes
2answers
571 views

Why a PHP module is not loaded into PHP?

Showing my case how to debug the problem, that a PHP module is not loaded into PHP. I use OpenSUSE v42.2 Linux OS, with Apache webserver, PHP v7.1, Mysql. Because it does not provide PHP v7.1 I need, ...
0
votes
1answer
341 views

Trying to install php 7.3 with httpd 2.4 on centos 6

I have CentOS6-equivalent systems (Amazon Linux original, not Linux 2) that I upgraded to Apache httpd 2.4. Now I want to upgrade PHP from 7.1 to 7.3. As far as I can tell, the Remi repo only provides ...
1
vote
0answers
38 views

Passing REQUEST_URI php-fm after a rewrite in Apache

We are trying to migrate an installation to Apache event engine replacing mod_php for PHP-FPM. We have a large an complex list of rewrites performed by apache from old urls and also to produce SEO ...
2
votes
1answer
414 views

PHP/FPM/Nginx Issue: Runs fine for a hours, then maxes FPM children in a matter of seconds, resulting in 502 errors

We recently migrated a long running (without issue) Ubuntu 16.04 / nginx (1.10.3) / PHP 7.0 stack over to an Ubuntu 18.04 / nginx (1.14.0) / PHP 7.2 stack. The result has caused instability at the PHP-...
0
votes
1answer
350 views

How can I set PHP 7.2 under Debian 10?

I'm trying to install phpBB and am getting that PHP 7.3 is too new to be supported, with a suggestion of downgrading to 7.2. Am I correct that I want to downgrade PHP to 7.2, and if so, what are the ...
3
votes
1answer
188 views

How Apache Limit POST are set to accept Strictly local service Request?

I am trying to harden an Apache 2.4 Web server running 2 wordpress sites with separate vhost settings. Deployed on Windows 2012 r2. I was hacked a few weeks ago and the server was completely lost. On ...
1
vote
0answers
29 views

install php5 but keep php7

I have upgraded, built a new one, my server (Ubuntu 18.04.6) which is running PHP Version 7.2. I would like to install PHP5 and keep PHP7 and have the option to switch back and forth. Have a site that ...
0
votes
2answers
78 views

Uploads failing with no reason

I've been trying to discover a problem on my webserver which simply makes the upload of files fail. I also created a simply php script to test the upload, and when uploading it fails but I don't get ...
0
votes
0answers
82 views

Unable to install mbstring for php7.1 on server running multiple PHP versions

My Centos6 webserver is running php 5.6 and php 7.1 (webmin/virtualmin). I already have mbstring installed for php 5.6, but I also need it for 7.1. When I do yum install php71w-mbstring I get the ...
0
votes
3answers
3k views

PHP files displayed as text

When I want to execute a php file it's displayed as text in my browser. I have a VPS at Hostinger I installed Ubuntu 18.04 with Webmin and LAMP(installed automatically). I checked the installation ...
0
votes
0answers
195 views

Schannel connect / MS SQL Server 2014 SP 3 / Win 2008 R2 / PHP sqlsrv_connect -> TLS Error

I have updated from Ubuntu 19.10 to 20.04 and all had gone well other than the following issue, possibly caused by 20.04 requiring TLS 1.2(?). I have updated MS SQL to the latest service pack with ...
0
votes
1answer
1k views

Install php extension for php 7.3 on centos 6

I have used, yum install php-pecl-zip Im getting the following error, Loaded plugins: fastestmirror, replace Setting up Install Process Loading mirror speeds from cached hostfile * base: centos....
0
votes
0answers
40 views

Wordpress website hosted on nginx ubuntu isn't loading anymore

I just found out the Wordpress website isn't running anymore. When opening example.in, it simply shows the text Error establishing a database connection. The wp website is the folder /var/www/...
-1
votes
2answers
527 views

crypt(): No salt parameter was specified. You must use a randomly generated salt and a strong hash function to produce a secure hash function [closed]

I'm getting the following password error. I have PHP 7.2 variant(to php version 5.5 does not appear to me this problem ), the following code : function make_key($length) { $valid_chars = '...
0
votes
0answers
97 views

PHP not loading specific extension if relative path is specified

I have a specific extension that won't load if I specific a relative path in the extension_dir parameter. If I specify an absolute path it gets loaded. I can't use absolute path because I often need ...
0
votes
0answers
235 views

continous session error messages on fresh cacti 1.2.12 install

I've just installed cacti-1.2.12 from source on a Centos 8. After completed the installation, always that I change among tabs, cacti logs show: 2020-05-07 19:28:17 - CMDPHP PHP ERROR WARNING ...

1
2 3 4 5
7