2022 Developer Survey is open! Take survey.

Questions tagged [postgis]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
112 views

Trying to install postgis on Centos 6.9 and missing dependency libgeotiff.so.2 [closed]

I'm trying to install Postgis 2.1 on Centos 6.9 (and postgresql 9.5). I try to yum install it: yum install postgis21_95 And get the error: > Finished Dependency Resolution Error: Package: gdal-...
user avatar
0 votes
1 answer
82 views

Can't compile GDAL 3.2 on CentOS/RedHat 8

I've been trying to compile GDAL 3.2 on CentOS 8 (due to a java project requiring gdal bindings that should be provided by gdal32-java), however rpmbuild fails right at the start before I make any ...
user avatar
0 votes
1 answer
191 views

postgis installation on linux

I'm trying to install PostGIS extension on arch Linux. here tried so far as archlinux wiki about PostGIS : sudo pacman -S postgresql-libs postgis sudo systemctl restart postgres.service and go to ...
user avatar
1 vote
0 answers
157 views

OGR FDW only works with UTF-8 databases, postgis install

I try to add postgis extension on postgresql95. I use centos7 I follow this link to install postgis: http://www.postgresonline.com/journal/archives/362-An-almost-idiots-guide-to-install-PostgreSQL-9....
user avatar
2 votes
2 answers
519 views

PostGIS on Fedora27

I'm trying to get PostGIS installed on Fedora27 and Postgres 9.6. When doing this on Windows, I can just use the Stack Builder, but that doesn't appear to be a utility available on the Fedora ...
user avatar
  • 121
0 votes
0 answers
222 views

Geonode install at Google Cloud Platform

I trying to install 'geonode 2.6' at Google Cloud Platform. Now I already open all my firewall port for geonode server which hosted at Google Cloud Platform. Even thought, it was not move an inch at ...
user avatar
1 vote
2 answers
2k views

CREATE EXTENSION postgis fails with /usr/lib/libgdal.so.1: undefined symbol: sqlite3_column_table

Problem: postgres=# CREATE EXTENSION postgis; LOG: statement: CREATE EXTENSION postgis; ERROR: could not load library "/usr/lib/postgresql/9.5/lib/rtpostgis-2.3.so": /usr/lib/libgdal.so.1: ...
user avatar
  • 141
5 votes
3 answers
4k views

Upgrade PostgreSQL 9.5 to 9.6 with PostGIS - pg_upgrade

I'm trying to upgrade a 9.5 server to 9.6, and pg_upgrade gives me the following error: Performing Consistency Checks ----------------------------- Checking cluster versions ...
user avatar
0 votes
1 answer
326 views

How to install Postgis with Osm2pgsql on NixOS

When installing PostGIS on NixOS with an expression like services.postgresql.extraPlugins = [ (pkgs.postgis.override { postgresql = pkgs.postgresql94; }).v_2_1_4 ]; How to add other extensions ...
user avatar
  • 553
7 votes
1 answer
2k views

Cannot upgrade postgresql 9.4 -> 9.5beta2 after postgis 2.1.6 -> 2.2.0 upgrade

Here is my situation: I started with Postgresql 9.4.5 and Postgis 2.1.6. Everything running smoothly. Both are installed from source. I upgraded Postgis to 2.2.0 (download source, configure, make, ...
user avatar
  • 201
0 votes
0 answers
777 views

How to install Nomtimatim in postgresql (windows)

I am trying to do geocoding in the postgresql, and I have already installed TIGER geocoder successfully. Then, I want to use Nomtimatim in postgresql. However,since the installed guide (http://wiki....
user avatar
4 votes
1 answer
9k views

Postgres on OS X can't find postgis extension control file

Using mac OSX Yosemite 10.10.1. I uninstalled and re-installed both postgres and postgis with homebrew. I understand that postgres is looking in the wrong place for the postgis control file. Also ...
user avatar
  • 201
1 vote
0 answers
1k views

libc/libcstdc++ issue - GLIBC_2.18 not found

After some package update on my Debian (Sid) machine I started to experience errors like: Error message from server: ERROR: could not load library "/usr/lib/postgresql/9.1/lib/postgis-1.5.so": /lib/...
user avatar
  • 33
1 vote
3 answers
1k views

How to install deleted port on FreeBSD

I am maintaining a code base that depends on Postgis 1.5. My local dev VM is running FreeBSD 9.2. I have recently been tinkering with packages and inadvertently deleted postgis, so I attempted to ...
user avatar
0 votes
3 answers
2k views

Apache: 403 Forbidden for WSGIScriptAlias

I am trying to install istSOS following these instructions from the website: Installation Install PostgreSQL $ sudo apt-get install postgresql postgresql-client postgresql-contrib pgadmin3 Install ...
user avatar
  • 77
3 votes
1 answer
962 views

Install postgis on ubuntu 12.04.4 LTS

I am trying to install postgis on ubuntu Ubuntu 12.04.4 LTS. I search the repo and find a package called postgresql-9.1-postgis. I then installed it: sudo apt-get install postgresql-9.1-postgis It ...
user avatar
8 votes
2 answers
5k views

Why is Postgres sitting 95% idle, with no file I/O?

I have a TileMill/PostGIS stack running on an 8 core Ubuntu 12.04 VM on an OpenStack cloud. It's a rebuild of a very similar system which was running nicely on very similar hardware (same cloud, but ...
user avatar
1 vote
1 answer
90 views

How to apt-get install a package for Ubuntu Quantal from Ubuntu Precise 12.04

On Ubuntu Precise 12.04, the package osm2pgsql is currently at 0.70.5+r25090-2ubuntu2. However I need to install a newer version 0.80 but apt-get update does not provide the newer version. Question: ...
user avatar
  • 1,429
1 vote
1 answer
1k views

Failed dependencies: POSTGIS RHEL6

I am attempting to install POSTGIS on RHEL6.3x64. To do this I used the following steps installed epel-release-6-7.noarch.rpm yum install postgis There was a dependency issue and would not install. ...
user avatar
  • 13
1 vote
1 answer
767 views

Django, PostGIS, Postgres on Mac OS X Installation Issues [closed]

So the context Django1.4.x doesn't support postgis2.0 (https://code.djangoproject.com/ticket/16455) Postgres9.2x doesnt support postgis1.5 (http://trac.osgeo.org/postgis/wiki/...
user avatar
  • 753
4 votes
1 answer
4k views

Contrib directory in PostgreSQL 9.1

Where is the contrib directory in PostgreSQL 9.1? This source states its at /usr/share/pgsql/contrib but the directory /usr/share/pgsql does not exist. I installed PostgreSQL from the rpm, on a ...
user avatar
  • 1,429
1 vote
2 answers
4k views

Dependency issue installing PostGIS on CentOs 6.3

I am new to linux and is trying to install PostGIS2 after successfully installing PostgreSQL 9.1. The machine is running CentOS 6.3 and has cPanel installed. Problem: When I tried installing PostGIS ...
user avatar
  • 1,429
1 vote
1 answer
2k views

Configuration Tuning for PostgreSQL 9.1 PostGIS 1.5 Ubuntu 12.04 Server

My server performance is poor. At times SSH, top, and other features or commands are very slow to respond, taking several seconds or more. A query that normally takes 5 minutes can sometimes take 30 ...
user avatar
  • 121
7 votes
1 answer
4k views

How to import a dump in Postgres from a newer version?

We have a postgres-databse under windows, that is version 9.1. From that we want to dump the data and import under a Linux-server, that runs Postgres 8.4. The data include spatial data with Postgis. ...
user avatar
  • 1,035
9 votes
2 answers
2k views

How to scale out OpenStreetMap data efficiently

For over a year now, I'm running an in-house PostGIS server filled with OSM data, used for both Mapnik-based tile generation and Nominatim-based geocoding, updated with day replicates. This works ...
user avatar
  • 243
4 votes
0 answers
204 views

Ignoring maturity, which database would be better for storing spatial data? [closed]

I am looking to store possibly millions of spatial locations. I will need to do queries like "hotels within 10 miles of [lat,lng]". I've had a little experience with MongoDB in this regard and was ...
user avatar
  • 243
3 votes
1 answer
2k views

Using PostgreSQL 9.0 and PostGIS 1.5 on Debian Squeeze

I have installed PostgreSQL 9.0 (postgresql) and PostGIS 1.5 (postgis) from Debian Backports on my freshly installed Squeeze (stable). However, when trying to create a PostGIS-enabled database, I ...
user avatar
  • 307
0 votes
1 answer
840 views

installing PostGIS PostgreSQL 9.1 on windows

Trying to follow these instructions however there is no "Spatial Extensions" in the "Application Stack Builder".
user avatar
4 votes
2 answers
813 views

Installing Nominatim Pre-Indexed Data

I am trying to install nominatim using this guide. After one day of processing, I finaly get this message: feature 895(k) Killed After a read in dmesg I got: [143978.925793] Out of memory: kill ...
user avatar
  • 616
3 votes
1 answer
2k views

Setting up PostGIS on Ubuntu 10.10

I followed this manual: http://www.paolocorti.net/2008/01/30/installing-postgis-on-ubuntu/ I installed using aptitude: postgis postgresql-8.4-postgis but there is no script lwpostgis.sql in the /...
user avatar
  • 249
0 votes
1 answer
286 views

GeoServer in Tomcat doesn't get update shapefiles from PostGis

I have two GeoServers running in the same machine Ubuntu Server 9.04. GeoServer V2.0.1 is running with Jetty and another GeoServer V2.0.0 is Tomcat. Both of them are using the same PostGis datastore. ...
user avatar
  • 2,411
0 votes
1 answer
580 views

Suggestions for hosting Java EE App.(Tomcat,Glassfish) and Postgis

Which company offers the best services for hosting the above app?(Preferable tomcat and postgis)
user avatar
0 votes
2 answers
805 views

Setting up PostGIS on Ubuntu Server 9.04?

Ubuntu Server 9.04 comes with PostgreSQL 8.3 installed. This is working correctly; I am able to log in, list the databases, etc. I have tried to follow the instructions here for installing PostGIS, ...
user avatar
  • 1,025