Questions tagged [powershell-v7]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
-2 votes
0 answers

Warning: PowerShell detected that you might be using a screen reader and has disabled PSReadLine for compatibility purposes. On visual studio

Warning: PowerShell detected that you might be using a screen reader and has disabled PSReadLine for compatibility purposes. If you want to re-enable it, run 'Import-Module PSReadLine'.In Visual ...
SWARAJ SINGH's user avatar
0 votes
0 answers

Powershell Linux - Unable to install Module in Azure Ubuntu

I'm trying to install the AZ module in the Ubuntu powershell of an Azure Linux server. However, the powersheel could not find the PSGallery repository. I suspect the DNS record retrieved by the server ...
Nash A's user avatar
  • 1
0 votes
0 answers

Access multple tenants as Global Administrator with principal from single tenant (PowerShell 7)

My goal here is to be able to use the service principal of an Enterprise Application in source tenant to authenticate towards/connect to destination tenants as Global Administrator. In source tenant I ...
Tedd Hansen's user avatar
0 votes
0 answers

PowerShell ForEach-Object Parallel RAM Memory Keeps Growing

Using PS 7.3.4 The code works fine without errors. Issue - the RAM consumed by the script keeps growing. How do I release the RAM? How do I see what is consuming the RAM? Any suggestions will be ...
Mike T's user avatar
  • 493
0 votes
1 answer

Error when importing certificate via PowerShell to Local Certificate Store. Missing PrivateKey Information

I have have tried the following ways to import a certificate to the localmachine store via PowerShell. The console was running as administrator. Import-PfxCertificate -Exportable -Password (secure....
Jessie's user avatar
  • 182
0 votes
0 answers

How to connect to a computer with custom WinRM port using Windows Admin Center?

My remote computer has a custom HTTPS WinRM port, I can connect to it using Enter-PSSession just fine and everything works as expected, but don't know how to do it in Windows Admin Center, couldn't ...
user avatar
0 votes
0 answers

Accessing remote database from Windows machine

I tried to connect to a remote MySQL instance from my script in WSL2 but it always failed. I tested using the following command Test-NetConnection -ComputerName -Port 3306 from PowerShell v7 ...
Dorklord's user avatar
  • 101
1 vote
0 answers

How to mount a Windows UNC Path on ubuntu using PowerShell Core

Background: I have an ubuntu machine that hosts a couple applications that I am in charge of and I want to automate the backup of the database that powers these applications. I noticed that ...
Jeffrey Quinn's user avatar
0 votes
1 answer

How to update Azure AD MS Group Mail and ProxyAddresses field using PowerShell

I need to update email address domain for all Azure AD Groups (of all types Unified, Dynamic ... ) and I am using PowerShell 7 with latest stable AzureAD module. I have an issue with setting new value ...
Hrvoje Kusulja's user avatar
0 votes
1 answer

Linux servers stopped being able to use PowerShell remoting over WinRM using NTLM on remote Windows Servers

So basically we have a team with Linux servers running PowerShell Core (a mix of 6 and 7) that have to execute remote Windows PowerShell commands on Windows servers. Problem is, the team never got ...
codewario's user avatar
  • 548
1 vote
0 answers

Remote Windows Update using Powershell to a air-gapped server

My setup has a Windows 10 Desktop that runs "Windows Admin Software" to manage a directly connected Dell Server. This set up is functioning smoothly. The Desktop is connected to Internet. ...
quasar66's user avatar
  • 109
3 votes
1 answer

PowerShell 7.0 / 7.1 and .NET runtimes

A Microsoft Doc has a table for required versions of .NET Framework for PowerShell versions 3.0 to 5.1:
HeadInCloud's user avatar
1 vote
1 answer

How are PowerShell and .NET runtimes related?

I understand there is a relationship between PowerShell and .NET, but I can't locate the details via Google. I was able to setup a fresh Linux instance that didn't have PowerShell or .NET, and then ...
HeadInCloud's user avatar
1 vote
1 answer

Unable to get years lapsed difference from a certain date with powershell custom date?

I cannot get the time difference from a certain date using Powershell like below: $Date = '11/12/2001' (New-TimeSpan -Start (Get-Date -Date $Date) -End (Get-Date)).ToString("'yyyy' Years 'MM' ...
Senior Systems Engineer's user avatar
18 votes
2 answers

Cause of Warning: PowerShell detected that you might be using a screen reader and has disabled PSReadLine for compatibility purposes

Steps Launch PowerShell 7 on Windows 10. Actual result PowerShell 7.0.0 Copyright (c) Microsoft Corporation. All rights reserved. Type 'help' to get help. Warning: ...
Bernard Vander Beken's user avatar