Last call to make your voice heard! Our 2022 Developer Survey closes in less than a week. Take survey.

Questions tagged [rc.d]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
262 views

FreeBSD: Cant stop program started by rc.d ("is not running")

I've created a rc script to start gunicorn as a daemon on boot. #!/bin/sh # PROVIDE: gunicorn_appleclue # REQUIRE: DAEMON . /etc/rc.subr name=gunicorn_appleclue rcvar=gunicorn_appleclue_enable ...
user avatar
0 votes
1 answer
88 views

"service my_service stop" is deemed an error whenever a service is in the "stopped" condition already. How to move on despite an error?

I have a bunch of bash commands that are run via ssh: #!/bin/bash CMD=" set -e cmd1 cmd2 # ........ service my_service stop # ......... # some commands here...... # ......... ...
user avatar
2 votes
1 answer
50 views

FreeBSD perform certain task when a new user is created

Is there a way to perform additional tasks every time a new user is created with adduser(8) in FreeBSD? To be more precise, i'd like to create a directory for every new user and map this user with ...
user avatar
  • 41
0 votes
1 answer
83 views

does RedHat EL6 uses systemd?

Does EL6 uses systemd? OS DETAILS here Linux version 2.6.32-642.11.1.el6.x86_64 (mockbuild@x86-027.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-17) (GCC) ) SMP Wed Oct 26 10:...
user avatar
0 votes
1 answer
285 views

I have deleted /etc/rc.d/ dirs, how can I restore them?

I have accidentally deleted /etc/rc.d and /etc/rc0.d folders which resulted deletion of init.d and other related folders. 1.What is the use of /etc/rc.d, rc, rc.d, rc0.d, rc1.d, rc2.d.......rc6.d and ...
user avatar
1 vote
0 answers
395 views

MongoDB rc.d script for FreeBSD

I want to start MongoDB (aka mondgod) as a service under FreeBSD. I have the following in rc.conf: mongod_enable="YES" mongod_config="/usr/local/etc/mongodb.conf" mongod_dpath="/var/db/mongod" But ...
user avatar
0 votes
1 answer
978 views

How to stop httpd and mysqld from starting automatically when booting Fedora 27?

In the olden days, when I don't want mysqld and httpd to start by default when booting my Fedora Linux, I simply go to /etc/rc?.d (where ? is a number from 0 to 6, depending on the running level ...
user avatar
4 votes
2 answers
3k views

FreeBSD rc.d script doesn't start as a daemon

I have developed the following script at location /usr/local/etc/rc.d/bluesky #!/bin/sh # PROVIDE: bluesky # REQUIRE: mysql sshd # BEFORE: # KEYWORD: . /etc/rc.subr name="bluesky" rcvar=...
user avatar
1 vote
2 answers
538 views

FreeBSD: Starting PostgreSQL before other services

I run a python application on FreeBSD that uses PostgreSQL, Nginx, and UWSGI. UWSGI I manage with SupervisorD. My /etc/rc.conf looks like this: ... postgresql_enable="YES" nginx_enable="YES" ...
user avatar
0 votes
1 answer
3k views

Folder /etc/rc.d was removed from Synology NAS [closed]

I was installing the Syncrify package when I created a file to place it in the /etc/rc.d directory, guiding by the following tutorial: http://web.synametrics.com/syncrifyfreenas.htm But, when I tried ...
user avatar
  • 3
1 vote
0 answers
163 views

Wrong PATH in init script on boot

Since the update of the System on my Synology NAS (x86), I have some problems with my startup scripts. The Bash scripts are stored in /usr/local/etc/rc.d. The scripts were executed for sure, because ...
user avatar
  • 111
1 vote
1 answer
398 views

Slackware 10.1 hangs at boot with kernel 3.x

In Slackware 10.1, what happens between rc.S and rc.M during boot? Trying to boot kernel 3.x (tried 3.4 and 3.10) on this box and it hangs right after rc.S finishes execution. 2.6 kernels boot up just ...
user avatar
  • 226
5 votes
2 answers
5k views

How to change rc.d startup order in FreeBSD?

My question exactly same as this question except I want to change services in FreeBSD. I made some research and I found rcorder command which gives full order of services with below paramaters. ...
user avatar
  • 431
2 votes
2 answers
2k views

RHEL4 script on shutdown

I need to backup some files every time I shutdown a Red Hat Enterprise Linux 4. I thought about make it with a script in /etc/rc0.d but shutdown process should wait for my script to finish. So the ...
user avatar
  • 63
0 votes
2 answers
606 views

FreeBSD rc.d scripts do not return to proper shell

My interesting problem is that when running some rc.d scripts they do not actually drop back to the root shell, but leave me at an intermediate shell as the user they're supposed to be running as. A ...
user avatar
  • 121
3 votes
1 answer
301 views

Installing SP2 on SLES 11 overwrote /etc/init.d/boot.local

From what I understand, the file /etc/init.d/boot.local is a perfectly legit place to sprinkle a few extra commands you would like to be run when SLES 11 starts up. However, when our organization ...
user avatar
2 votes
3 answers
2k views

FreeBSD rc.d script doesn't work when starting up

I am trying to write a rc.d script to startup the fastcgi-mono-server4 on FreeBSD when the computer starts up - in order to run it with nginx. The script works when I execute it while being logged in ...
user avatar
30 votes
4 answers
115k views

How to find error messages from Linux init.d/rc.d scripts?

In Linux, I've written some scripts to be executed during boot and played around with the various ways of installing them. For larger scripts I'll put in /etc/init.d and link the appropriate /etc/rc.d/...
user avatar
  • 635
5 votes
2 answers
7k views

How do I automatically start supervisor on boot in FreeBSD?

Is there a pre-existing startup script for supervisord on FreeBSD? If not, is there a good guide for writing rc.d scripts for FreeBSD? I'm pretty new to the platform. Thanks. UPDATE: I now have the ...
user avatar
  • 365
2 votes
1 answer
1k views

Rebuilding /etc/rc?.d/ links

A regular filesystem check on a Debian Lenny system triggered an fsck, and that nuked a handful of links in the /etc/rc?.d hierarchy (unfortunately I didn't keep a list). The system seems to boot and ...
user avatar
  • 856
67 votes
11 answers
176k views

Disable a service from starting at all runlevels?

I have a service foo which currently starts at runlevel 3 and above. How can I stop it from doing so, without using update-rc.d foo stop 3 ., which (if I understand it correctly) would turn off the ...
user avatar
  • 1,571
0 votes
7 answers
4k views

Why isn't my shell script executing on startup

I'd like my openSuse 11.1 server to run a small shell script on startup. I've created a the script and put a symbolic link to the script in /etc/init.d/rc5.d/. Yet, the script does not get executed. ...
user avatar