Questions tagged [ubiquiti-edgerouter]

EdgeRouter is a line of network routers from Ubiquiti Networks.

Filter by
Sorted by
Tagged with
0
votes
0answers
22 views

Why do we lose IPSec connections and can't re-establish them?

We have tens of IPSec connections between our office and customer sites. At the office we use pfSense V2.4.5 as VPN gateway and placing Ubiquiti Edgerouter X devices with the latest firmware on the ...
0
votes
1answer
106 views

Routing LAN traffic from Edgerouter to wg0

So I've read and tried all I could find on the interwebs and I stil can't get my head around this. I'm trying to accomplish something super easy with OpenVPN on my EdgeRouter X that seems impossible ...
0
votes
1answer
35 views

Certificates explanation for VPN Server Edgerouter + IPSec/IKEv2 + Active Directory Certification Authority

I’m trying to setup a IPSec/IKEv2 VPN Server for roadwarriors on my EdgeRouter 6P which has Linux Strongswan 5.6.3 on board, with Active Directory CA as TRUSTED ROOT CA and Microsoft NPS as Radius for ...
1
vote
1answer
45 views

router or reverse proxy - network failure

I have an edgerouter x sfp as the main router to the internet. To this router a server is connected with a reverse proxy docker running called swag eg. letsencrypt which I use to access nextcloud and ...
1
vote
0answers
37 views

Assigning a single public IP address to a VLAN with NAT

I've been assigned to be in charge of our business' networking and am a bit out of depth here. We have a few production services running on multiple servers, currently sitting behind a NAT and a ...
0
votes
1answer
35 views

Allow Outgoing Traffic Through Port

I have the ERL3, and am needing to connect to a couple of MySQL Databases that use port 3306. I have looked at my firewall rules with show firewall > myoutput.txt and port 3306 is not blocked or ...
0
votes
0answers
737 views

IDS/IPS on Ubiquiti EdgeRouter

I have changed my network setup from the default ISP device to an Ubiquiti EdgeRouter (ER-X-SFP) a while ago. Currently I’m planing to switch to an static IPv4 address. From the ISP I would also get ...
0
votes
0answers
71 views

Issue “seeing” all connected devices :Site-to-Site IPsec VPN to USG

so i've tried a search, but could not find anything that fit. This all concerns a Unifi EdgeRouter X SFP and a USG. In the network where the USG is, I have a controller running on a server. I have set ...
1
vote
1answer
33 views

XenServer (Citrix) Management Network Interruption

We have an OOB/management network we use to loginto storage, hosts etc. We're using VLANs to separate out storage, from hosts, to camera's etc. We would like to replace this switch with a new one ...
2
votes
2answers
1k views

Exposing LAN with Zerotier when using Ubiquiti Edge Router X?

So I managed to install ZeroTier with the Ubiquiti Edge Router X via: admin@edgerouter# sudo -i root@edgerouter:~# curl -s https://install.zerotier.com | sudo bash And got to access the Edge OS (...
1
vote
0answers
48 views

Comparable Ubiquiti to Cisco native vlan configuration

I am trying to replace a cisco router with a ubiquiti router. On the Cisco, you don't address the base interface. You only address the vlans. Then, you choose the native vlan and that will match the ...
0
votes
1answer
610 views

Azure P2S VPN routing issue

I set up a Virtual Network on Azure a few days ago and connected our local business Network through a site-to-site VPN Connection with the virtual network. Everything is working fine so far. Then I ...
0
votes
1answer
404 views

Ubiquiti EdgeRouter uses default route over static when responding to ICMP

I need to have a working connection between two router devices and the subnets behind them. Everything else in the setup seems to work except one static route. Here is the basic information about my ...
0
votes
0answers
360 views

New Ubiquiti router potential DNS issues?

We have a SonicWall as our business router for around 50 ish people. Recently it was getting super slow, and it turns out the fans in it died and it was overheating. I've replaced it with a Ubiquiti ...
0
votes
1answer
138 views

DNS/DHCP configuration in /config/config.boot vs. /etc/dnsmasq.d

I have an Edgerouter 4 and I am trying to make sense of the configuration areas for DHCP and DNS, when use-dnsmasq enable is set. I see four places where the configuration can be done: from the ...
1
vote
2answers
3k views

Route traffic between two Azure site-to-site VPN locations

I have a single Azure virtual network gateway running the "Basic" VPN SKU (MainVGW) in "Route-based" mode in the Australia East region. MainVGW has two "Connections" (BR and MH) which are IPsec Site-...
0
votes
0answers
263 views

OpenVPN DNS resolution issue on router (EdgeOS)

I've been using OpenVPN client over vtun interface and all works as expected only if the remote VPN server name (in the OpenVPN config) is the IP address. When I use the DNS name as part of the ...
3
votes
1answer
1k views

Edgerouter DNSmasq send updates to BIND

TL;DR: How do I configure the Ubiquiti EdgeRouter, running DNSmasq or DHCPd, and NSupdate, to send its DHCP leases to a central BIND server? I have a system comprised of a few Ubiquiti EdgeRouter X's ...
0
votes
1answer
5k views

EdgeRouter X as VLAN-only Switch

The Ubiquiti EdgeRouter X (ERX) has a switching chip on board so that it can be used as an L3 switch instead of as a router. I have another router, we'll call it router-core, which is serving an ...
1
vote
1answer
526 views

PXE Server Implementation Issues

I have an ESXi VM running a tftpd-hpa server on the latest version of Debian 9 for the network PXE environment. For testing purposes, I configured another VM to handle DHCP on Debian 9 using isc-dhcp-...
0
votes
1answer
1k views

EdgeOS BGP routes received but not being injected

I'm trying to set up BGP over IPSEC with Google Cloud Platform. The IPSEC tunnel is successfully established, and GCP reports the BGP session as up. EdgeMax router is receiving the routes, but isn't ...
0
votes
1answer
217 views

How can I restrict access (by IP) to devices behind my Edge Router?

I have a Ubiquiti ERPro-8 with some servers behind it. I would like to allow access to those servers, on specific ports. But I would like to restrict access to those servers by IP address. For ...
1
vote
0answers
1k views

OpenVPN works with TCP but not with UDP

I have two sites which I want to connect via an OpenVPN tunnel. I have the setup running using TCP as transport protocol, but as this comes with a performance hit, I want to change this to UDP. But ...
3
votes
1answer
771 views

What is the complement to 'set' in EdgeOS? (How do I check a value in EdgeRouter?)

This question discusses how to set the gui and ssh listening addresses in EdgeOS running on an EdgeRouter. I'd like to check my current configuration before making a change, as well as learn the ...
1
vote
0answers
729 views

EdgeRouter IPSec Site-to-Site fails to come “up”

I've got two Ubiquiti EdgeRouters set up in different locations. I need to setup a Site-to-Site VPN so that everyone has access to the server on one location. This is the network topology: https://i....
1
vote
1answer
2k views

How to handle a Site-to-Site VPN one site behind a Double-NAT [closed]

Goal: Establish a Site-to-Site VPN tunnel between an office and a remote-site behind a Double-NAT connection. (e.g 4G Hotspot with a CGNAT IP) (Remote Site Setup) LTE Modem: e.g Sierra Wireless ...
1
vote
1answer
2k views

unable to install source route - RTNETLINK answers: No such process (IPsec / strongswan)

Basically I'm trying to connect a pfSense to an EdgeRouter via IPsec site2site. (public ip networks obfuscated by '1.2.') [pfsense] <-> [edgerouter] public: 1.2.156.229/30 <-&...
0
votes
0answers
115 views

The Chrome browser can sometimes not reach Google servers with a new router

I have an odd problem which I haven't been able to even find mentioned elsewhere. A while back, I switched out the Wifi access points as well as the router for a small office network. After I did this,...
2
votes
0answers
1k views

Routing public IP addresses to customers in a WISP setup

We have a fibre leaseline with a /29 range for our pfSense WAN port 61.179.145.40/29 So the WAN of our pfSense box is 61.179.145.42 with a gateway of 61.179.145.41. Our ISP has also routed 61.179....
5
votes
1answer
5k views

Disable EdgeRouter Lite GUI on DMZ interface

I'm using the Ubiquiti EdgeRouter in a SOHO network. I've configured it using the "WAN+2LAN2" wizard, without bridging the LAN ports. This sets up the three port router with eth0 assigned to the WAN,...
2
votes
2answers
17k views

Port forwarding to the router itself on Edgerouter

I recently upgraded one of my customers to a Ubiquiti EdgeRouter Lite, which is a significant improvement over their old ISP-supplied router. To reduce the frequency of attacks against the router's ...