Questions tagged [vyos]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
-1 votes
0 answers
11 views

How to response to DHCP interface-mtu (option 26) request?

The VyOS DHCP service cli command supports various options. Just wondering if the service able to response to interface-mtu or options 26?
user avatar
1 vote
1 answer
389 views

VyOS Configuration Issue

I am working on setting up a VMWare lab. I have a physical box with which I've installed ESXi 6.7 on. While I'll be adding many more, I currently have 3 vm's; a Windows 2016 Server with no server ...
user avatar
  • 113
1 vote
0 answers
235 views

TPROXY interferes DNAT port forwarding rules

I'm setting up TPROXY on my VyOS router to forward certain traffic to a local transparent proxy. It works pretty well, until I discovered that all of my DNAT port forwarding rules are no longer ...
user avatar
0 votes
0 answers
752 views

Unable to Ping IP Addresses on VIF interfaces on VyOS

I'm having issues with 2 VyOS routers, not being able to ping IP address on VIF interfaces. Below is the configuration on the router, which is also running BGP (which I've confirmed is working as ...
user avatar
0 votes
1 answer
45 views

Requesting help / assistance on NAT VyOS configuration

i would like to request help / assistance on NAT VyOS configuration. i'm new to it, so please bear with me :) please see link for the sample diagram. https://i.ibb.co/kx1N6pD/NAT.png from the ...
user avatar
1 vote
1 answer
2k views

L2TP VPN connection not working - PAYLOAD_MALFORMED

I am trying to replace an old VMWare server (ESXI 5.1.0) with a new one (ESXI 6.7.0) and to do that we are trying to replicate the setup of the old one. We have another physical server that needs to ...
user avatar
  • 111
0 votes
0 answers
97 views

Vyos VPN from AWS to Cisco

I'm trying to configure Vyos VPN from AWS VPC to Cisco VPN. I'm using prepared AWS AIM images - tried vyos 1.1.7 and vyos 1.2. My Vyos instance is in a public segment of VPC: vyos@ip-10-0-2-238:~$ ...
user avatar
1 vote
1 answer
267 views

Vyatta OpenVPN fails with push-route

we have a router running VyattaOS 5600 5.2R5 and want to set up openvpn to access our private subnets behind that router. Basic VPN setup was successful and connecting works as expected, but when ...
user avatar
  • 75
0 votes
1 answer
218 views

vyos: how does one use an address group in a rule?

I have a (modified) configuration looking like this: When I try to commit, however, I get an error message: "Configuration error: "OUR-SERVERS" is not a valid IP range. I really want to have ...
user avatar
0 votes
1 answer
2k views

vyos - error message "respawning too fast"

Just pulled down the ISO for the latest stable vyos today, 1.1.8, and ran on my Mac under VirtualBox. It emits this message about every 5 minutes: INIT: Id "TO" respawning too fast: disabled for 5 ...
user avatar
3 votes
0 answers
971 views

Route OpenVPN traffic through Site to Site IPSec connection for specific routes

We recently changed our firewall from a Sonicwall 3060 to a Meraki MX100. After changing we discovered that our work for one customer relied on a site to site vpn to their network with outbound nat ...
user avatar
0 votes
1 answer
896 views

Vyos: How to enable prior disabled Nat rules

Vyos ver. 1.1.8 When in configuration mode, you can easily disable a NAT rule by using the "disabled" argument. E.g.: set destination nat rule 10 disabled But how to enable it again ?
user avatar
  • 1
1 vote
2 answers
123 views

Synchronize states of bridge interfaces

We have redundant 10G fiber links to our upstream internet provider in an active/failover configuration. Between our router and the upstream router, we have a pair of firewalls running Vyos in ...
user avatar
  • 1,212
3 votes
0 answers
2k views

Use static IPv6 addresses on a router behind a Comcast Business IP Gateway

I recently got set up with Comcast Business Class internet. Previously, I was using DSL with another provider and had a single static IPv4 address (VyOS). Now I want to get Comcast set up. I ...
user avatar
1 vote
2 answers
2k views

Use 5 static IP addresses without NAT on hosts behind router behind Comcast Business IP Gateway

I have a VyOS router. VyOS is an OSS fork of Vyatta pre-Brocade/pre-Ubiquiti EdgeRouter. It has a DMZ fronting several servers that face the public and a private zone fronting our private WiFi and ...
user avatar
2 votes
1 answer
297 views

VyOS equivalent of "deny unknown-clients" from dhcpd

I'm attempting to use VyOS as a router and move my dhcp server functionality into it. In my current setup, I have a subnet that only allowed statically mapped clients. I can easily get the static maps ...
user avatar
  • 131
0 votes
1 answer
5k views

Can't access LAN devices behind OpenVPN Server

I have OpenVPN running on Ubuntu Server 16.04 (10.122.224.2). On the same LAN as the OpenVPN server (10.122.224.0/24), I have a VoIP PBX (10.122.224.5). Local to me, I have an IP Phone (192.168.10....
user avatar
3 votes
1 answer
7k views

Ping works but TCP doesn't in a bit of an unusual topology

I'll first say that I didn't design this network from the get go, so the topology came as a surprise even to me. There are two subnets (one is our companys and one is our clients) which reside in the ...
user avatar
1 vote
0 answers
915 views

VyOS configuration qos by ip

I have a simple question, VyOS is a bit new to me. I am trying to apply traffic shaper QOS. this configuration works but I would have to repeat it 80 times (class 20, 21, 22, 23....) set traffic-...
user avatar
1 vote
0 answers
274 views

Domain-based instead of IP addresses load balancing in Vyatta

Currently my company has 6 Internet lines (1 Lease line and 5 fiber lines). Only the lease line (eth1) has the static IP address. So, if I want to give users access to secured site (That check IP ...
user avatar
1 vote
1 answer
6k views

VyOS - routing in 2 networks

I do not know how to do routing between Lan#1 192.168.1.0 and Lan#2 192.168.10.0. I tried with static routing set protocols static route 0.0.0.0/0 next-hop 192.168.10.0 distance '1' but I do not ...
user avatar
0 votes
1 answer
2k views

VyOS NAT does not work

We are migrating our Internet Gateway from Cisco to a VyOS router. Our ISP gives us a /29 network on VLAN 2715 from their router (A.B.C.114/29 where A.B.C.113 is their router and the gateway for our ...
user avatar