Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [websphere]

Questions about administering WebSphere Application Server, a commercial Java application serve.

2
votes
3answers
54 views

file link access via email

we have a server where an application is hosted. in our current configuration, our web server (IBM HTTPD) redirects all its requests to the application server (WAS). Now, we want to access a file ...
1
vote
3answers
868 views

How to increase heap size for ws_ant.sh when deploying on WebSphere 8.5 (64-bit Linux)

TL;DR -- How do I give ws_ant.sh and/or the <wsInstallApp> task more heap at runtime? I am attempting to deploy a relatively large (~160-MB) EAR file to WebSphere 8.5 running on a 64-bit Linux ...
1
vote
3answers
1k views

Configure startup order of websphere application withing EAR

Is it possible to define startup order of the WebSphere enterprise application within EAR (some of descriptor/binding files, META-INF or anywhere else)? The procedure described in IBM InfoCenter ...
2
votes
2answers
539 views

IBM WebSphere Application Server SSO does not set REMOTE_USER on Cognos BI 10.2.2

Very similar issue was posted here, I do not believe they are the same. IBM WebSphere Application Server SSO sets REMOTE_USER incorrectly We are running IBM Cognos Business Intelligence Server 10.2....
0
votes
2answers
68 views

How can a URL from my website be hidden?

I have my site which URL is like this: https://test.my.webpage.example And I need to block a URL similar to: https://test.my.webpage.example/weblogic/someApp/someService This is for a application in ...
0
votes
2answers
204 views

Downstream IBM Httpd Server returns 404 only when accessed through another upstream IHS web server

We have a current setup like the following: HTTPServer - IBM HTTPD Server v? WASServer6.1 - WebSphere Application Server v6.1 (Running App "A") The basic communication is as follows on the listed ...
4
votes
1answer
194 views

Tomcat to WebSphere - Server Contexts

I have a line that defines the location of reports and images in my Tomcat setup that has the following data: <?xml version='1.0' encoding='utf-8'?> <Context docBase="/usr/local/app/oid/...
2
votes
1answer
2k views

How do I configure in IBM WebSphere 8.5.5 a data source using Oracle Wallet?

I have a server with a fresh installation of WebSphere Application Server 8.5.5 and I'm trying to configure a data source over a connection using JDBC and Oracle Wallet for SSL. The error message in ...
1
vote
1answer
579 views

Connection Reset Error AxisFault

I'm trying to call a third party web service using axis2. It was working fine before the third party provider made some changes on their server. They disabled TLS 1.0 protocol and the server only ...
1
vote
1answer
558 views

websphere 8.5 war installation fails

I am trying to install a small (4MB) war file in the admin console of Websphere 8.5.5.9 and it fails with the following stack trace in the SystemErr.log: [5/31/17 14:06:28:139 CDT] 00000072 SystemErr ...
1
vote
1answer
907 views

Nginx as reverse proxy with IBM Websphere upstream

I have an IBM WebSphere serving multiple domains: x.x.x.x:8080/app1 x.x.x.x:9090/app2 ... I need to configure Nginx as reverse proxy to serve: app1.example.com app2.example.com Here is my config but ...
1
vote
1answer
38 views

Max connection on a specific Application

I've an application ( that contain some Web Services ) deployed on a Server in a WAS 7 environement. That server host a many application; what I'm looking for is a way to limit the number of ...
0
votes
1answer
53 views

wsadmin - jmsprovider creating duplicate resource without any exception

I am trying to create jmsprovider resource using wsadmin as show below in WAS ND 8.5.5.9 installed version Setting the scope to TestDmgrNode wsadmin>AdminConfig.getid('/Node:TestDmgrNode/') '...
0
votes
1answer
1k views

Cannot start or initialize IBM WebSphere

I am unable to start or initialize IBM WebSphere. I have a clean install of Linux CentOS. I have installed IBMs Installation Manager. In IBMs Installation Manager, I have added repository http://www....
0
votes
1answer
276 views

WAS not processing request hence web are not available

I'm newbie for supporting WAS(Websphere Application Server), currently I'm having issue with my WAS, my WAS was installed under AIX under 2 servers/nodes. While investigating it, I found in our ...
0
votes
1answer
99 views

Diagnosing why apache virtual host has stopped working

We have an Apache (IBM HTTP Server that is a fork of Apache: http://www-03.ibm.com/software/products/en/http-servers) server that runs virtual hosts that listen to port 80, 8000, and others (this for ...
0
votes
1answer
48 views

IBM Cognos Business Intelligence 10.2.1 for AIX yields a lot of 500 Internal Server Errors

I am using IBM Cognos Business Intelligence 10.2.1 on WebSphere Application Server 7.0.0.37 for AIX 7.1.3.45 TL03. Every time my system undergoes a heavy usage period, which currently happens pretty ...
0
votes
1answer
116 views

websphere - dmgr and node agent priority

I frequently see that deployment execution on our development WAS server hangs, while the applications running on it keep on responding to user requests. This leads to deployments taking ages, with ...
0
votes
1answer
164 views

WebSphere 8.5 Application Installation Directory

Where in the Admin Console can I find an application's installation directory? I have installed applications but I have no clue where they were installed to.
0
votes
1answer
53 views

WebSphere breaks connection while servlet continues to work

We have an application running on WebSphere. Requests are often running for a long time (tens of minutes). Our users report that Internet Explorer breaks connection and shows blank screen after some ...
0
votes
1answer
212 views

How do I switch from http to https and back again with an Apache reverse proxy and WebSphere Application Server

I'm running a Spring Web App in WebSphere Application Server (WAS). WAS is listening on port 36500 using https, Apache is listening on port 80 using http. The protocols in use are out of my control ...
0
votes
1answer
1k views

WebSphere Application Server can not start in command line

I installed WebSphere Application server 8.5 trial version, when I try run the startServer.bat in the commmand line, it shows it need a profile,no default profile exist and a profile name was not ...
0
votes
1answer
1k views

-XX:MaxNewSize and other JVM parameter setting in AIX

All, I am trying to adjust our application's memory settings: JVM and Heap adjustments. I also came across -XX:MaxNewSize parameter. Our application runs on a AIX machine which has ample RAM (100+ GB)....
0
votes
1answer
75 views

Amazon Web Service monitoring

I have deployed a web app on an AWS server. I have following questions: Monitoring my websphere app server status capacity monitoring? uptime thru Amazon CloudWatch metrics? Load balancing ...
0
votes
1answer
264 views

What are the ports that should be open between Deployment Manager and Application Servers?

I install Deployment Manager and Application Server on different servers each one exist on different zone as following : 1- Deployment Manager : Web Zone . 2- Application Server : App Zone . What ...
0
votes
1answer
234 views

How I can generate patch from RAD ready to deploy in WAS?

To use update option directly from IBM WAS-ND , I need to generate patch file from RAD ready to deploy ( already packaged ) . Example : After Deploy HelloWord.ear on WAS-ND 7.0.11 , an exception ...
0
votes
1answer
773 views

Writing a Script to Delete JMS Queus in Websphere

suppose I have the following JMS queues "doc/queue1","home/queue2" and "someOtherQueue" added in a websphere process server, how can I write a script to delete them? looking around the web i haven't ...
0
votes
1answer
999 views

How do I tell Websphere 7 about a front end load balancer so that re-directs are handled correctly?

On WebLogic 11G I can use the console to set the FrontendHost and FrondendPort on a server or on a cluster so that re-directs are handled correctly and end up resolving to the front end load balancer ...
2
votes
0answers
226 views

Changing the port that the admin console runs on for Geronimo/WASCE

I am running WASCE version 2.1.1 I am trying to change the default port that the admin console runs on. I have seen it mentioned that default ports can be changed in the config.substitutions file but ...
1
vote
0answers
35 views

Unable to create additional cluster member in IBM WAS ND 8.5.5

I have server1 on a node, and server2 on another node. I created a cluster (OCHCluster1). If I add server1 to the cluster (irrespective of the clone basis I choose), it adds successfully. If I ...
1
vote
0answers
533 views

Monitoring IBM Websphere 8.x via JSR160RMI JMX fails on Windows

I have an AIX Server running Websphere 8.5 Under Administration Services in the Web UI I have configured all the JMX Connectors to be enabled. No SSL or Authentication at the moment, since it's only ...
1
vote
0answers
379 views

How to get Deployment manager hostname and port dynamically in IBM WebSphere Application Server 8.5.5 using shell script in linux?

I need to get the deployment manager hostname and port dynamically in IBM WebSphere Application Server 8.5.5 using shell script.
1
vote
0answers
325 views

Enable Administrative Security on Websphere (localhost)

In the Websphere administration console under Security > Global Security, when I try to tick "Enable Administrative Security", I get the following message: Validation failed: SECJ7724E: Error in ...
1
vote
0answers
316 views

Websphere Application Server and Kerberos Keytab Renewal

I am currently running into an issue with Kerberos ticket expiration from a keytab on WAS 8.5.5.5. The same process works correctly on Tomcat 8, and I believe the primary difference is the JDK / JAAS ...
1
vote
0answers
190 views

Browser shows IIS Error Messages with WebSphere error messages below

I am working on an environment (external) where IIS is the web server and WebSphere is the application server. I have noticed that the error messages (Ex. 403, 404) show both IIS error messages as ...
1
vote
0answers
383 views

How cache OpenLDAP Meta database (for use with Websphere Application Server)?

I have configured Meta database directory on OpenLDAP server for two different Active Diretories and it's work. But now I'd like set cache for this OpenLDAP, but I don't know how. From my slapd.conf ...
1
vote
0answers
1k views

How to limit a webapp to a certain number of CPU cores

I need to set a webapp to run on a certain number of cores/ or all of them, on the server(depending on configuration). The webapp will be running on any one of the following application server's. ...
1
vote
0answers
805 views

How to define mail from and host settings in Websphere 6.1 for Java application

Working with some older WAS 6.1 hosts (fix pack 25), and have a java app that sends mail from one host with a mail from field: nobody@nosuchhost.nosuchdomain.com [mailto:nobody@nosuchhost....
0
votes
0answers
38 views

MQ 9.1 - PAM [Authentication failure]

for QMGR Authentication we use PAM (Websphere MQ 9.1 on Linux CONNAUTH(USE.PAM) all relevant users are in the local usergroup "mqm". That works fine for all but one user. i get the following errors ...
0
votes
0answers
31 views

“Install New Application” tab not visible in websphere application server base

Recently I installed websphere application server base 64bit on centos os and dmgr and node agent working fine but In the console there are not options visible for create server, New application etc ...
0
votes
0answers
136 views

Adding WAS 9 Server in Rational Application Developer 9.6

I downloaded both and created a profile also for WAS 9. I am unable to see WAS 9 option in add server section under server perspective. I read this : How to add WebSphere Application Server 9 to ...
0
votes
0answers
300 views

Issue setting up SSO with Cognos 11 and Websphere Portal

I can't seem to get Single Sign-On working with Cognos. I am trying to setup SSO with IBM Websphere Portal 8.5 and Cognos 11.0.11 with IBM HTTP Server 8.5. I followed IBM's guide to setup Cognos SSO ...
0
votes
0answers
70 views

IHS webserver version from wsadmin script

Please help with getting IBM HTTP Server version from wsadmin (jython) script. The ISC webconsole displays webserver versions but I'm not able to fetch this in scripts. For WebSphere we can use ...
0
votes
0answers
438 views

IBM WebSphere Application Server ND 7.0 installer on a Debian Jessie AMD64 KVM host stuck on generateProfileKey

I am trying to install IBM WebSphere Application Server Network Deployment version 7.0 on an AMD64 KVM VM running Debian Jessie. I cannot start the launchpad.sh script regardless of whether I use ...
0
votes
0answers
103 views

Do I Have To Restart The Entire Cell After Adding A Signer Cert To The CellDefaultTrustStore

I need to add a new signer cert to a bunch of WebSphere 8.5 instances in the CellDefaultTrustStore. After adding the cert do I need to restart the entire cell or just the application servers that are ...
0
votes
0answers
430 views

IBM WebSphere Application Server SSO sets REMOTE_USER incorrectly on Cognos BI 10.2.1

I am running IBM Cognos Business Intelligence Server 10.2.1 (no other extra software products) on WebSphere Application Server 7, both softwares on an AIX server. I am trying to configure LTPA SSO ...
0
votes
0answers
5k views

WebSphere hung threads, how can I track then down?

We have an application running on WebSphere (unfortunately it is 6.1 which is no longer supported, it has not yet been migrated in production to a later version) which becomes entirely unresponsive ...
0
votes
0answers
121 views

linkage error upon starting webapplication on websphere 8.5.5

While I am trying to start the my web application on websphere 8.5.5 it failed with linkage error. But it will work 100% correctly when I restart the websphere from services (if I do stopserver then ...