New answers tagged

0

I think the easiest solution could be to set the action to the https url. <form action="https://<YOUR_Server/post-handler" method="post" ...>


1

HTTP protocol works on top of TCP protocol. HTTPS works on top of TLS. so underlying connections are different. In order to submit your form with HTTPS encryption you would need to upgrade your HTTP connection to HTTPS using "Upgrade" HTTP header. https://en.wikipedia.org/wiki/HTTP/1.1_Upgrade_header HTTP was not designed to encrypt data. Regarding your ...


0

Thanks everyone for their effort to help... I found the problem... there was a redirection in the nginx default in sites-available and in apache2 000-default.conf I deleted it and now everything works if it can help someone else I would be very glad


0

So the solution was quite...interesting. To say the least I'm quite frustrated it has taken this long for me to figure this out but here it is: From what I understand Google owns the .dev TLD and have since required an SSL certificate (https://) to host a domain on a .dev domain. Since I did not have one yet, it wasn't working. So the solution would be to ...


0

Finally I got anwser for that. The only thing I need to provide is VirtualHost for the 80 port. it will be something like this (.ebextensions/myconfig.config). files: /etc/httpd/conf.d/default.conf: mode: "000644" owner: root group: root content: | <VirtualHost *:80> RewriteEngine On ...


0

I only fixed your RewriteRule and added an additional protocol check. If you have different vhosts for HTTP and HTTPS, you can remove the protocol check. Just wanted to make sure there is no redirection loop if you're already on the HTTPS site. RewriteEngine On # make sure we only redirect if protocol is HTTP, remove if not needed RewriteCond %{HTTPS} =off ...


-1

I will move the logic to the load balancer, if it is not possible to replace the existent load balancer, install a small nginx in each Apache server to proxy the connection. [User] - [Load Balancer] - [Nginx] - [Apache] By using nginx as load balancer or reverse proxy you have access to the upstream responses (In your case, Apache), and you can make rules ...


2

Haproxy can reject tcp connections based on dynamic conditions, including the number of servers available on the backend. The config keyword is tcp-request connection. (Link to docs below.) So, maybe put haproxy in front of Apache (I know, I know! Three layers?!?!) or maybe use haproxy instead of Apache. Might look like this (not tested): frontend http-in ...


0

This will probably not work with apache httpd itself. The problem is that your failed application makes apache httpd generate an error. This error only happens when you actually request an URL from that application. Apache httpd needs the URL to decide wether this is an error or not and to get the URL from the client it needs the TCP connection. What you ...


0

Some compatibility problem with mod_mono and new versions of systemd appear to be the culprit, with no dev response or acknowledgement from the mod_mono team: https://bbs.archlinux.org/viewtopic.php?id=243508


1

I recently moved a wordpress site from an apache server which ran it well enough I dont know the TTFB but I decided to change to NGINX for the new server and it works fantastically. My setup for the Fastcgi for the fastcgi_pass this should change to whatever version of php fpm you install. location ~ [^/]\.php(/|$) { fastcgi_split_path_info ^(.+\.php)(/.+...


1

Use the LocationMatch directive, which allows specifying a regular expression as a location, like this: <VirtualHost *:80> ServerName your.server.name (...) <LocationMatch "^/[^/]*"> Require all denied </LocationMatch> </VirtualHost> This will block all access which begins with a /, but does not contain any / ...


1

There are several ways to limit the access to a certain path, but here's one example: Make use of the <Location> tag. For example: <VirtualHost "*:80"> DocumentRoot "/path/to/blah" ServerName blah.blah.blah <Location "/somepath"> Require all denied </Location> </VirtualHost> You could also use the ...


0

you may want to check if there is an environment file. in Debian based systems this would be found in /etc/default/$file (not sure what actual file name is) on CentOS/RHEL based systems it would be found in /etc/sysconfig/httpd... I'm *adding this answer since I had this issue and a format is not an option... So for whoever may stumble across this I had ...


0

It seems the problem got fixed because I ran this command: sudo certbot certonly --webroot turns out I needed the --webroot parameter. Sorry about the trouble, -Rat (Joey)


0

well i somehow solved it, so my router is configurated to ip forward any person who accessing my ip public to the server ip port 80, and there is no configuration to ip forward to port 443, after added that configuration now i can finally access the site via https.


1

Wordpress and similar like to naively assume that only one domain points there. (And also that the protocol is the same on your reverse proxy and backend. You would have the same problem if your apache was using https, and the wordpress was reverse proxied to some other thing (other host, same host other service)). So unless you can configure wordpress to ...


1

Review your mpm_worker_module configuration to determine if you have enough memory to create the configured amount of threads. ( ThreadLimit X ServerLimit ) X ThreadStackSize = Memory_Max (in bytes) <= System_Memory Note: The default value of ThreadStackSize varies on other operating systems. You can check it with ulimit -s in RHEL. Review your /etc/...


0

You can reconfigure Tomcat to listen on some other port, e.g. 8088 and then configure Apache: Any traffic on your http://example.com, http://example.com:8080 and https://example.com:8443 redirect to https://example.com (ie port 443). These won't be passed through to your Tomcat. Only pass through traffic from https://example.com (ie port 443) to Tomcat port ...


0

You've got this config: <Directory /var/www/html> Options Indexes FollowSymLinks Options ExecCGI AllowOverride None Order allow,deny Allow from all AddHandler cgi-script .cgi </Directory> This tells your apache server that files ending in .cgi should be handled as scripts. But you've named your script test.py. ...


Top 50 recent answers are included