59

There are several things you can do: 1. Application Initialization You can use Application Initialization Module which comes in-box with IIS 8.0 you can have something like this in your web.config <applicationInitialization doAppInitAfterRestart="true" > <add initializationPage="/" /> </applicationInitialization> This will send ...


37

We had the same error on a brand new server. The reason was not the default IIS security policy, stored in applicationHost.config, as suggested by the other answer (although we checked that). The reason was that we installed IIS without support for ASP.NET (an ASP.NET 4.5 role)! When we installed the missing support for ASP.NET, our application just ...


15

In my case: The Event Log was empty. web.config wasn't corrupt - verified by using same on local machine / using inetmgr Finally... Checking IIS logs showed a request like this ...Chrome/57.0.2987.133+Safari/537.36 500 19 5 312 The key being: sc-status sc-substatus sc-win32-status 500 19 5 which with some googling pointed me to the ...


11

Had the same question as the original poster but could not find a concise answer, below is the analysis from my research. Application Pool != Worker Process (w3wp.exe) Typically we see a single w3wp.exe instance running for each application pool but technically we can configure a web garden with multiple w3wp.exe instances running. Web gardens... are they ...


9

I'm guessing that you're using WS-Federation? Or at least using the WSFederationAuthenticationModule and/or SessionAuthenticationModule? Both of those modules perform a redirect to match the casing of your application as it's in IIS any time they're unable to authenticate you or verify that you're authorized to get the requested resource. I don't see any way ...


7

Active Directory Federation Services (ADFS) is primarily concerned with authentication. It is not a metadirectory and can't be used to return generalized information from Active Directory. Accessing the Active Directory through LDAP is probably the direction you want to go, as it allows you to both query the attributes of user accounts (and other objects). ...


7

try to put a port in the range 44300-44399 this one hundred port numbers already have a certificate "bound" to them


7

It looks like "Start application pool immediately" controls whether the application pool is "Started" when the World Wide Web Publishing service is started. But a "started" application pool is not necessarily running (meaning there may not be a w3wp process). If an app pool is not "started" then you will get a 503 when you hit a site that uses that app ...


6

It's 2019 and I still couldn't find any documentation for Beanstalk Platform Hooks regarding .NET apps. I ended up doing something similar to your solution. Create a config file in .ebextensions folder. Create a script file that I want to run (either save it in the code, or define/retrieve it as part of the config file in Step 1) Inside this config file, ...


5

It is really, really dangerous to run IIS as a user that has access to all folders in the file system. You are asking to be hacked badly (do you really want IIS to access C:\Windows?). It is better to explicitly grant permission to the user IIS runs under to access the folders you really need IIS to access. If you really must change the identity IIS runs ...


5

Bit late to respond but I will add my findings as I looked around to find asnwer to this same question. "OnDemand": IIS will launch worker process when first request for Web application is received. "AlwaysRunning": IIS Launches the worker process for the application pool as soon as IIS is started OR when application pool is created.


4

The most obvious issue is improper or zero NTFS rights on the web application folder. So make sure the account serving the site has the right permissions. Without proper NTFS rights to the web directory it doesn't matter what you put in the web.config as it will never be read. A quick check can be to give everyone full rights - if the site starts working ...


4

File permissions for anonymous access are set via a special user account called IUSR_<MachineName>. Check the NTFS permissions (Security tab) of both your document root folder and the index.htm file itself. Verify that this account has "Read" access to all of the files and folders that anonymous users need to be able to browse. If this account is not ...


4

Another way to bypass this is to run the following code in your ASP application: Response.TrySkipIisCustomErrors = true; Source: https://stackoverflow.com/a/21271085/238753


3

This appears to be a duplicate of https://stackoverflow.com/questions/434272/iis7-overrides-customerrors-when-setting-response-statuscode , but I'm too new on Server Fault to flag this. My take: I had a similar problem when using Mediawiki on an IIS server box. When you browse to a non-existing page in Mediawiki. It sends back a special wiki page that says ...


3

Our issue was actually that we were using Integrated Windows Authentication which automatically passed the credentials of the logged on user to the server. In order to prompt the user for credentials, we enabled Basic Authentication to pass the login information to the server, which then used the login info and windows active directory to authenticate.


3

This is, as Chrome correctly reports, a path issue. The HTML markup says, for example: <ul class="payment-listing"> <li> <a href="JavaScript:void(0);" title="Visa"> <img src="/Content/NewImages/img-visa.png" alt="Visa" width="49" height="29" ...


2

In my case, the server role was already installed, and yet the static handler served blank pages even for a trivial test site with just a single handler mapping. The fix was to enable the request restriction "Invoke handler only if request is mapped to". It doesn't matter whether I set it to "File" or "File or directory"; as long as the checkbox is enabled, ...


2

Typically speaking your code is going to be deployed on the IIS server. This means your "web api" and website. Quite frankly I don't think your using the correct terms here as what you seem to be saying is that you have a web site which communicates with a web service that then communicates with the sql server for data access. The web service and ...


2

So basically problem wasn't in connection string inside web.config ,it was entity framework's problem. We started to develop our project on localhost and when finished we deployed site on hostgator.com, problem was, entityframework controlled all conection strings, therefore it was useless to change anything at all in web.config. Here is address where we ...


2

The answer can be found on StackOverflow. It ended up being a bug with a hotfix.


2

Two solutions come to mind. The first is a simple frame/iFrame on the Linux website of your client enclosing you ASP.NET www.yourwindowsserver.com/clients/clientXYZ/MyPage. This is simple to set up, but for the more tech savvy visitors of your clients website it will be visible that they're redirected to a second server. The second alternative would be ...


2

I'm guessing they don't provide RDP access. If so, first thing I would do is attempt to ping the sql server, and try to create a system DSN using odbcad32, and verify that the database is accessible independent of the application. If your database is not the only or default instance on the SQL server, you may need to specify the instance name in the ...


2

No of course not, Microsoft have no reason to provide ASP.Net for Nginx. If you are using Windows, then use IIS (or if you must Apache). On Windows, Nginx is very ropey, to quote the manual: Version of nginx for Windows uses the native Win32 API (not the Cygwin emulation layer). Only the select() connection processing method is currently used, so ...


2

As a system administrator who has to deal with maintenance and lifeycle issues I would say no this isn't acceptable as, as you note there may be complications ... Windows development tools have packaging tools don't they? I don't understand why you wouldn't use them. As to performance you will have to test this yourself.


2

Install things properly! People doing stuff like that is the reason I have a couple ancient servers that can't be rebuilt, cant be migrated to another server, can't do anything but pray it never breaks. If you install it properly, I can look in add/remove programs and see, "Oh, it needs X and Y installed". If you randomly copy DLL files around, I can't ...


2

Sorry, I do not agree with my previous poster's. Web Applications need to be able to be installed in various environments, this can be your own server, or it can be a webhoster. On a Webhoster for example, you do not have access to "install" these tools properly, so it is perfectly fine to deploy these assemblies into the bin folder. Please find some ...


2

From my experience, AlwaysRunning and Preload enabled doesn't get much speed up. The most wait time goes on dynamic compilation (which can be fixed with aspx precompile) and loading assemblies into memory and caching.


2

I finally solved this last week. There is a configuration file that is apart of our web application that needs read/write permissions for IIS. On our shared hosting account at GoDaddy, the permissions had been removed for some unknown reason. And when we loaded the application onto the test server, I basically just forgot that we had to reset those ...


2

I notice that your web.config files do not contain any shibboleth configuration, for instance the handler part : <add name="ShibbolethEndPoints" path="*.sso" verb="*" modules="IsapiModule" scriptProcessor="C:\opt\shibboleth-sp\lib64\shibboleth\isapi_shib.dll" resourceType="Unspecified" preCondition="bitness64" /> When I did my initial setup (...


Only top voted, non community-wiki answers of a minimum length are eligible