Hot answers tagged

9

You have to use a 64-bit system to address that much primary memory. The fact that you're able to address anything beyond ~4G is thanks to PAE, which is a way of logically extending the memory map for 32 bit systems. It doesn't scale very far, as you can see. So reinstall with an amd64 distribution, and you will be able to address the rest of your memory.


5

To remove current epel-release use: $ yum remove epel-release $ yum update or $ rm /etc/yum.repos.d/epel.repo $ yum update To install epel-release 6.8 use: $ yum install https://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm $ yum update or $ yum install https://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm $ yum ...


4

You need to uninstall the incorrectly installed package, i.e.: rpm -e zabbix-release You remove packages by package name, not by filename, because installed packages don't have a filename. Of course, this probably won't fix the problem, because you destroyed and rebuilt the RPM database when there was no need to do so, and it is likely there are files the ...


3

First step: Update to CentOS 6.10 plus any subsequent updated packages. v6.5 is really old now (5+ years...). This should also take care of the Kernel and any system services like Apache and MySQL if you used the default packages. If you have installed PHP7 or other stuff via 3rd party means, make sure this is updated as well.


3

Both CentOS 6 and 7 should accept the PERSISTENT_DHCLIENT option within /etc/sysconfig/network-scripts/ifcfg* files .e.g. # /etc/sysconfig/network-scripts/ifcfg-eth0 BOOTPROTO=dhcp PERSISTENT_DHCLIENT=yes ONTBOOT=yes DEVICE=eth0 This instructs the ifup-eth script to run the dhclient without the (default) -1 option if is_true "${PERSISTENT_DHCLIENT}"; ...


3

A systemd timer can be scheduled for an interval respective to system boot/start time with the OnActiveSec=, OnBootSec=, OnStartupSec=, OnUnitActiveSec= options /etc/systemd/system/your-notcron-hourly.timer [Unit] Description=Run Something every hour respective to systemd start time [Timer] OnUnitActiveSec=1h [Install] WantedBy=timers.target


2

I recommend you read PHP Configuration Tips which explain how to switch to FPM and use multiple PHP versions using Software Collections, designed for parallel installation. Official RHSCL / Centos-scl repository provides rh-php70 and rh-php71 collections. Remi repository provides some newer versions (php56, php70, php71, php72, php73) and is also use as ...


2

Since you are using Pound, that is the application which accepts the initial HTTPS request and which must have the certificate configured or "installed". Check its man page on the commands to use (HTTPS listener).


2

Everything is in the base/updates repository libgssapi_krb5.so.2 => krb5-libs-1.10.3-65.el6.x86_64 libdl.so.2(GLIBC_2.2.5)(64bit) => glibc-2.12-1.212.el6.x86_64 libcrypt.so.1()(64bit) => glibc-2.12-1.212.el6.x86_64 As some package are always there (e.g. glibc) Check you are really running CentOS 6.10 # cat /etc/redhat-release CentOS release 6.10 (Final) #...


2

Do it in one step. /sbin/lvresize --resizefs --size -8g /dev/mapper/centos-home Where 8g is the size of the root volume you want to install. Constant size may be acceptable because the size of your new install is predictable.


1

The algorithm change cited as solving those XFS metadata problems is delayed logging, both in that 2012 linux.conf.au slide deck and the LWN write up of it. Commit history of the documentation shows that the experimental flag was removed in 5d0af85. As this was circa October 2010, Linux 2.6.37: xfs: remove experimental tag from the delaylog option ...


1

As a commenter mentioned, you're calling the wrong program. The reboot binary is at /sbin/reboot, not at /usr/bin/reboot. The latter is a symbolic link to consolehelper, which is a wrapper that lets non-root users run the corresponding program in /sbin under certain circumstances. You can see its man page if you're really interested in how it works, but as ...


1

Did you inherit this server? It looks like someone has gone a little crazy with PHP versions and third party repos. Currently your server is using PHP 5.4 from the remi repository, but you have disabled that repo, and enabled webtatic, from which you don't seem to have anything installed. Enable the remi repo, disable the webtatic repo, and try again. To ...


1

You can work out which PCI device owns a disk block device using the /dev/disk/by-path/* nodes, for example: $ ls -l /dev/disk/by-path/* lrwxrwxrwx. 1 root root 9 Mar 2 18:10 /dev/disk/by-path/pci-0000:03:00.0-scsi-0:0:0:0 -> ../../sda lrwxrwxrwx. 1 root root 10 Mar 2 18:10 /dev/disk/by-path/pci-0000:03:00.0-scsi-0:0:0:0-part1 -> ../../sda1 ...


1

sqlite3 now comes in the standard library. You have to update your python. You could use a virtual environment, if you want to preserve the System's python version.


1

From the log, we can understand that we are trying to create a template using a Xen Virtual Machine which is vm8719 and its Operating system is Windows server 2003 R2 64bit. The following fix should help you with solving the errors which are given in the above log. Please note that you have to change the VM name with respect to your VM while executing the ...


1

On RHEL 6, PID files are almost always in /var/run or a subdirectory thereof. This directory is only cleared at boot time. On RHEL 7, this directory is now /run and /var/run is symlinked to it for backward compatibility. The directory you mention, $XDG_RUNTIME_DIR, is used by user processes, not system services. You aren't really meant to abuse /dev/shm ...


1

You can use this area to place pid files, no drawbacks. Actually you can place pid files anywhere your app have write access to. It is a convention to place pid files in certain places, to easily locate them and to not pollute everything around. Additionally, placing files in tmpfs you could be sure there will be no old pid-files after system reboot.


1

Looks like this is a common problem with some older HPE servers. The first thing you should do is update the system BIOS/firmware. If the updated firmware doesn't resolve the problem, you can work around the problem by disabling the ACPI power meter module, e.g.: echo "blacklist acpi_power_meter" >> /etc/modprobe.d/hwmon.conf In pre-3.0 kernels ...


1

Use yum install, not yum downgrade, on packages which can have multiple versions installed. The lowest version package of the same name will be removed if the number of versions has exceeded installonly_limit. You can also yum remove a specific package version if you wish (but avoid removing the running kernel; this usually results in an unbootable system).


1

Check that all the Server blocks have listen directives, otherwise nginx will default to 80 for that block.


1

start-stop-daemon is a Debian-specific script that exists only on Debian and systems derived from it, such as Ubuntu. You won't find it on CentOS, and indeed, it shouldn't be used as it isn't there. You can just start and stop the daemon directly. In the case of node_exporter, the project ships an init script for CentOS 6 which you can use directly. You do ...


1

It's a Firmware feature that can be toggled off Since October 13, 2017, Intel released a version of their driver 2.3.6 that support toggling off the LLDP handling using a private-flag. This is done by executing the following command: sudo ethtool --set-priv-flags <interface name> disable-fw-lldp on replace <interface name> with your interface ...


1

The two I always check on the server sudo chown <username> /home/<username>/.ssh/authorized_keys sudo chmod 0400 /home/<username>/.ssh/authorized_keys


1

As someone might stumble over this question just as I just did: A very simple solution to the problem could be to exchange the SATA cable. I moved an SSD from 2014 into a 2018-ish system and used the old, unshielded cable to connect it. I got exactly the errors and problems described here. They were all completely gone after I exchanged the cable to a modern ...


1

I had the same exact symptoms that you described. To fix the problem all I had to do was fix the DNS server addresses. We had moved the NAS to a new network, which required updating the DNS server addresses. The addresses were statically assigned, but in the QNAP web interface I updated it to automatically assign.


Only top voted, non community-wiki answers of a minimum length are eligible