Hot answers tagged

140

This could also be because of a protocol mismatch. In 2017 Microsoft patched Windows Servers and advised to disable the SMB1 protocol. From now on, mount.cifs might have problems with the protocol negotiation. The error displayed is "Host is down.", but when you do debug with: smbclient -L <server_ip> -U <username> -d 256 you will get the ...


49

On archlinux after a recent package update, I had to add vers=1.0 to my mount options. I'm connecting to an old centos 5 box and up until yesterday I could connect without explicitly stating a version number. CIFS in linux kernel 4.13 now defaults to SMB 3.0 and in kernel 4.14 it tries 2.1 and higher. See this change log.


22

USB-stick at Fritz NAS showed "Host Down" for Ubuntu 17.10: Defining the version (vers=1.0) worked - here's the full string: sudo mount -t cifs -o vers=1.0,_netdev,username=<user>,password=<pwd>,uid=1000,gid=1000 //192.168.178.1/fritz.nas <local mountpoint>


18

I did find a way to do this. Hopefully this helps someone else looking for the same information. On the server, open a powershell then enter this command: Get-SmbSession | Select-Object -Property ClientComputerName,ClientUserName,Dialect For more verbose output: Get-SmbSession | Select-Object -Property *


15

I had exactly the same issue but with Samba 4 exports and Windows 7 clients. It is definitely client side error. After some thorough troubleshooting, I simply added the registry key and it worked like a charm after hitting the F5 button once. Only had to add this registry key: DirectoryCacheLifetime[DWORD] = 0 HKEY_LOCAL_MACHINE\System\CurrentControlSet\...


13

By default, the samba (cifs) package on some distributions doesn't use the hosts file to resolve the name. Instead, it uses the NetBIOS name to resolve to the IP. There are two ways to go about this: Set samba to use the hosts file for resolution. In your smb.conf file, find and modify or create the following line: [global] name resolve order = ...


12

I have the same problem because my password contain comma symbol (i.e. "PASS,WORD"): $ sudo mount -t cifs -o domain=mydomain,username=myuser,password=PASS,WORD //server/share localfolder mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) At first, you should try enable verbose mode (--verbose option): $ sudo ...


11

Not sure why the problem is happening, but as a workaround, have you tried to put something like touch /mnt/windowsbox/keepalive.txt or echo "I am still alive." >/mnt/windowsbox/keepalive.txt to be run via cron every minute? That way the connection should stay active.


10

You can set the local UID using mount options, example below. You can find out your UID by running the id -u command. sudo mount -t cifs -o username=maazza,domain=MYDOMAIN,uid=1000 //192.168.123.2/company-files /mnt/test This will essentially map and override all files within that share to your own local Linux UID, regardless of remote ownership. However, ...


10

Edit: someone from the community has noticed that official update fixing the problem has been released; this link provides a solution: Microsoft released the Update KB4487345 to fix the issue: This update resolves the issue where local users who are part of the local “Administrators“ group may not be able to remotely access shares on Windows 7 SP1 and ...


9

You're probably missing the fact that Offline Files must be enabled on the client side in order for files and programs accessed from the Share to be cached offline. Additionally, only files and programs that have been opened from the Share are made available offline. Simply accessing the Share doesn't cache it's contents in the Offline Files cache.


8

Similar problem after upgrade to ubuntu 17.10, with an old Buffalo Diskstation. Solved by adding in /etc/fstab the "vers=1.0" option: //myWDhostname/partage /media/Partage cifs guest,vers=1.0 0 0


8

Durable handles are part of SMB 2.0 Resilient handles are part of SMB 2.1 Persistent handles are part of SMB 2.2 which is now called SMB3 My main references for the following are: https://wiki.samba.org/index.php/SMB3_kernel_status and although this was originally for Samba3, it has more details: https://wiki.samba.org/index.php/Samba3/SMB2 Durable file ...


7

This configuration worked for me: 137/UDP, 138/UDP, 139/TCP and 445/TCP. Source and additional information at: http://www.icir.org/gregor/tools/ms-smb-protocols.html. So these are the iptables rules for my Samba server: # The router doesn't need SMB access. -A INPUT -s 192.168.1.1 -p udp --dport 137 -j REJECT -A INPUT -s 192.168.1.1 -p udp --dport 138 -j ...


7

Will File Share in Azure (SMB3 under the hood) work? https://docs.microsoft.com/en-us/azure/storage/files/storage-files-introduction Azure File Sync will help with the local “cache” on premises. https://docs.microsoft.com/en-us/azure/storage/files/storage-sync-files-deployment-guide?tabs=azure-portal


6

Sorry if this is a late response (I realise it's an old thread), however I have just discovered there is another possible reason why mount.cifs would say the host is down. I have an antivirus with a firewall and even though I set it explicitly to allow "windows file and print sharing" -- a predefined rule, it was still blocking connections. I had that ...


6

I too encounter this every few months. sudo umount -l is my workaround. https://stackoverflow.com/a/96288/2097284


6

I found this link here which says SMB 2 and 3 is not supported for rhel and Centos 6. It can only mount SMB1. From Centos and rhel 7 this is supported.


6

Replacing the spaces with \040 is actually the right way to do it. The reason why it’s not working for you is probably because there are (forgotten?) quotes after /Restricted: //servername.org.au/ABC/Company\040Services/…/Restricted" /mnt/n-drive cifs id=0,credentials=/etc/samba/login.crt,iocharset=utf8,noperm 0 0 Change that to: //...


5

A little bit late ... But here is the solution: docker volume create \ --driver local \ --opt type=cifs \ --opt device=//server.domain/path/to/share \ --opt o=addr=server.domain,username=myuser,password=mypw,file_mode=0777,dir_mode=0777 \ --name myvolume In some situations the DNS-name did not work, this has been fixed in this PR ...


4

How to set up a CIFS Multiuser Mount CIFS is a session-based protocol. This means that the session runs with the privileges of the user who logged on for the CIFS session. Therefore, the normal way of using CIFS is to mount the shares at user login time with the privileges of the user logging in. This is what the protocol was designed for. Nontheless, the ...


4

My issue was related to: "mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)" For me the solution was adding key to regedit in Window. Below is my answer in other topic: https://serverfault.com/a/619963/237340


4

I received the same error without further ado from a new Samba client, when trying to mount a CIFS SMB network share: mount error(112): Host is down Eventually, it turned out I had previously restricted SMB server access to only a limited number of IP addresses by configuring /etc/samba/smb.conf: # Allow these IP Addresses to connect: hosts allow = 127.0....


4

Same trouble connecting to Synology DiskStation (DSM 4.3). Using vers=1.0 in the mount options works fine. Additionally I had to use the option "noperm" because all files wrongly showed as not readable and writable by the owner.


4

There is a utility on the NetApp website called 'secedit' that helps create a 'security definition file: http://support.netapp.com/NOW/download/tools/secedit/download.shtml A basic file looks like this: cb56f6f4 1,0,"/vol/vol_name/qtree_name/subdirectory",0,"D:(A;CIOI;0x1f01ff;;;Everyone)" This will set 'Everyone / Full Control' as an explicit ACL on the ...


4

I think I found the answer to your problem, see my own question here: Powerbroker Open : Cannot automount CIFS share, where is the kerberos ticket? CentOS 7 uses systemd and the PBIS service is configured to use private "tmp" folders. Unfortunately this leads to a Kerberos ticket created in the wrong directory (it is generated in /tmp/systemd-private-xxx ...


4

Assuming you have an up-to-date version of osmc running, use the following options instead: x-systemd.automount,noauto This results in a systemd automount unit being created. See systemd.automount for more details.


4

More about persistent handles...Persistent handles are available across several servers of the same cluster. When one server goes down for any reason, the client machine can semi-transparently continue using this handle over a connection to another server. That's why the implementation of persistent handles (in contrary to durable and resilient handles) is ...


4

There are at least three different versions of SMB around. The problem is, when you are just mounting SMB with no further option on the Linux kernel and SMBv1 is disabled on the server, then the server will send a TCP RST packet to the client and this results in the error you mentioned. Add this option to your entry in the fstab command and check the ...


3

The SMB1 version of the protocol has been deprecated, however this is the default version used in older versions of mount.cifs, e.g. I have this problem with version 6.2. You can check with: sudo mount.cifs --version If you try to connect to an SMB3 server using SMB1 protocol, you get the Host is down error. The workaround, as described by many other ...


Only top voted, non community-wiki answers of a minimum length are eligible