Hot answers tagged

2

You probably can't configure eth0 as it's a container, not a real VM, and the host controls the network. In a real VM you could create a dummy interface and use that. Since you have a container, this depends on whether the container host has loaded the dummy module (and the chance is pretty close to 100% that they have not). iface dummy0 inet static ...


2

The main problem in terms of caching is that this some form of a broken response (I would think broken NODATA based on the suggested intent). DNS caching is done based on some TTL, for positive responses the RRSet TTL and for negative responses the cache TTL is based on the SOA record in the AUTHORITY section (specifically the TTL used is MIN(SOA TTL, SOA....


2

iptables can do a lot of voodoo to traffic -- look for a redirect rule. And LXC can further muddy the waters with different network namespaces -- ip netns list [root@r510-main ~]# ip -all netns exec netstat -plnt netns: qrouter-a0291178-a7d9-4419-a47e-47d8bdfe6fa2 Active Internet connections (only servers) Proto Recv-Q Send-Q Local Address ...


1

Remove the address= line and put the example.com hosts you want to resolve in /etc/hosts.


1

In your dnsmasq conf file add these lines to forward specific domains to different IPs. server=/domain1.ca/192.168.2.4 server=/domain2.ca/192.168.2.5 And this line to forward to your 'campus nameserver' server=10.0.0.8 If you don't have these two things working yet (forward domain, and forward all else), troubleshoot until you get this piece working. ...


1

This is a long-known bug in Shim/Grub. https://bugs.launchpad.net/ubuntu/+source/shim/+bug/1813541 It occurs in proxy-configurations, where DHCP<>PXE. The shim is TFTP-hardcoded to DHCP and ignores PXE-option "next-server". Since you need a (Microsoft) signed version, you are in the hands of Ubuntu or Debian. But for years now this remains unfixed.


1

DNSMASQ added a caa-record option in version 2.80, released in October 2018 (after the original accepted answer). I'm adding this answer since this is still the top result for "dnsmasq caa" on Google for me. Please note that the previous answer still works fine and is useful for older versions of DNSMASQ! Manual Entry for caa-record --caa-record=&...


1

You're missing the closing : Your line should look like this: address=/:clients[0-9]*\.google\.com:/192.168.10.2


1

You can also set short hostnames in /etc/hosts 192.168.3.99 website1 192.168.3.99 website2 192.168.3.99 website3 192.168.3.100 website4 and tell dnsmasq to expand all names in /etc/hosts to the .devbox domain. local=/localnet/ expand-hosts domain=devbox website3.devbox should resolve. This enables you to define DNS names via /etc/hosts only, which I ...


Only top voted, non community-wiki answers of a minimum length are eligible