New answers tagged

0

dnsmasq responds to the client using a UDP broadcast packet on port 68, which does not make it out of the bridged Docker network unless using --net=host. One workaround is to add a socat listener on the Docker network that forwards to the host: socat: image: alpine/socat command: > UDP4-LISTEN:68,reuseaddr,fork TCP4:172.18.0.1:24000 and then ...


0

Turns out you can use this dnsmasq option --server=10.1.2.3@ethX where ethX is the Ethernet interface to use. I tested it and it works fine.


0

Seems like it was self-induced hell. The whole setup is needed just to work with some environment,requiring catching special names and resolving them into predefined local addresses in 172, which also have to be bound by hand. The latter was done through systemd-networkd via custom file in /etc/systemd/network/; after deleting it everything start working ...


Top 50 recent answers are included